Wifi not working at all

My wifi is not working at all...from the time of turning on my laptop..it's not working ...I am getting delayed for my work ... :disappointed:...
When I am opening my laptop the wifi icon shows absolutely fine but when I open my browser to browse the internet..I can't ..

When I turn off my wifi then the wifi icon shows like these

Hoping to get help soon :slight_smile:

Please turn off the Wifi Airplane Mode:

Some notebook computers also have a Physical Switch that toggles airplane mode on and off. Look around your computer and see if you have one:

Whenever I turn off my wifi then airplane mode automatically turns on ... It has always been like these for me since I installed Zorine ... Problem is I am not able to browse the internet even with my wifi on ....

This shows airplane mode as being on.

You might have some luck with this:

To prevent airplane mode from turning on automatically. Let's first ensure that is solved and you are not in airplane mode at any point.

Then run in terminal:

sudo lshw -C network

and post the terminal output in this thread.

Yea .. I am not in airplane mode rn .... Still can't browse the internet :slight_smile:

Also the following command that you gave me .. run that on the terminal and here is the output :slight_smile:


Your wifi driver is supplied in the kernel.
Can you first try connecting with a working Ethernet Connection or Phone Hotspot and once connected to the net that way, run in terminal:

sudo apt update && sudo apt full-upgrade

You should see the higher released Zorin OS Kernel install during any other upgrades. Once complete, reboot and test your wifi.

USB tethering isn't working as well :slight_smile:

I connected my mobile with my laptop then ..turned on USB tethering option on my mobile while my mobile was connected with my home wifi > this didn't work out :slight_smile:


You normally tether using your mobile data - that is what I had to do when my ISP provided poor service during lockdown. You may need to pay for unlimited data, but depending on data coverage, internet was much faster using hotspot.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.