Yet another WIFI issue

I have a strange issue with a mostly fresh install of Zorin Core 16. After about a week of normal use I'm starting to suddenly see my Wifi connection randomly drop and refused to come back up. The laptop is an HP Envy x360 (15m-eu0033dx) w/ AMD Ryzen 5 5500u w/ integrated graphics. Aside from a few hardware limitations (fingerprint reader) and sleep issues, everything else has been working just fine up until a few days ago.

Wifi connects and works fine for a few minutes, then suddenly disconnects and won't reconnect without a reboot. I've already tried turning off wifi power-saving by editing /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf and changing wifi.powersave from 3 to 2 and turning off random mac addresses to no avail.

inxi shows these values:

me@HP-Lappy:~$ inxi -i
Network: Device-1: Realtek driver: rtw89_pci
IF: wlp2s0 state: down mac: c8:94:02:82:ea:d3
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
IF: enx58ef68133f30 state: up speed: 1000 Mbps duplex: full mac: 58:ef:68:13:3f:30
IP v4: 10.10.1.30/24 type: dynamic noprefixroute scope: global
IP v6: fe80::1aff:f731:ac8:ea6b/64 type: noprefixroute scope: link
IF-ID-1: docker0 state: down mac: 02:42:54:67:8d:24
IP v4: 172.17.0.1/16 scope: global
WAN IP: xx.xx.xx.xx
randy@HP-Lappy:~$ inxi -N
Network: Device-1: Realtek driver: rtw89_pci
Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152

Wired Ethernet via USB-C dongle works fine (I'm using it to post this thread)

DMESG output:

[ 1023.584339] wlp2s0: authentication with 68:d7:9a:75:a1:bc timed out
[ 1034.048933] wlp2s0: authenticate with f6:92:bf:6e:9c:d9
[ 1034.290977] wlp2s0: send auth to f6:92:bf:6e:9c:d9 (try 1/3)
[ 1034.306445] wlp2s0: send auth to f6:92:bf:6e:9c:d9 (try 2/3)
[ 1034.321319] wlp2s0: send auth to f6:92:bf:6e:9c:d9 (try 3/3)
[ 1034.336727] wlp2s0: authentication with f6:92:bf:6e:9c:d9 timed out

Any suggestions on where to look next?

It appears you are not alone in this issue with that chip:

yeah... just seems kind of odd that it worked fine for several days, then suddenly started being weird for no apparent reason (i.e. no updates to OS or no changes to network).

But, I'll follow the linked thread and see if it leads anywhere.

I know some people like this...

2 Likes

WiFi issues were always an issue with Zorin for me.

My work around was to use poweline devices to connect an ethernet cable directly to my laptop - no problems thereafter.

I've just got used to having the cable attached.

1 Like

If you have a smartphone, install one of the apps that tests wireless connectivity such as:
WifiAnalyzer (open source)
and
Who's on my wifi

Before Covid I had intended once retired to run computing business helping people out and on an old Netbook I used a free wifi analysis tool inSSIDer - let's you see what channels neighbour's are using so you don't have a channel conflict.

Other useful resources:

This Linux Mint thread that solved the issue ([SOLVED] WiFi and ethernet dropouts - Linux Mint Forums) was using the command:

 sudo service network-manager restart