Zorin 12.4 acting odd (live disc for 15.2 also not working)

I was given an older laptop preinstalled with Zorin 12.4. I’m not super familiar with Linux, but I know some rough basics. Anyway, I spent a day updating the machine, as it hadn’t been used in over a year. I also spent the day trying to install Steam through Wine and managed to be only partially successful. (Steam loads, but it’s just a black window where my games library should be.) After that, I did a couple more updates and then set the machine aside for a couple days.

Today, I decided to use the laptop to watch a DVD. However, the movie wouldn’t play. I opened the Videos app, and it gave me an error message saying the DVD was unreadable. So instead, I decided to spend some time trying again to install Steam, this time giving up on Wine and installing the Linux version. However, the terminal commands would only start the install process and then it would fail. I right clicked the .deb file and hit “open with software install.” The software installer opened, but it just had a swirling loading icon for a really long time. I closed out and opened the software installer from the start menu, and when it loaded, every icon in it just had three horizontal dots instead of pictures. When I tried searching for apps, nothing would come up. I also have a red exclamation mark in the lower right corner that says “A problem occurred when checking for the updates.” I’m connected to the internet, as I’m posting this from said laptop, so I don’t think that’s the issue.

I had made a live disc for 15.2, so I decided to just install the newest version of Zorin. I put it in and loaded it up, but I wanted to give it a try first to see if it was compatible with this laptop. After connecting to the Wifi, I tried opening firefox, but it wouldn’t load. I then went to the software center to see if I could install anything. I tried two different apps, but both failed to install. I went to try a third app, but then the pictures all did the same thing that happened after I tried installing Steam through the software installer in the 12.4 version: all the pictures turned into three horizontal dots in a row. I tried opening firefox again, but it still wouldn’t come up. When I tried restarting, though, it said that two instances of Firefox were not responding.

I restarted and got back to 12.4. I then decided to try to take a screenshot of the weird dots. However, before I could press the screenshot button, the window vanished. I now can’t get it open again, even when I restart the computer.

So, right now I’m kinda just like… what do I do? I know from past experience that an OS on a live disc can perform much differently than it does after installing, but I’m not sure if it’s worth the risk of installing it when I was getting similar issues on it that I’m already having on the current version of Zorin I’m using. I currently have the core version installed, and the version of 15.2 I have is also core. Should I be using lite instead? It’s not a super old computer, but it came with Windows 7 preinstalled originally, so I guess it’s kinda getting up there in computer years…?

Idk. Any advice would be much welcome. Thanks!

Updated to add computer info:
Lenovo Ideapad Z575

Processor: 4x AMD A6-3400M APU with Radeon™ HD Graphics
Memory: 3497MB (1074MB used)
(Not sure what else to add from my system information report)

Back to basics please! And welcome to the forum! Please can you post Make Model and spec of the beast you are trying to install Zorin 15 to? Thanks.

1 Like


I added the info to my original post. :slight_smile:

I suspect video being an issue as ATi/AMD no longer supply proprietary drivers other than those embedded in the kernel. Also not clear how much memory is also allocated to the graphics chips. I would give Zorin 15.3 Lite a go instead of Core. Alternatively you could give AntiX 19 or MX-Linux 19 a go as uses minimal RAM. I particularly like the latter as you can make changes to the desktop in live mode and tell it to use that layout for the install. :wink:

1 Like

Thanks! If it acts up again, I’ll give that a try. But for some reason, it’s working 100% fine now.

After updating my post, I clicked around on things and restarted a couple times until I got frustrated and gave up. But a little while ago, I decided to see where things were before checking this thread for replies, and now everything works like it was never broken. The red exclamation mark telling me it couldn’t get updates is gone. I got Steam installed plus some games and it all runs flawlessly. Even the DVD that wouldn’t play earlier works just fine now. I don’t know what was wrong and I did literally nothing that I’m aware of to fix it. But I’ll make a Zorin 15.3 lite disc to keep on hand should the laptop start pulling this sort of thing again.