Zorin 16.2 install problem

I don't know what the problem is, but Zorin has updated the 16.2 .iso some days ago, you might want to try that out.

OK - will give that a try - still 16.2?

Download is now named 16.2 r1. and of course has a new SHA256 checksum to go with it.
ref: Uploads of Zorin OS 16.2 r1 .iso files

Great - super optimistic! .. will DL as soon as I see it, and report back :crossed_fingers: will it appear on DistroWatch?

You can download latest 16.2 r1 from Zorin website here: Download - Zorin OS

It is a bit confusing on the download page, as it is still labelled as ZorinOS 16.2, but the actual download .iso files and SHA256 checksums are the Z16.2 r1 release not the original Z16.2 release.

oh .. thanks, downloaded and sadly makes no difference and fails in the same way the 16.2 iso did - such a shame, Ubuntu installer works perfectly but the changes in Zorin just makes it crash for me - I'm guessing its the splashscreen / videomode with the Zorin logo that's causing it.

I am also facing same problem in installing Zorin os 16.2 on my msi laptop(2021 model). Screen becomes black after selecting Zorin try or install option. I am thinking to shift to Fedora 37 which installs without an issue on msi laptop.

1 Like

Try pressing Ctrl+C before that screen pops up (or would pop up, if the process proceeded normally). I've noticed that if I do so, the Zorin integrity check halts immediately, so I believe that keypress is 'cached' until something can read it, and that 'something' is the Zorin integrity check in this case.

1 Like

AWESOME! IT WORKS!!! ALMOST :frowning: the simplest of solutions - I can't believe all the hours spent chasing BIOS settings, different USB's, etc.. etc.. coincidently I did apply the latest BIOS today .. BUT once the install is complete and I remove the USB and reboot - BLACK SCREEN. So Zorin is now installed but won't start! :rofl: maybe I should stick with Windows :face_with_open_eyes_and_hand_over_mouth:

1 Like

Tried nomodeset - tried recovery... but as soon as I hit enter to start Zorin black screen and no drive access. I'm about to give up on Zorin just too much effort to install --- just crazy that I can TRY from USB

Try these:

I suspect your GPU is dropping off the bus.

Yes latest BIOS as of this morning. Tried Hyper on/off. Yes I can choose cores, tried all and set only to 1. Will try ACPI options suggested ... weird thing is it works fine running from USB but dies as soon as I hit enter to boot

Get the Grub menu to come up at boot, then edit the kernel parameters from there, then boot... one of those options in the post above might work for you.

Also, your graphics card (I'm assuming it's the Intel Iris Xe Graphics card?) might need special handling:

So I'd boot into the Zorin OS USB stick, then in Terminal enter:
sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt update
sudo apt install mesa-vdpau-drivers

Then do the install so it can pick up the proper drivers.

If that crashes your system before you ever get to the installation, revert it by rebooting the Zorin OS USB stick, or:
sudo apt purge mesa-vdpau-drivers
sudo ppa-purge ppa:oibaf/graphics-drivers

More information:

No ACPI entries in GRUB, tried adding both at different times boot immediate black screen when I choose boot Zorin.

Tried installing the new drivers -- response was already the newest version (21.2.6-0ubuntu0.1~20.04.2) --- so nothing changed :frowning:

So it's not the driver itself... it's got to be that the GPU is dropping off the bus. Try the other options in that post above, then I'm out of ideas.

thanks for all your suggestions.. I've tried everything and sadly still get the instant black screen and no drive activity as soon as I 'CTRL+X' from in the grub screen.
Its definitely something quirky with my new NUC .. my old i3 installs Zorin fine from the same media but this newer unit will allow me to TRY via USB or I can install Mint no problem - but prefer Zorin.

Happy to keep trying if you think of anything ... or wait until 16.4 releases? unless there is some beta testing somehow?

My only remaining idea is to take some of the memory out, so you've only got 2 GB of RAM when you install... I remember back in the day, I had something similar happen when I was playing around with Linux, and to get it to install, I had to reduce the amount of installed RAM, install the OS, then put the RAM back in once the installation was done. Not sure if that's still an issue, though.

That's what kept me from migrating from Windows at that time. This time, although I had problems getting Zorin OS to install on this machine (because of a particularly stupid UEFI that wouldn't give up on Windows as the default boot until I'd zero'd the drive, and wouldn't let me choose Linux as the default as long as Windows was an option), I decided to stick with Linux because Windows has iteratively gotten worse and worse.

Thanks for your help - I've given up with Zorin TBH. Been running Mint 21 without any issues, now I've got my apps setup I can't really notice any difference although I do prefer the Zorin GUI/style :frowning: hopefully Zorin 17 can be more reliable/less fuss?

1 Like

A strange but happy :slight_smile: outcome - downloaded Zorin-OS-16.2-Core-64-bit-r1 and it installs without any issue whatsoever - using all the same hardware and bios settings (default) and triple booting Win11, Mint and Zorin. The only odd thing was I needed to install grub-customiser in Zorin to change the boot order as it had no effect running from Mint, YAY! success ... no idea how or why but assuming the Zorin-OS-16.2-Core-64-bit-r1 addressed my issue -- thank you Zorin developers -- very happy indeed!!