Zorin 16.2 install problem

Zorin is currently on 5.15.0-52...
Odd. I would have hedged my bets on the kernel...

Well...you can try just to see what you have. It may help someone here to figure this issue out.

lshw -c video

But, this link:

Ubuntu 5.17 oem kernel

Shows, if I understand it correctly, that Intel is supporting up to the Ubuntu 5.17 oem kernal. With all that noted...can you not download the Intel packages and do a custom install during OS installation?

Anyway, you are on 5.15 but Intel is indicating 5.17. It is always a mess.

description: VGA compatible controller
product: TigerLake-LP GT2 [Iris Xe Graphics]
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
logical name: /dev/fb0
version: 01
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=i915 latency=0 mode=3840x2160 resolution=3840,2160 visual=truecolor xres=3840 yres=2160
resources: iomemory:600-5ff iomemory:400-3ff irq:179 memory:603c000000-603cffffff memory:4000000000-401fffffff ioport:3000(size=64) memory:c0000-dffff memory:4100000000-4106ffffff memory:4020000000-40ffffffff

Kernel: 5.15.0-52-generic x86_64 bits: 64 compiler: gcc v: 11.2.0 Desktop: Cinnamon 5.4.12
tk: GTK 3.24.33 wm: Mutter dm: LightDM Distro: Linux Mint 21 Vanessa base: Ubuntu 22.04 jammy

.. got bored and tried 16.2 Lite -- same outcome :frowning:

This leads me right back to thinking Kernel...
Can you try

sudo apt install linux-oem-20.04

Reboot and test...

install within my working Mint environment?

Ah, I see... Sorry, my brain was moving faster than the rest of my brain.

It would need to be installed on the non-working Zorin OS.
But to do so, you would need to be able to fully successfully install Zorin OS, even if you cannot log in once instealled.
You would need to compile the linux OEM 2.04 kernel into the installer...
And the biggest trouble is - I am not sure that it would definitely help resolve the issue.
Mint 21 is using the same 5.15.0-52 kernel that Zorin OS is.
But if the OEM kernel, with its modules, are also oncluded over there, it may describe why it is working.

Sadly I can't even install Zorin :frowning: all good though - appreciate your efforts

I know that I am late to the party and I might be out on deep water here but have you checked that you have the latest BIOS and firmwares for that hardware setup? On my XPS 13 9370 (2018, bought refurbished in august 2022) I (at first) ran into some problems with both Mint (older version) and Zorin 16.1 because of older BIOS and my SSD had the original firmware running which prevented it from being detected by the installers (don't ask me why, I have no idea). I then installed Windows 10, upgraded all BIOS and firmwares available (edit: latest UEFI-BIOS which allowed me to turn off RAID-mode and choose AHCI instead, Thunderbolt, TPM and SSD firmwares) and once those were updated I removed all the SSD partitions with the Zorin installer which now found the hardware correctly and Zorin 16.1 was installed as it should. 16.2 however will not install on my laptop but 16.1 did and was then upgraded through apt-get to 16.2 and is now running fine.

Yep - BIOS is up to date, I've even tried removing the m.2 and using an clean SSD but still the same result.

It now does sound like the Zorin installer reacts to some of your BIOS settings. Figuring out which one (edit: or ones as they collaborate) may be a hassle since the Mint installer does not react to those exact same settings. I my case it was the RST (Intel Raid)-setting, once changed to AHCI, along with shutting off all legacy settings to "force the installer to choose UEFI", I could install Zorin 16.1. Question is how much time you want to dedicate to this?

Your BIOS has a field for IGD Primary Video Port. Options are Auto, HDMI or Thunderbolt. Since you are using an HDMI port, make sure the option is set to HDMI and not AUTO.

On the IGD Secondary Video Port select NONE to disable that port.

Check the Display Emulation, you may need to go from Virtual to No Emulation. Maybe.

The BIOS also has options related to TV HDMI. I would disable all of the TV and TV HDMI options and be certain you are in the HDMI for Monitor and not TV.

Something in the BIOS seems to not be liked by the Zorin Installer. Disabling anything not related to the HDMI port you are on may be a good idea. Sort of force the HDMI to be seen by the installer.

I think this is the glossary for your BIOS. Intel has a lot of info but sometimes you have to dig for it. You did not mention your BIOS so I am going on Intel data.

Intel NUC-AptioV BIOS Glossary

I am going to tag @AZorin and @zorink. The NUC are highly popular for kiosk, POS, etc. uses and if there is an opportunity to fix this then that would be good for Zorin OS.


All done - no difference. I also turned off all audio (DSP/Digital MIC etc.) Thunderbolt Support, and Wireless Charging option.
Couldn't see anything Emulation related?

BIOS is latest PATGL357.0048.2022.0801.1148

I pretty sure I have turned off everything in the BIOS with the exception of what is needed to boot. :frowning:

Optimistically wait for 16.3 and use MINT until then

Also posted on the intel NUC support forum :crossed_fingers:

Well poo! Sorry to hear that BIOS changes did not help but thanks for trying all our suggestions. It is good that you have asked on the Intel NUC forum, perhaps someone there has a solution. Maybe the Zorin Group will come up with something in the meantime?


I accept defeat but man does it sting. Hopefully one day you will figure this out and report back to us.

Will do - the Intel forum hasn't been helpful at all -- pretty much the response I received was it was not a supported OS :frowning:

Which is actually false.
In fact, Intel is one of the stakeholders for the Linux Foundation.

It's how a person squirms out of helping, is all.

1 Like

Yep, it's not a particularly helpful forum at all compared to the multiple attempts and great suggestions to help troubleshoot my issue from this group :slight_smile:

1 Like