Zorin 16.2 on Tablet - after manualy screen roatation, touchscreen works incorrectly

I have a tablet pc with 10,1 screen with Zorin 16.2 installed.
Auto rotation not works at all, but I don't care about it because I am always using it in landscape mode. The problem is, that Default setting is portrait in my case. In this mode , touchscreen works fine and reacts in touched place. But when I change to landscape mode, touchscreen still reacts, but it looks than it gets position from portait mode, being in a landscape mode. In practice, when display is rotated to be landscape ("right") , after touchscreen is pressed on left bottom corner, reaction is like it was clicked somewhere in the center.
Does anyone know if this is fixable ?

Gday @hepos ,
I dont have a touchscreen, but a few things' may help you in the right direction.

  1. Run "software updater" Click on "settings" & Additional Drives "Tab" make sure if any drivers are avaiable that you select the one to match your spec's.
  2. Restart Tablet.
  3. Check DPI/resolution.
    Try downloading " Calibrate Touchscreen ". from the "Software" app.

Note: Also update windows to let it adjust to new dual boot.
Restart after any changes.

Let us know how you go.

@hepos Whilst you are in Software Updater, check your source is set to "Main Server" instead of a local/regional server.

1 Like

Hey All!

I have the same problem with my Lenovo Yoga 530. My touchscreen used to work both on Windows and Linux, I previously used Zorin before, but now I have moved to Linux for good.

So what works:

  • Screen rotation
  • Tablet mode switches off touchpad and keyboard
  • Lenovo active pen works, no issues: I can draw, select, navigate...

What does not work:

  • My finger... :frowning:

Any ideas? I use the main server, no additional drivers were found apart from the wifi driver. And no, it did not work in Windows 10, that was one of reasons I moved to Zorin, because battery management and touchscreen always worked before. Now just battery threshold support, no touchscreen.
There are no settings in the BIOS regarding touchscreen.

Thank you all for your ideas.

OK. What changed from it working to not working, e.g. was there a kernel update that stopped it? If so, try going to "Advanced Options for Zorin" on boot and select an older kernel to try.

My problem is that I don't know what happened Windows. I tried Windows 11, it was working then went back to Windows 10, and one day I have just realized it does not work anymore.
I used Zorin OS first end of 2021 I think, so quite long time ago. Do you think a BIOS refresh could cause this? Is that a possibility?

Are you dual-booting Zorin16.2 and Windows?

From websearch "yoga 530 touchscreen fail after rotation ubuntu 20.04", seems many people reporting Yoga touchscreen issues. Ubuntu 20.04 Touchscreen on Lenovo Yoga - Ask Ubuntu

But I also found same issues reported on Windows before I added "ubuntu 20.04" to search term. If you still have Windows, maybe do a websearch "yoga 530 touchscreen fail after rotation"

Thank you for getting back to me, I did follow the instructions but did not help. Most probably in my case this is due to a HW issue... I read through this post and it seems there are lot of various issue sources. I guess Lenovo did not do a good job here.

Thank you for looking into this. I think I'll let this be, since with pen it does work. :slight_smile:

1 Like

Hi, I have the same issue as OP: my touch screen does not rotate in tablet mode (I have a Lamina T-1010B) and the touch display respond 90 degrees wrong when using my finger in landscape mode. I did the "xrandr -o right" command after installation due to default portrait mode (now it changes as soon as i have logged in after (re)start).

Any (other - I have tried the ones above) suggestions how to fix this (these)?

/John in Sweden

PS. The tablet display worked fine with previous install with Fedora 37, but was too slow, so I tried Zorin 16.2 instead.

There is a bug, now fixed (which would be why it worked in Fedora 37):

As Zorin OS 16 is based on Ubuntu 20.04, you may need a workaround to resolve this issue:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.