Zorin 16 alpha conky install

I'm having serious issues with this. I can start conky from the terminal, won't allow pkexec. When I try to download the manager it says it cannot find it in apt, the teejee2008 repository seems to not have this. I have tried from synaptic, which states that I have conky-all installed, with dependencies, but do not have manager. Tried reinstalling conky-all, which happens without issue. I downloaded the deb for conky-manager.v2.4 amd64, but when I dpkg that it tells me it couldn't complete. Then it's installed, but I'm holding broken packages...looking for node-fs-extra, nodejs and a llb file that are all there. This is confusing me to no end

This one tells you to add a repository for the manager: How to install Conky Manager on Ubuntu 18.04? | Ubunlog

Some people having issues adding the manager: apt - how to install Conky Manager on Ubuntu 18.04? - Ask Ubuntu but I'm hoping the first link's method works for you.

PS - I'm sure you've already tried this but I'm guessing Synaptic's "Edit" -> "Fix Broken Packages" didn't help, right?

no....I had to remove...which failed, then complete removal. Did a reinstall of conky-all after and still no manager. I've been searching google for about an hour and a half for a solution

edit:
as I said earlier, it's not seeing conky manager in the teejee2008 ppa

Sorry, my bad habit again of not reading carefully. Yep, there's a problem. I added the repository and update and sure enough, no conky manager.

and the deb file gives me this error:

irtdev@VirtDevTuf:~/Downloads$ sudo dpkg -i conky-manager_2.4~136~ubuntu16.04.1_amd64.deb
Selecting previously unselected package conky-manager.
(Reading database ... 509010 files and directories currently installed.)
Preparing to unpack conky-manager_2.4~136~ubuntu16.04.1_amd64.deb ...
Unpacking conky-manager (2.4~136~ubuntu16.04.1) ...
dpkg: dependency problems prevent configuration of conky-manager:
conky-manager depends on realpath; however:
Package realpath is not installed.

dpkg: error processing package conky-manager (--install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Errors were encountered while processing:
conky-manager

EDIT:
Again, now I have broken packages to fix... :pensive:

Seems like what some of the guys mentioned on the askubuntu link may be the issue, you need realpath (and your terminal output also indicates that). Try this: Get Desktop Widgets on Ubuntu 18.04 with Conky | Technastic

As I said earlier...all dependencies are installed. This is a screenshot of synaptic with the realpath installed

But conky manager is there, runs, but I have a broken system?!

once I configure it, can I remove the manager without losing my configuration?

My suggestion would be to do a search for all conky files with root as well as home folder and removing all files - and then reinstalling after that. That would remove all configuration files.

Why I'm asking is so I can save the configuration, remove the offending package, and keep the configuration I had set....backup that config if necessary so I don't have to play in config files to set everything

ok...configured conky, copied the .conky folder for backup then removed the manager.

going to restart and see if I need to restore anything.

ok...they stuck around. I thought it was the 64bit I was installing...but it looks like support of this was dropped in ubuntu16.04 because it is very difficult to find a deb package that is later...and I believe it is 32 bit...hence my dilemma. Oh well. I downloaded the git repository, but couldn't compile it because it doesn't have a configure directory. This whole experience has been strange. Not fixed, but livable. Maybe it will be upgraded for ubumtu 20, but I'm not sure. Thanks for trying carmar

I use and install conky like crazy including Conky manager- which I have had running perfectly on each and every build.
For Ubuntu 21.04 and UP, you must use Conky Manager 2, instead.
But for Zorin 15 and for Zorin 16, you only need Conky Manager and conky

sudo apt install conky-all

Then add the repo for Conky Manager

sudo add-apt-repository ppa:mark-pcnetspec/conky-manager-pm9

sudo apt install conky-manager

Select the Manger from your app menu and then checkmark the conky you want to run. On the toolbar, you can access the Text File or you can use a GUI positioning setting that makes repositioning easy.

You MAY need to totally uninstall and remove (as well as any different Repo like the old Tony George 2008 repo) an existing and yes, backing up ~/.conky is all you need to do to save your conky configs.

2 Likes

uh oh...getting this on update after adding that:

Err:20 http://ppa.launchpad.net/mark-pcnetspec/conky-manager-pm9/ubuntu focal Release
404 Not Found [IP: 91.189.95.85 80]

Edit:
and in synaptic I get:

The repository 'http://ppa.launchpad.net/mark-pcnetspec/conky-manager-pm9/ubuntu focal Release' does not have a Release file.

EDIT-2:
The following repository has both versions:
ppa:tomtomtom/conky-manager

hmm.. I forgot you are using the Z16 Alpha, sorry.

Try this one instead for Focal:

sudo add-apt-repository ppa:tomtomtom/conky-manager

1 Like

Thank you Aravisian