Zorin 16 Core - bluetooth not working

I just installed Zorin OS 16 Core on my desktop. I have it on my notebook and bluetooth works seamlessly. However, on the pc, every time I try to turn it on... it doesn't. It doesn't turn on, whatever I do.

Mind you, I am an absolute beginner and don't know much (if anything) about tech. I've tried many "solutions", to no avail.

Please, please help. I need bluetooth for work and college and this is reeealy throwing me off from using the OS.

This was lsusb's ouput:

Bus 001 Device 006: ID 0bda:8771 Realtek Semiconductor Corp. Bluetooth Radio

Doesn't look good...:

You might have success with the following driver from the Arch repos:
https://mpow.s3-us-west-1.amazonaws.com/mpow_BH519A_driver+for+Linux.7z

Extract the file, then open a terminal and change directory to it with the cd command.
Then run

make

sudo make install INTERFACE=all

Weird thing is, this dongle worked on fedora out of the box.

I ran these commands. This was the output. I'll translate, as my terminal runs on my mother language.

image

nick@nickzodia:~/.driverLinux$ make
make: *** No target indicated and no make file found. Stop.
nick@nickzodia:~/.driverLinux$ sudo make install INTERFACE=all
[sudo] senha para nick:
make: *** No rule to process target 'install'. Stop.

This usually means that your terminal is not opened in the proper directory.
If you extracted in your home Downloads folder, open terminal and then

cd ~/Downloads/mpow_BH519A_driver+for+Linux

I had actually extracted it to my home folder and renamed it to driverLinux. I extracted it to Downloads this time, didn't rename, did exactly as you described. Same outputs :confused:

Try with just

sudo make install INTERFACE=all

Instead

I found the problem! There was a folder inside the folder. I had to cd this one in order to run the make file.

It did run, but there were errors. Should I post the whole output here (not TOO many lines), or just towards the end, where the errors are located?

No, please try my suggestion above. I downloaded the file and ran just the one line to test prior to posting it.

I did. The command itself worked, the terminal found the make file and installed it. It's just that towards the last lines there were errors (and now the pc doesn't recognize that there's a dongle plugged in, for some reason)

I hate my life.
Can you remove the dongle, then try the install - then plug the dongle back in?

Unfortunately, the same exact errors occured. I also hate my life

Let me wander off and examine this a bit... In the meantime can you check your blacklist and if you need to modprobe the new driver?

I will, but I might try a new OS. Zorin serves me perfectly well on my notebook, I recommend it to everyone I know and I'll keep being a user, but for someone as technologically inapt as me, doing a lot of probing gets difficult. I also can't get the speakers to work, for some reason. I'll look a llittle further into distros, although I really love Zorin.

Update: bluetooth is working after unpluggling the dongle, restarting the pc, running "sudo make install INTERFACE=all" and plugging the dongle back in. I'm still working on the speakers though. On this part it seems to be a audio outputs issue. I'll hork harder on it and, let it be fixed, keep Zorin as my desktop OS.
I'll also keep an eye on the bluetooth, as it won't necessarily remain working, although working now. I'd say for now the issue is closed! Tysm for your patience and help.

1 Like

I think we can all make this statement. Yet, here we accept our challenges. Maybe we are not as inept as we think we are. You can plainly see in this thread I am no guru and was flying by the seat of my pants with guesswork.
When I used Windows, I was often net-searching how to fix something. It does not matter really, which OS you use, there will always be a moment to fix something in a way new and unfamiliar.
Hey... We landed people on the Moon.
We can do anything.

Have you started a thread on this yet?