Zorin 16 Software Center

Hi guys,

My Zorin 16 's Software Centre doesnt respond on 'Installed' and 'Update' tabs. It keeps showing the loading animation for days. I even used synaptics package manager to re install it. I update my system 2x a day, both from terminal and 'Software Updater'.

Attaching screenshots for reference.

Please suggest me steps to be undertaken to resolve this issue.

Thanks in Advance!!

1 Like

Can you please try:

killall gnome-software

rm -rf ~/.cache/gnome-software

Then re-launch Gnome-Software and test.


Did same as you said.
When i re - launched software, i did took a while to download cache.
And it worked.

Thanks alot


Hello Sir,

The solution you provided worked fine for me. But i need to do it everytime I boot my system up. Can you suggest whats happening here.

Can you please try:

sudo apt update && sudo apt full-upgrade

sudo apt install --reinstall gnome-software && sudo reboot

then test the software store?

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.