Zorin 16: Taskbar disappearing after sleep

It doesn't happen all the time but every now and then when my system wakes up from sleep I am missing the Zorin taskbar.

It's very similar to when windows explorer crashes and the taskbar disappears - everything else seems to be working.

I assume it's just a Zorin 16 bug but how would you go about recovering it? At the moment I just log out and log back in but I was hoping there would be a less destructive way of recovering the taskbar.


1 Like

You might try alt+F2, then entering into the pop up window:


Then hit the enter key to restart gnome-shell.
See if that gets the taskbar and shell working correctly.


Very nice, I'll give that a shot next time it happens and report back, cheers.

1 Like

I also had the same issue. This happens when I had put some video in fullscreen mode and locked pc (or sleep). When computer is unlocked taskbar disappers. Seems like a bug from beta. Refreshing gnome-shell ("r" command as told by Aravisian) brings back taskbar. It may also be brought back by exiting fullscreen video and locking and unlocking pc again. This needs to be fixed. Temporary fix may be to run command r everytime user unlocks computer (Run shell script)

Remember to bug report it. It aren't gonna fix itself :wink:

1 Like

@Storm Good point, but the thread is marked "Zorin 16:....." so I would hope the devs will spot it anyhow.

I have notted the issue during my first week of zorin beta install and had reported to devs using fedback.


Thanks for reporting this bug! We have published a fix for it yesterday.

Simply install the latest updates from the Software Updater and re-log in/reboot to apply the fix.


It's baaaack :wink:
For me anyway...

I'm on 16 Pro, and the bar is gone after it returns from sleep. I installed this OS two weeks ago.

Alt F2 does nothing. Is there another command line patch I can try?

Have you restarted the computer since this started?

Has it happened more than once?

Yes and yes...
It has been happening all this week. The computer starts from cold every morning, and I restart it during my workday to restore the missing bar (although I'm happy to attempt some command line debug or re-install)... so something like 7~8 times now?

You likely have a Gnome Extension that is creating a conflict.

In Zorin Settings > Extensions or in Gnome Tweak Tool > Extensions, disable all extensions except for the Zorin App Menu or other criotical system extensions and then with the majority of extensions disabled, test Sleep and see if panel remains after.

Just to circle back on this, I suspect it had something to do with the Slack app and it's default desire to remain active in the background with an icon in the bar.
I flipped all manner of extensions on and off during weeks of trial and error, and either it was dumbing down Slack which worked - or just coincidental to some updates during this period.