Zorin 17.1 pro cursor issue

With recent versions of Electron that too shouldn't be a problem. Essentially everything from Pipewire Audio/Screen capture, Wayland-Native rendering and Portals are supported. You will only reasonably run into issues when you try using in-development features[1] or older versions of Electron[2]

Also, you no longer have to disable the GPU Sandbox to get it running under Wayland, and since last year you no longer have to manually enable Ozone and Wayland rendering.

Indeed, that is why for Flatpaks of apps with old electron versions these overrides should be setup by default, but for some reason unknown to me, they aren't.

It is explicitly designed to handle those including VRR...???

That is a lack of Nvidia Proprietary Drivers supporting the HW-Accelerated Cursor Layer, and it doesn't happen on either recent versions of GNOME or KDE Plasma as they have overrides in place to disable this on Nvidia Proprietary Drivers.

That just sounds like old Electron with extra steps...? Either that, or I'm missing some crucial context as to what "Chromium Embedded Frameworks" are :thinking:

Wayland supports fractional scaling better than X11 ever could by design. Unless X12 happens, the X Windowing System won't see proper fractional scaling. This was even proven today by another user in the Zorin Forums having issues with scaling on X.

That is again a result of old Electron. Developers should update to support the latest features.

Yes I know this results in worse UX, but no it isn't a Wayland fault.

Interesting, I tried to replicate this running KDE Plasma and...I just couldn't no matter how hard I tried

Seems like a GNOME-Specific issue? I wonder why this wasn't fixed yet either???
Eh, I guess that is GNOME being GNOME again :melting_face:

  1. like Pipewire-Video ↩︎

  2. like what is sadly used in things like Discord. ↩︎

1 Like