Zorin and Windows 10 times don't match

I set up my laptop as dual boot to WIndows 10 and Zorin. I can't get the time to sync so every time I go back to Windows, the time is wrong and has to be reset. I googled it and followed the suggestion to go into my BIOS and change to UTC but my BIOS doesn't appear to give me that option. My time zone at the moment is Tel Aviv, so GMT+3. Any suggestions would be most appreciated.

Same thing happens to me with dual boot Windows 7. This is a Windows issue, not relevant to Zorin.