Zorin app Store, Freezing

Hi, using Zorin Lite.

I wanted to aks this for some time know.

Why does the Zorin app store, which is what I use to search/install/remove apps takes ages to load?

Is there a way to speed up the process? I mean my laptop is pretty old, but I have tried some distro and this app store takes ages to load on my system.


Have you checked this thread?

1 Like

I really don't touch and use gnome-software(the default app store for Zorin OS) anymore bcs I already get used to use the terminal. If only I want to install some software through GUI, I use Synaptic. But, if you want to use something similar to gnome-software with a decent look but with a faster load, I can recommend you to use mintinstall. It's an app store that was built by the Linux Mint team. It only works for .deb packages from your repositories and flatpaks from flathub repository. This is how mintinstall looks like in my system:

But be aware to use install the right version of mintinstall and its dependencies (mint-common, and mint-translations).

Yes I remember that look of the store in Mint.
I am looking for something fast like the install/remove/Upgrade software like I have in Manjaro xfce.
Super fast simple look and no bloat banner ads.
I don't know if its compatible since its an Arch thing with AUR and Snap support.
I already have Synaptic installed.
It's kind of confusing.
I guess I'm used to GUI store.

The Gnome Software store was honestly not great in 20.04 and Zorin basically inherited that. It will get better in Zorin 17 though as it was better in 22.04

This is the GUI of Pacman in Manjaro super simple fast and intuitive:

As I mentioned before the 20.04 version of Gnome Software was never great. It got a lot better in 22.04 which will be in Zorin 17. There is not a lot you can do about it at the moment.

1 Like

Gday @Jesuslinux ,

Try changing the download sever within "Software & Updates" From main to a local sever near you.
Can you tells us your machine spec's?

I believe that is set in the mirrorlist to fastest.
I read some tutorials about it.

I stays in this screen for quite some time:

About the machine specs (please don't laugh):

tSystem:    Kernel: 5.15.0-72-generic x86_64 bits: 64 compiler: N/A Desktop: Xfce 4.16.0 Distro: Zorin OS 16.2 
           base: Ubuntu 20.04 LTS Focal 
Machine:   Type: Laptop System: TOSHIBA product: Satellite L40 v: PSL48E-01T00GPT serial: <filter> 
           Mobo: TOSHIBA model: Satellite L40 v: 1.0 serial: <filter> BIOS: American Megatrends v: 1.50 date: 08/21/2007 
Battery:   ID-1: BAT0 charge: 12.8 Wh condition: 13.2/44.0 Wh (30%) model: TOSASU NS2P3SZPHIWR status: Unknown 
CPU:       Topology: Dual Core model: Intel Pentium Dual T2310 bits: 64 type: MCP arch: Core Merom rev: D L2 cache: 1024 KiB 
           flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 5851 
           Speed: 798 MHz min/max: 800/1467 MHz Core speeds (MHz): 1: 798 2: 798 
Graphics:  Device-1: Intel Mobile GM965/GL960 Integrated Graphics vendor: Toshiba driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.13 driver: modesetting unloaded: fbdev,vesa resolution: 1280x800~60Hz 
           OpenGL: renderer: Mesa DRI Intel 965GM (CL) v: 2.1 Mesa 21.2.6 direct render: Yes 
Audio:     Device-1: Intel 82801H HD Audio vendor: Toshiba driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.15.0-72-generic 
Network:   Device-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter vendor: Toshiba driver: 8139too v: 0.9.28 
           port: c800 bus ID: 05:07.0 
           IF: enp5s7 state: down mac: <filter> 
           Device-2: Realtek RTL8187B Wireless Adapter type: USB driver: rtl8187 bus ID: 1-2:2 
           IF: wlx001644124d02 state: up mac: <filter> 
Drives:    Local Storage: total: 111.79 GiB used: 56.60 GiB (50.6%) 
           ID-1: /dev/sda vendor: Kingston model: SA400S37120G size: 111.79 GiB temp: 31 C 
Partition: ID-1: / size: 34.89 GiB used: 20.63 GiB (59.1%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 3.00 GiB used: 402.2 MiB (13.1%) fs: swap dev: /dev/sda4 
Sensors:   System Temperatures: cpu: 58.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 232 Uptime: 2h 22m Memory: 2.90 GiB used: 1.85 GiB (63.6%) Init: systemd runlevel: 5 Compilers: gcc: N/A 
           Shell: bash v: 5.0.17 inxi: 3.0.38

Actually I was reading about linux commands to show you hardware specs and came across this one:

root@jesuslinux:/home/jesuslinux# dmidecode -t memory | grep -i size
	Maximum Memory Module Size: 2048 MB
	Maximum Total Memory Size: 4096 MB
	Installed Size: 1024 MB (Double-bank Connection)
	Enabled Size: 1024 MB (Double-bank Connection)
	Installed Size: 2048 MB (Double-bank Connection)
	Enabled Size: 2048 MB (Double-bank Connection)
	Size: 1024 MB
	Size: 2048 MB

I thought this ancient laptop from 2007 could only handle 3GB RAM but the command says it can handle 4GB RAM, right?
This is huge news!
I need a 2GB RAM stick now lol !

When the Software store does that for me i close it and wait 30sec & reopen it & all is good again.
I had a lot of this prior, when i had the server on the default "Main Server" , once i changed to local, this only occurs if I'm to quick after bootup.
You may try clearing temp files/cookies/cache.
Next would be to refresh the modem.
Last you could try setting your "Swappiness" to zero, making your machine use the RAM more before swapping.

Please show the results of this:

free -m

I have set swappiness is set to 10.

root@jesuslinux:/home/jesuslinux# free -m
              total        used        free      shared  buff/cache   available
Mem:           2972        1764          96         259        1112         763
Swap:          3071         406        2665

root@jesuslinux:/home/jesuslinux# sudo cat /proc/sys/vm/swappiness

I read in some tutorial to set it from the standard 60 to 10.
Sometime I check htop and it is using swap with enough RAM still (not reaching 90%).

1 Like

10 swappiness is fine, personally id set it to zero.
Clean out thing's & see if it helps.
If the store does this when first opening it again, close it and see if it will work in 30sec time.

You may already do this, but if possible close any apps using the net, may help,More so the browser's are the biggest offender's.

I guess It's because of my old specs.
But the Manjaro pacman store loads blazing fast compared to Zorin.
Was wondering if there is something similar with less "bloat" on banners and suggested apps.


Try looking here;

I'd like @Aravisian ( or others familiar with this) to look at this, as he may have an alternative he uses, or further help with the Software centre app, we're using atm.

1 Like

What you said checks out.
Second time the store loads it's much faster.
It's just that first time that it takes a long time to load.

1 Like

i believe it's a bit of a glitch, but that exactly what happens to me.
I find even sometimes when my machine has been on for a long time this can also happen, so i assume it's a loading glitch, & yes it works perfect on the next load, i have been to quick to restart it again & ended up with the same issue,
Other than that small glitch , i love the software centre.
Hope this has helped solve your issue.

1 Like

The first time, it must gather and check any updates.

I recommend Synaptic Package Manager for GUI package management. I have it installed, but I very rarely open it.
Honestly, I just use the terminal. In the beginning I used the Software Store but quickly switched to Synaptic. But as time went on, the Terminal was just too fast, easy, powerful and efficient to use anything else.
This may seem strange coming from one whose primary interest is in the UI/UX and GUI. But it just goes to show how much of a great utility the terminal is.


Yes I already have Synaptic installed.
I prefer using the store it's less confusing.
I guess that's the purpose of a GUI app store.
It's just that it feel the store could load faster if didn't have to load app banner and suggestions for apps.
Something like pacman app store.
You type what you want and shows the sources it's has. Either official, snap, flat or AUR.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.