Zorin Core 16; install ends with errors (fixed)

Hi all.
Really looking forward to having Zorin as my day to day distro. Spent time on the live version, now trying to install.

Dell Inspiron i7 16gb ram, 1TB nvme drive.

Have also ubuntu studio, ubuntu 18.04 on the sdd, have freed up 250GB for Zorin formatted ext4.
Install goes ok, not as straightforward as other distros I have tried, had to go to 'custom', delete a partition, 'change' to format it ext4 and choose / as the mount point. Also chose my 1TB nvme as the boot device.
Install seemed to go fine until the last moment, then an error box came up saying 'there was an error installing pre-installed software'.
On rebooting, it went to busybox and initramfs prompt.
Any ideas? Have searched the forum, found a couple of instances of initramfs prompt but their probs dont seem to be the same as mine. My hardware is working fine (other distros flawless), can see nothing faulty, but am stuck at this initramfs prompt.
This is the 3rd time I have tried the install today, am now still on the live usb after installing and am unwilling to try rebooting into that prompt again without an idea or two of what to do next..

One more bit of info, above the initramfs promt is a line saying 'SGX not enabled in bios'.

It was all down to SGX in the bios..!

Had it in my head that this was a 32bit thing but no, Zorin Core 16 requires it to be switched it on seems. First distro I have encountered that needs it but hey, whatever works right?

Switched it on in the bios and Zorin just booted right up. Am guessing the error at the end of the install was due to Zorin detecting SGX was not switched on. Worst I suffered was some vigorous head scratching for a couple of hours but am now very pleased with my new distro, am looking forward to playing with it.

One final mention of this, maybe will help someone else having a similar problem. After enabling SGX in the bios and booting into Zorin for the first time, I then did all the updates waiting for me and rebooted again.
This time there was a Dell firmware update waiting for me. I am guessing that this was due to switching on SGX as my bios duly updated after the firmware update.
I had spent some time scouring the net looking for a solution and came across quite a few mentions from Dell owners hitting similar problems with install. Hope the above might give them a idea or two to get through the install ok..

1 Like