Zorin lite added display resolution mode not saved

Hi Community,
I installed Zorin Lite to VirtualBox, to fit the screen I have to setup the resolution with below script:

cvt 1920 975
sudo xrandr --newmode "1920x975_60.00" 155.25 1920 2040 2240 2560 975 978 988 1012 -hsync +vsync
sudo xrandr --addmode Virtual1 "1920x975_60.00"
sudo xrandr -s "1920x975_60.00"

But wonder how to make it permanent so that no need to run script every time after reboot. (it seems the 1920x975 was not saved somehow in the display resolution options.

Thank you very much.

Launch Display from the app menu.
Then in the popup window, move to the Advanced tab.
Under Connecting Displays, check ON "Configure new displays when connected" and "Automatically enable profiles when new display is connected"

Your Current set up is your profile.

Hi Aravisian,
Thank you for your time. I have checked ON both options on the Advanced tab.

Still when logout or reboot, the default logon screen is always 1024768. (maybe this symptom can help debug?)
Also found that after saved the 1920
975 profile couple of times, the profile must be there, but it profile list is showing empty.

Thanks again,

IF you are using virtualbox or vmware in dynamic mode I've found it messes with profiles something with the virtualdisplay driver and dynamic resolutions. its possible that the VM is reporting only limited video modes until the drivers load. Im not sure i never dug into to deeply but i've seen what you are experiencing..

A quick dirty 'solution' is to add the commands to a .sh script drop it in your home folder and add it as a startup item.


Thank you Sean, seems like it. My real old tank T410 works just fine.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.