Zorin Lite will not wake from sleep/suspend

I installed Zorin OS Lite in a laptop but when I close the lid or put it in suspension and then I try to use it it freezes and does not do anything I have to turn it off by force to make it work.
Do you think I have a solution?

What is the make and model of your laptop?

Is a HP Stream 14

This is a long standing and known XFCE D.E. bug.
Will not wake from sleep or suspend.

You can try many things, including from terminal:

xset s 0,0

To prevent the Screensaver from inhibiting the settings. If you have “light-locker” installed, remove it and install

sudo apt-get install lightdm-gtk-greeter-settings

instead. Then use the above installation to set up your LightDM management.
In Power settings, ensure that you have everything set to “never” or “do nothing” for laptop lid close.

THERIUXTV, welcome to the forum. Would you mind an edit to your title to “Zorin Lite will not wake from sleep/suspend” ?

1 Like

Oh thanks then I’ll try it out and see if it works.


While you’re performing the steps mentioned by @Aravisian, will you answer the following?

When you attempt to use your laptop after it going to sleep, do you get a login screen or is the screen just black? Also, do you see your cursor, and can you move it around?


I forgot to mention, would you mind attaching a screenshot of the output from entering neofetch in the terminal? This will give an output of your system specs. The results from running it on my machine is as follows.


If you need to install it, you can do so with sudo apt install neofetch.


Thanks for the help, I already installed Zorin Core, maybe if you are interested in what happened was that I got out of suspension and the menu appeared and I could move the cursor, but when I tried to click some option nothing happened and the only solution I had was to turn off the laptop by force.

Am also having the same issue with my Zorin Lite. Once the screen goes to sleep, am sometimes able to scroll but the screen remains black while other times a login pop up shows up and after entering my details nothing happens.

It says checking… and that’s it. It’s quite stressful hence am left with the option of turning off my laptop by force.

First, a quick link as both of these threads are directly related:

It is a fine line to balance; between those that do not want to hear anything other than a solution - and those who prefer to hear an honest answer.
I am going to shoot for an honest answer:
This is a long standing and known XFCE bug.
There are a great many ‘fixes’. Some work for some users but not for others.
I have been stricken by this bug, too, in past days and often, an update causes the bug to just go away… Sometimes, an update causes it to reappear.
In recent days, I have cycled through all of the known ‘fixes’ to no avail.
As I am not using XFCE on Zorin Lite, but have switched to using Cinnamon, I am not currently affected- but I would be if I logged into Lite or XFCE desktop.

The cause is clearly not really known. It appears to be a conflict between Xwindow, Power Manager and Xscreensaver. Most often, changing the settings of the screensaver or even removing it entirely resolves the issue, though you lose the screensaver in the process (some install an alternate screensaver app). But on rarer occasions, that strangely does not always resolve it.

Zabadabadoo had posted a bit of genius on this forum a while back: A separate app that prevents the screensaver from engaging by tricking the computer into thinking the mouse is moved every few moments. The app is called Caffeine. I am told it is available in the Software Store.
This does not solve the problem in any way. It just prevents the screen from automatically locking and therefor the problem affecting the user.
And, like all ‘fixes’ for this bug, it comes with the caveat that a user can no longer rely on the computer to auto-lock if they walk away from the machine. But it does prevent the problem from arising that results in needing a hard reboot to overcome.

1 Like