Zorin loggin out immediately after loggin back in

I seem to have a problem with Zorin OS(16.3 Core). For some reason, if you have multiple programs open(usually Chrome and another program) and you log in, at the top of the screen you can see your Chrome tabs, but the rest of the screen is the other program, it stays like that for about 2 seconds and then logs back out again. It only seems to do this if you have programs open, because if nothing is open, it logs in immediately and you can go on with your day. It also only does this once, if it logs out like this, you log back in and then everything is fine.

My OS is also completely up to date.

I can not remember exactly when it started(as I thought it was a one time glitch or something) and I don't know if something else is causing it.

Any help would be appreciated!

Can you say what Make and Model you are using?
Also what graphics?

sudo lshw -C video

Have you tried reconfiguring GDM3?

sudo systemctl start gdm3.service

sudo dpkg-reconfigure gdm3

I am assuming by Make and Model you mean the computer. It is a Lenovo Ideapad 130-151kb, but I replaced the RAM to 8GB 2400MHZ and it has an SSD, no HDD.

The graphics is: -display
description: VGA compatible controller
product: UHD Graphics 620
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 07
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:127 memory:b0000000-b0ffffff memory:a0000000-afffffff ioport:4000(size=64) memory:c0000-dffff

(Mesa Intel® UHD Graphics 620 (KBL GT2))

I just tried configuring the GDM3 as you suggested, and after letting it sleep for about 2 minutes it resorted back to it's old tricks.

Thank you again for helping.

There are a lot of things that can cause a Wake from Sleep issue... But I have never seen one where it only does it when different software is open on the screen.

I am hesitant to try throwing potential "fixes" at it without at least a slightly better idea what component is likely at fault.

If you are willing to do some tedious testing:
Does it revert to login screen if the open software is all Minimized to the Panel prior to putting it to sleep?
Does it only happen with specific apps?

It only seems to do it if it is open, i.e. not minimised. I haven't tested it with other programs, so I will let you know in a couple of minutes.

1 Like

I checked with other programs and it also logs out after about 2 seconds...

So any programs, as long as there are more than one and as long as they are active on the screen and not minimized: leads to a login loop or Desktop Crash.


If you use the Zorin Settings tool that handles Gnome Extensions, or if you prefer using Gnome Tweaks > Extensions tab... Can you disable all extensions except for the Zorin App menu.
Then try testing with the open window apps on screen and sleep which all extensions disabled and see if you can replicate the issue.

Could you perhaps give me instructions as to how to disable the extensions? Sorry I am still new to Zorin and Linux in general.

I am using Zorin Lite (XFCE) not Zorin Core (Gnome). So my familiarity is low and I am typing the below based on what I remember of having used Gnome in the past.
So, you may need to review what you are seeing on your screen and kind of follow the road signs a bit with my post as a general guide.

Can you please tap ctrl+F2 to open the launcher, then paste into it:


Scroll down the list to Extensions and select it. Now, select the switch for each extension to disable any that are already enabled.
Remember to not disable the Zorin App Menu gnome shell extension. I am confident it is not causing a crash, and you kinda need that one enabled.

If the above is not working out... Install Gnome tweak tool:

sudo apt install gnome-tweaks

Launch it from the app menu. Again, you will see a tab in the Left Pane for Extensions.
Select that, and then in the Right Pane, you should see all the extensions listed with a slider switch to enable or disable them.

It seems to have stopped logging out. Do you think it is one of the extensions causing the problem?

I tested it with a combination of the extension turned on and off. It seems the Taskbar extension is the main culprit, because with it engaged, there is a problem and without it there is no problem.

Thank you very much!

1 Like

It was the next likely possibility so we needed to try it.
Sadly... The next part is the most painful and tedious part.

Re-enabling each extension one by one until the problem reappears in order to narrow it down to the extension at fault.

Now, there is a "lazy" way out. While not a full resolution, it would at least get your sorted. Let's say that you do not care about some of the extensions that are enabled by default. Like, you do not care about Magic Lamp effect for example. You could test a shortcut of enabling all of but only the extensions you care about using, first. Then test if the problem reappears. If it does - we need to narrow it down.
But if it doesn't - you can call yourself satisfied at that point and cease the tedium of narrowing it down further.

EDIT: LOL... I see you narrowed it down during the time I was typing all that long winded post above...

Can you please run this in terminal:

sudo apt install --reinstall gnome-shell-extension-zorin-taskbar

Then test if the crash occurs after enabling the extension?

I tested it after reinstalling the gnome taskbar extension and it seems to be working. Thank you again, I guess it was something akin to a corrupted file. Thank you for all of your help!

1 Like

You won't believe it, but I left it for like 10 minutes and know it is crashing again...

1 Like

I suggest that we may be on the right track, at least.
As long as the panel is functional and moderately usable - we can test leaving it disabled for a time, then see if the problem returns.

Now, Gnome Extensions also can rely on some dconf settings that can be configured in your home directory ~/.config
You can see the "hidden files" (the ones with a period in front of the name) by tapping the keyboard shortcut ctrl+h in your home folder.

That would be the next thing we look at.
For me, it is very late here now...

It's fine, thank you for your help. I will try and google something, at least I know where to look know. Thank you for your help!

I found the problem online, the Intellihide function causes the glitch to occur. After disabling it, the issue is no more. Thank you for your help in narrowing it down, it was getting really annoying :joy:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.