Zorin not remembering my display brightness after a restart

Since I reinstalled zorin 15.3 lite. My PC is not remembering my display brightness. I always set my brightness level to 100% but after every restart it goes back.
Any ideas on where should I look?

@Aravisian can this be related to gpu ?

I'm not sure; I would think /sys/class/backlight/ configuration, not GPU.
But you might try the steps in this guide to solve your issue:

1 Like

Thanks for reply, The article you mentioned is vice versa to mine. My PC gets dimmed after a restart and I want to keep it always at a maximum level whereas the article provides solution for Brightness is reset to maximum on every restart but after reading it seems like the solution is same for both.

In the article they said to add line to to /etc/rc.local but I can't find such file named rc.local in etc

That guide may be outdated. Let me look into it further.

Maybe try this ? Amd/ati card (if you have a different gpu please let us know and you can skip this post)

To find current brightness level:
cat /sys/class/backlight/amdgpu_bl0/brightness

Set the brightness on boot using:
echo 30 > /sys/class/backlight/amdgpu_bl0/brightness


I'm sorry for being dumb, How can I find what gpu I have?

sudo lshw -c video

       description: VGA compatible controller
       product: Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:16 memory:ee100000-ee17ffff ioport:1800(size=8) memory:d0000000-dfffffff memory:ee200000-ee23ffff memory:c0000-dffff
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: pm cap_list
       configuration: latency=0
       resources: memory:ee180000-ee1fffff

There you have it.:slight_smile:

Thanks, So I have to skip the post @Michel posted as it's for amd?

1 Like

Yes, that is for AMD only.

What is the output of ls /sys/class/backlight/. Is it acpi_video0 or is it something that begins with intel or something else.

Yes it is acpi_video0.image

Okay, try the following.

Open /sys/class/backlight/acpi_video0/max_brightness. You will see your max brightness value there. Now go to terminal and run ~/.maxbrightness.sh. In your OP, you said that you want to set your brightness to 100%, so in the the text file, paste the following and change 'x' with the value you saw when you opened the file max_brighness.


#change brightness setting to 50 percent on startup or resume

pkexec /usr/lib/gnome-settings-daemon/gsd-backlight-helper --set-brightness x

Save it and then run chmod +x ~/.maxbrightness.sh. Again in terminal run

gsettings set org.gnome.settings-daemon.peripherals.input-devices hotplug-command "/home/USERNAME/.maxbrightness.sh"

Replace USERNAME with your username in the above command.

Try logging out and the logging in. Let's see if it works.


Thanks a lot. Unfortunately I can't follow the steps because I posted the same question in zorin's reddit page which I haven't done before. Two people there said to tryout Zorin 16 despite having a low end machine which made my mind change quickly and without a second thought I installed Zorin 16 and the brightness issue is not there but I will mark this post as solution as it might help others.
Thank you.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.