Zorin OS 16.3 Pro - NVIDIA CARD PROBLEM!

I had problem on my laptop using Zorin 16.3 PRO, my laptop have graphical card NVIDIA GeForce RTX 3050, i try reinstall os few times with NVIDIA "modern" installation and normal but problem in both places is same. In general, the graphics card does not work as it should, cuts the screen when scrolling, cuts videos when playing online, I tried reinstalling the original drivers from the site, the problem continues!

At the moment I am very disappointed with this OS and I regret paying for a PRO version to support!

Please if anyone has had an improved problem let me know how they solved it!

I am using Nvidia RTX3060.
I have had various issues with the 535 proprietary driver, so I recommend using the 525 (proprietary) driver, instead.
Which kernel are you on?

uname -r

Are you set to prime-select Nvidia?

When you tap alt+F2 and run nvidia-settings does the proper settings window show?

image

So to switch to 525 (proprietary) driver from Software Updater


Which version???

The fifth option down from the top:
version

You can use -server(proprietary) safely, they are essentially identical. The server driver just gets longer support in certain areas.

It will take its time loading and installing the driver... and once complete, a reboot is necessary.

some issue, i installed the marked version, and not work ok....

Can you run (if using copy/paste, remember to do one line at a time):

sudo apt remove --purge '^nvidia-.*'

sudo ubuntu-drivers install

sudo add-apt-repository ppa:ubuntu-x-swat/updates

sudo apt update && sudo apt full-upgrade

Launch Software & Updates - ensure on 525 (proprietary)

Reboot and test.

again same issue, i make a screen record to see the videos run by slow frames
https://youtu.be/IpY2Mh3igyQ and scroll is cuts

Are you logging in on Wayland?

Well, we have looked at the Nvidia driver...
But Nvidia driver does not always get used. It generally is used for more intense applications.
You also have an Intel built in graphics card. Watching Youtube, on my computer, does not kick in the Nvidia card. That's the Onboard Intel at work.

What is your terminal output for

glxinfo | grep "OpenGL version"

Yes, this will show your Nvidia 525, as well. Just want to see your Mesa build version.

If you need to upgrade mesa; the Mesa ppa is

sudo add-apt-repository ppa:kisak/kisak-mesa

sudo apt update && sudo apt upgrade

Intel may need the Tear-Free option set. You would need to create the file:

sudo touch /etc/X11/xorg.conf.d/20-intel.conf

Open the file in text editor elevated to root or use nano and ctrl+shift+v to paste the below in:

sudo nano /etc/X11/xorg.conf.d/20-intel.conf

Copy the blow and paste it into the file

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"    "true"
EndSection

tap ctl+o to overwrite, then enter to save current configuration. Tap ctrl+x to exit the editor.

Reboot and test.

Second the prime-select query - it may be in a power saving mode.

Complete nonsense, one after another no works! How do other OS configure things themselves, I mean Ubuntu, Popos and others, only this stupid Zorin doesn't want to! I SORRY I ORDERED IT ABOUT THE VERSION! FULL OF BUGS!

I am running Zorin OS on Nvidia RTX3060 without any trouble. Everything installed and worked right out of the box.
In the meantime, on other distros, users make the same complaint you just did. Not because those distros are inferior, but because in computing, sometimes things go wrong. It paints our perceptions.

Ubuntu and PoP_OS have the same configuration and base files as Zorin OS. They all use the same drivers.

Have you tried any of the suggestions from above?

1 Like

It can be very frustrating, I know your pain for sure. Took me about a year to fully commit to installing in the beginning ('04-ish).. Didn't quite grasp the driver installs or trying to diagnose HW stuff.. Ran Ubuntu and Knoppix off live CD for a looong time.

I was watching your YT screen capture; I couldn't hep but think 'is HW acceleration enabled?'. For my new-ish 11th gen i7 with an MX450, I still can't enable HW acceleration; it stutters, a lot. Especially with higher definition videos. Drivers - would highly recommend using one of the offered versions through 'Additional Drivers' though; not the open kernel ones. I've not ever had any good interactions with those, new or old..

Hey i`m backend developer and building high performence apps via docker based on microservices, one project have more than 40+ docker containers, in every restart i wait a few minutes to start working.

Thanks for the responses, but to play by trial and error, I can't spend that much time. I installed Ubuntu and no have issues.

Good luck!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.