Zorin OS 16 Beta

was trying to install Zorin OS 16 Beta on an old Dell laptop. It worked fine when running off the Live USB stick but when I finished the installation I got this, you can also see what I have tried.

1 Like

This awfully looks like what you have:

How to fix Grub error: no such partition Unknown File System (Error Fixed)

1 Like

Trouble with this video is that its based on Windows which I don't have.

Ah, I see.
Have you tried Boot Repair?

Nope. It's an old laptop. Its battery doesn't charge properly anymore so, it was going to get recycled anyway. I did get a good play on OS 16 and it looks great.

My oldest laptop with Zorin is over 10 years old.
Is your laptop older than that?

Yep. 12.

Can you tell me the make/model of your laptop?

error: file '/boot/grub/i386-pc/normal.mod' not found

As of Zorin OS 16, 32bit arch is no longer supported. Zorin OS 16 is only available in 64bit.

1 Like

But OP said:

which indicates it can run 64 bit OS.

That is why I asked its make/model to clarify this 32/64 bit question.

i386-pc directory is architecture specific and indicates a BIOS install. For a 12 year old machine, that is not surprising that it would be BIOS and not EFI.
Which is pretty much where my brain stopped.

So, I just did some net searching and for a computer from around that time frame, this is not too uncommon of an error.
I found the following:


In which case, it look like you are quite right that it is x86_64.

The laptop is a Dell Inspiron 14Z ultrabook. It's 9 years old not 12. My apologies.

Thanks for the info.

  • CPU
    Intel Core i5 (2nd Gen) 2450M / 2.5 GHz

It is the same CPU as my Acer Aspire, which is running 64 bit Zorin Lite without any issue.

How much RAM do you have?

This is a generation of laptop which can be serviced by a user much easier than more recent sealed laptops. If you like to tinkering around PC like myself, it is a great toy :slight_smile:

You can easily find a replacement battery at Amazon for around 30 dollar. So far, I replaced batteries for Aspire, HP netbook, Fire tablets and old macBook with batteries I purchased at Amazon (recommended) or ebay (my last resort).

1 Like

She had a battery replacement only a few months ago, for the same issue it is experiencing now. It would suggest something else is a foot.

I suppose you did the initial battery conditioning.
full charge -> full discharge, repeat 2 to 3 times.

Have you also opened and cleaned the air filter?
If you can remove CPU, replacing the thermo compound also helps for PC of this vintage.


Turns out, the reason my attempt to install Zorin OS 16 Beta on my laptop was the fact that the mechanical Hardrive had failed and was only running on the 32gb SSD where the main OS and it failed to install properly. Right now it is having Windows 10 put back on the 32g SSD to use a spare laptop but it now appears to have another hardware or software problem (

see image)

1 Like

Wow, that is some seriously truncated font. And it puts wobbly windows to shame.
Sorry to hear of your troubles. Hopefully, 9 years of service has paid for itself.