Zorin Forum

Zorin OS 16 Core reboots instead of shutdown

Hello community, :smiley:
I have built a new PC and installed Zorin OS 16 Core on it. I have been using Zorin OS for a year now and I am satisfied with it. But now with the new PC I have a problem.
Every time I ask the computer to shut down, it restarts after about a second. I have already searched the internet and found some topics with the same problem, but so far I have not found a solution that works for me.
My (new) hardware is:
Mainboard: Gigabyte B550 AORUS PRO AC AM4
CPU/GPU: AMD Ryzen 7 5700G
According to what I read in other communities, the problem could be in the BIOS. So I added my bios configuration here, maybe I missed something? I also don't understand every function in the BIOS yet.
It would be cool if my new PC can also shutdown gracefully again with Zorin OS :sweat_smile:






1 Like

It could be some type of bug in Zorin OS. Report it to the developers.
Workaround: Meanwhile, you can open the terminal and enter shutdown now. It should shut down.

How are you shutting it down? Via terminal (i.e: poweroff or shutdown -h), holding in the off button, via Zorin, etc? Also, are you dual booting?

Actually by holding the power on/off button. Up to now that's what works for me, but it's not that elegant.

OK, i will look how to report that and update the answer of the developers here. :thinking:

The power on/off button can be configured in the system settings.

1 Like

yes i know. But it's no matter how i ask the pc to "shut down", it will shut down and then reboot. Just like i would enter "reboot".
By holding the power button for 4sec. the whole PC turns off and stays off, that's configured i guess in the BIOS and it's actual my only option to shut it down. :sleeping:
(i reported my problem right now via the "OS-in-build" feedback. Hope they got it.) :grinning_face_with_smiling_eyes:

1 Like

The terminal commands i already tried, no success.
No it's not a dual boot. It's a clean fresh install.

I am looking for a solution for you but i came across another post from another user with another board Gigabyte B450 Aorus M and he has the same issue on ubuntu and also not fixed. He posted that it works fine in Windows 10 but not on ubuntu 20.04.

Ill keep digging for you.

3 Likes

I found another post that you might try. This user has a B550i Pro Ax F13 BIOS

I have a temporary fix for now. You have to disable GPP0 wakeup which is a GPP bridge to the NVMe drive in M.2 slot. Check your wakeup table using cat /proc/acpi/wakeup and look at GPP0. It should say *enabled. Using sudo /bin/sh -c '/bin/echo GPP0 > /proc/acpi/wakeup' you can set it to *disabled. PC should suspend normally then.

Maybe you should try this:

This workaround also works on the B550 Vision D / F13 bios

Here's a quick guide. Create the file /etc/systemd/system/biosWakeupWorkaround.service with the following contents (need sudo):

[Unit]
Description=Workaround for Gigabyte B550 F13 bios sleep/wakeup bug

[Service]
Type=oneshot
ExecStart=/bin/sh -c "echo GPP0 > /proc/acpi/wakeup"

[Install]
WantedBy = multi-user.target

You may need to change GPP0 to some other id if the corresponding device isn't the NVMe slot. Then run sudo systemctl daemon-reload && sudo systemctl enable biosWakeupWorkaround.service and reboot your computer. Confirm that GPP0 is disabled in /proc/acpi/wakeup; if so, then you're good to go.

2 Likes

That will just reboot man.

hm, thanks for the workaround, :+1:
but it still reboots when you type "shutdown" or similar. After shutting down correctly, first the SSD led flickers briefly and then it reboots normally.
But I can wait patiently for a software update as long as the OS itself is running :sweat_smile:

1 Like

Holding the power-button of the PC-hard-case for 4sec. will force the system to shutdown.
All other shutdown-options (e.g. terminal) i have found in communities haven't worked yet.

The only thing you can try now is this one, i deleted that post yesterday but i have put it back

2 Likes

ok, for cat /proc/acpi/wakeup i get this output.

Device S-state Status Sysfs node
GPP6 S4 *disabled
GP17 S4 *enabled pci:0000:00:08.1
XHC0 S4 *enabled pci:0000:0a:00.3
XHC1 S4 *enabled pci:0000:0a:00.4
PS2K S4 *disabled
GPP0 S4 *disabled
GPP5 S4 *disabled
GPP3 S4 *enabled pci:0000:00:02.1

I then disabled GPP0 (it was already disabled though) as you recommended, but no change in shutdown behavior.
Then I tried to disable GPP3, because there was a pci displayed I found that obvious, but also no change. I guess my SDD is shown in GPP3, it is on the slot closest to the CPU.
(after some shutdown/reboot I undid all changes). :sweat_smile:

2 Likes

I just tried it again and could make an interesting observation. if I disabled GPP3 and then shut down the pc with the shutdown button in the taskbar, the mainboard logo appears for maybe 1-2 seconds, but then it reboots as already described. But if I then look again cat /proc/acpi/wakeup is GPP3 enabled again, all by itself? Is there a way to force it being disabled, or what trigger enables it?

Caution:
If it is reasserting itself, there may be a reason why. Forcing it may cause breakage.
It may be wise to investigate other solutions, first.

1 Like

Today my issue was solved by an OS update.
Now it is working fine without rebooting.

Thanks for all of your help and ideas.

1 Like

A post was split to a new topic: Zorin OS 16.1 reboots instead of shutting down