Zorin OS 16 live DVD/USB will not boot on i7 gen 11 HP desktop

Greetings. I was happy to acquire a new HP desktop with an i7 11th gen CPU (11th Gen Intel(R) Core(TM) i7-11700F @ 2.50GHz) and a Radeon(TM) RX 550 GPU. Unfortunately, both the live DVD and live USB media for Zorin OS 16 hang at the logo screen after successfully verifying all checksums. I tried all Zorin boot options with both old and new video driver choices with the same result.

For giggles, I burned a DVD of Ubuntu 20.04.3 LTS to see if that made a difference - and this also hung on boot-up, not even getting to a logo screen.

What do you all suggest? I need to solve the live boot problem before considering installation of Zorin (or Ubuntu, for that matter) as a second OS.

By the way, I was able to boot from both the USB and live DVD into Zorin OS 16 on my old dinosaur Core 2 Duo HP PC (that currently has Zorin OS 12.4 installed).

I really want to get this new PC running Linux so I am not just leasing a version of Windows.

Thanks in advance for your help!

1 Like

You earn a :star2: for being one of the few to actually make sure to check the SHA256 checksum. You are awesome! :grin:

Now something you may not have thought of, was making sure that you have SECURE BOOT and FAST BOOT disabled in your bios. That has to be done first.

If that is not enough to get it going, switch your SSD drive to AHCI too.

1 Like

Also, once you are able to boot into the ISO, and launch the installer, make sure to say CHOOSE SOMETHING ELSE. This will give you the opportunity, to delete all the Windows partitions off the drive. Basically, you want to have nothing but unnalocated space afterwords.

Then after you do that, you can click back in the installer, and then choose let Zorin install via the normal automatic option, and then just follow the instructions.

1 Like

Thanks for the prompt reply! I did disable Fast Boot but did not disable Secure Boot. I will check that setting and try again, posting results back here.

2 Likes

Thanks! I will give that a shot when/if I get to that point.

Turned off secure boot... and live DVD bootup still hangs on Zorin OS screen, when selecting Try Zorin...

I assume, you've also tried the AHCI switch too. I see you have an Radeon GPU, so you don't want to use the Nvidia option at the bottom of the list.

Are you able to launch the Zorin installer in Safe Mode?

BTW, I've never seen a modern notebook sold with an optical drive, its the reason why I had to buy an external optical drive incase I want to use disks. Either way though, USB is known to be more reliable for installation over DVD disk.

Having said that however, if you did burn the ISO to USB drive, the question I have to ask you is, did you use Balena Etcher? Because if you used Balena, that could be the issue, its the worst ISO burner.

If you have access to Linux on another machine, I would format the USB drive and burn the ISO again, but using the Popsicle APP this time, cause its much better.

But if your coming from Windows, then you have option of using Rufus or Unetbootin for ISO burners.

1 Like

Ok but if screen is freeze that doesn't mean installation not going forward. Wright?
You put cd plate on dvd then click installation or I am missing something?

Are you running a radeon card in addition to Intel dedicated graphics or does this machine contain only the radeon graphics card?

He has an Intel 11th gen CPU i7-11700F, it doesn't contain an integrated GPU. The only GPU that he has in that machine is the discreet Radeon RX 550 GPU.

So as an update, I disabled Secure Boot (had already disabled fast boot previously), and attempted to boot into live DVD versions of Zorin OS 16, Ubuntu 20.04 LTS, and Ubuntu 21.04.

All live boots failed on the new desktop PC, hanging/freezing soon after the checksums passed. By contrast, all live boots from these same DVDs worked flawlessly on my ancient Core 2 Duo HP desktop.

The only thing that I did not do was change the AHCI setting on my SSD drive - but is there any need to do this if I am only trying to live boot from a DVD without attempting an installation?

By the way, the reason why I tried to boot into Ubuntu 21.04 was because I had read (maybe in a forum for Ubuntu) that the 20.x version will not work with the i7 11th gen CPU. Oh well, 21.04 didn't work.

I suppose I could install some version of Linux into a VM running on Windows, but I prefer separate dual boot capability. I will continue to research and post results here. Thanks again for all the helpful responses.

Actually, yes there is. Other then installation, changing the drive over to AHCI, could also allow Zorin to see the drive. While I cannot say for certain, the freezes may be caused by the fact that it can't see the drive, and goes bonkers.

Again, I have no proof of this, its simply a theory. But when you've tried everything else, there's no reason not to try switching to AHCI. But seeing as how all those LIVE ISO's are having issues, that tells us this is not an isolated case to Zorin OS.

There is something else going on here and we have to figure out what it is. I will say this, 11th gen is a very new CPU architecture, I hope its been totally flushed out by now, but it hasn't been a full year yet, and usually problems get flushed out after a year.

The latest kernel that Zorin uses should support 11th gen though, so as far as hardware support goes, Zorins kernel should have you covered. This was a recent download of the ISO right? Not one you downloaded a month ago?

Cause yes that question does matter a lot. We had serious issues with EFI a month ago. And hten a week ago we had a kernel that was utter garbage. So if you downloaded the ISO as recent as today, yesterday, or day before, everything should be good, as long as the ISO passed the integrity check.

But again, your having issues with the other distro's too, and I have to keep reminding myself of that, as that is an important factor to keep in mind. Its not isolated to Zorin, its happening with other Ubuntu based distro's.

And yes you could try in a VM and see how it goes, actually, I am downright curious at this point. Cause technically, even in a VM, its going to be running on your modern hardware, its just going to use more RAM to do it, and I wanna know if it works.

Thank you, StarTreker. I actually did download the Zorin OS 16 ISO last week, so perhaps that is the problem. I downloaded the other ISOs this week, but I will check for updates. I was busy this weekend and didn't get to work on this, but I will keep you posted. Thanks again for the help!

I just configured a VirtualBox VM on the new computer and was able to boot into Zorin OS 16 from the DVD without any problems. Virtual Box appears to use a lower video setting, so I am wondering if the GPU was the problem causing the direct boots to fail and hang?