ZORIN OS 16 Pro on External NVME Drive Gives Black Screen On Boot


Some background, I've been using Zorin OS 16 PRO on a WD Blue External NVME drive for quite some time now, and after a long and arduous install process getting it to work with dual boot on my Surface Pro 7, it's been working perfectly for ~8 months or so!

That is, until today when I attempted to boot as normal and was met with a black screen prompting me to login. After logging in and running "startx" I get met with an error screen stating that the system experienced an error and could not be recovered and to try booting again. I've also tried to update and got met with 404 errors. I am connected to the internet still and can ping google with no packet loss, but the update aborts anyways. The last thing I tried was booting from previous kernels with "nomodeset" but still nothing.

Any ideas how to resolve this? I've loved using Zorin the last little while and would love to get back to it without having to re-do the whole install from 0 (it was kind of a pain in the butt getting the dual boot to work properly lol) and lose the data that I have!

Thanks <3

1 Like

What Graphics card are you running?

Have you tried using LiveUSB to boot the Try Zorin and accessing the data on your drive (Make back ups just in case)? With this method, you also might remove the ~.Xauthority file and try booting it up.

This means you have been able to access Advanced Options for Zorin, correct?

From Advanced Options... try selecting the Recovery mode for your current kernel. Entering the Recovery Menu, arrow key down to Enable Networking. With that enabled, back to the Recovery Menu and arrow key down to Drop to Prompt.
Hit enter and in the Terminal run:

sudo dpkg --configure -a

sudo apt clean && sudo apt autoremove

sudo apt update && sudo apt full-upgrade

Report any errors but if everything runs cleanly, back out of the Recovery Menu and test a Boot.

1 Like


You're speedy thanks for the quick reply! I'm on a windows surface so just have intel integrated graphics.

I already tried the recovery mode options as I saw them on a different post of yours, and ended up getting 404 errors on a number of the upgrades. I was able to run get and then installed them and installed zorin-os-desktop which seemed to get me into everything properly and then Installed updates from the software updater.

I've just rebooted and everything appears to be resolved now!

Unsure what really caused the problem in the first place, but am glad to be back into my system with everything intact.

1 Like

Are you using the Surface Linux Kernel?

My guess would be packet loss during an update that caused a partial upgrade. This cascaded into Necessary files being missing or corrupted in the system.

1 Like

My guess is the same!

I don't believe I'm using a surface specific kernel, I wasn't even aware of it! I just installed whatever Zorin os pro came with out of the box as it was my first try at linux.


Many pieces of hardware are designed for Windows - You can read more in depth here:

With the Surface, this goes even deeper. The Surface Notebooks are commissioned by Microsoft to be built specifically for Microsoft and Windows OS.
The Surface is not Asus or Sony or Acer... it is a Microsoft computer.

Here is the Linux Kernel for Surface:


Gday @SpotOnSpenny Welcome to the community.

Another thought!
As it has been working & it looks like it's started working again by itself, i thinking the connection cable/s or how ever you have your setup,
Some thoughts:
If you leave the external always plugged in, try unplugging both ends if possible & replug then in a few times ( to scratch up the connections, a can of Electro clean would be handy, to give the ends a cleaning).
The Cable itself,
It doesn't take much to break the fine wires, even just lifting it ever now & then to clean under/around it, Good to have a backup cable anyway, so id invest in a new cable.
Hope this may help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.