Zorin OS 16 Stuck Boot

Hello, everyone! So this week I've been trying to boot my Zorin OS 16 Beta Version after a uefi dual-boot installation. I used BalenaEtcher on my 8gb pendrive, and I chose the option to install Zorin with Nvidia drivers, all went well, the grub is working too, my only problem is that when I boot Zorin the AsRock logo shows and then boom, nothing happens, it get stuck.
I've tried booting with "nomodeset" and other options, but nothing worked. I wonder what could be the problem here?

System Info:
Motherboard: ASRock H310M-H64
GPU: NVIDIA GeForce GTX 1070
CPU: Intel Core i5-8400
RAM: 16gb
Storage: 240gb SSD
Space reserved to Zorin: 45gb
Partitions: 4gb of Swap and the rest for root

P.S: Both secure boot and fast boot are disabled

1 Like

Please create a partition that you intend to install Zorin onto. Format that partition as ext4, not as NTFS.
Once formatted, in Windows, navigate to your Control Panel and through to find Fast Boot and turn that "off." Fast boot locks the HDD preventing write access.
Shutdown and boot into your UEFI settings and ensure that Secure Boot is disabled.
Now, you can begin the Ubiquity installer by booting your Live Zorin OS and selecting "Install Zorin."
I recommend that you choose the "Something Else" Option. This will open the partition manager again and all you need do is select it, then select the journaling file system, ext4 and mount point at /

1 Like

I did exactly as you said, my root "/" partition was mounted as journaling file system ext4 through the partition manager of zorin os. Secure boot and fast boot are disabled too. My problem is to be stuck when trying to boot Zorin, as you can see in the image with the motherboard brand "ASRock" showing.

What about Grub repair?

Replace "ubuntu" with "Zorin" in your reading of it.

1 Like