Zorin OS 16 vs Pop! OS 21.04

sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-4.19.0-17-amd64
I: The initramfs will attempt to resume from /dev/sdc3
I: (UUID=80734380-1b01-4d92-9060-b9ea3ec1f207)
I: Set the RESUME variable to override this.


I see the same problem what was in POP OS
What that means?
It turns out that the system should be installed on a naked laptop, without a station or foreign monitors. Otherwise it gets stupid and doesn't function properly.

@StarTreker, wish me luck. Going to delete Windows 10 from my SSD drive and install Pop! OS on that drive.

Windows free in a few minutes :innocent:

This is interesting mostly people delete windows but not throw window apple operating system, because this is also unix system?

@StarTreker, i wiped the entire windows partition and installed pop os on it. When i reboot the laptop pop os does not boot up + i can't boot in my second drive where zorin os is installed on.

Any ideas what is causing this ??? tried to reinstall pop os again and not working.

Did you format the drive GPT? Then after, install POP OS? I think you know the drill. SECURE BOOT and FAST BOOT disabled. And that your SHA256 Checksum checks out most deliciously, for a delicious install?

I let pop os do that it self, the funny thing is i do the same on the m2 sata drive (the one where zorin was installed on) and pop os works perfect. So yes format went perfect, it created this.

Imgur

I guess it does not like my samsung nvme drive. I also went to the pop os site for boot repair. Followed every single step, but still it wont boot the os on nvme.

1 Like

OK, Gparted is a little easier to understand because of the way its laid out in the window. But so far, if I am reading that right, that look normal those partitions. This is how POP OS did my drive when I let it do its thing.

See the EXT4 partition on mine? Thats where the POP OS installation will go to.

The top FAT32 is my EFI boot loader partition
The FAT32 just below that is the 4GB recovery partition.

There is also the 4.3GB Encrypted SWAP partition.

And finally, a tiny bit of unallocated space at the beginning and end of the drive on each end.

Yes i got the same in the nvme drive, yet the nvme drive refuses to boot. I wonder why ???

Could be a BIOS settings? Have you played around with EFI VS AHCI, cause thats thrown many through a loop, and that aint no lie. :thinking:

I can't change that, only UEFI or Legacy. I post some pictures later.


Live USB have a normal resolution. Interesting
After Installation i have a normal resolution but i disconnect all hard disks.

@Bourne, boot repair did not work. I already tried that from the pop os website. For some reason samsung 980 1tb nvme does not want to do a boot with systemd boot efi.

Thanks @Bourne for trying to find a solution. The problem i have after i installed pop on it and reboot my drive it does not see the efi/boot parameters for some reason.

I installed pop on a m2 sata and that one works as how it should.

I cant find much info about the nvme not booting, hope pop os/ubuntu fix this with newer versions out of the box

@StarTreker, @Aravisian or @jgordon or @337harvey do you have any ideas ? nvme that does not boot with systemd boot instead of grub

Did you used a guide partition POP OS from yt what i put here on this forum?
Zorin to go in best using boot menu from bios with keyboard a laptop F2 or another button it depends a type laptop. If you want start Zorin then you need click fast SHIFT to get inside grub menu. When you want go to POP OS the same method boot menu from bios then choose the same method but the keys will be CTRL+ALT+F5. The zorin using ubiquti and pop os is systemd and don't have a grub. You must install grub on POP OS.

I did alot of research, it seems this is a possible bug that needs a fix in the kernel. I tried to reinstall again with the other drives removed. I get things like this:

Imgur

Imgur

I put the other 2 ssd's back, need to repair boot on the other drive...done! and now i will stop testing haha. I give up to use the nvme for main os. I use the other m2 sata drive which is fast enough for booting up a os.

You could be very right Michel, it could be a really bad bug that needs to be fixed in a new kernel. The only real difference between our NVME drives, is mine is Western Digital, and yours is Samsung.

So maybe each of our drives are encoded a little differently. And maybe our NVME drives operate at different speeds from each other. Although I can't see that mattering that much.

I use Samsung nvme drives (970's) and haven't had one issue installing (alpha - pro). If you have ssd's connected, make sure they are in ahci mode. Somehow this has been effecting nvme drives. Also, take a look at your pci-e settings in bios, maybe turning off power management for the interface may help. Your computer doesn't use IRST from Intel, does it?

The most weird thing happend. I removed my second m2 sata driver where pop os is installed on. So i would make sure it would not happen again to lose the boot. I reinstalled pop on the nvme drive, rebooted and the same thing happend again. Can't boot, tried everything. So i thought oke i tried everything, lets install the sata m2.

"no bootable devices found" wth ?

Followed pop os instruction to recover boot, did work BUT i have to press F12 all the time. Wiped the entire drive again, reinstalled on the sata m2. Rebooted "no bootable devices found".

Formatted all drives with the windows 10 usb, reinstalled pop os and it worked. I guess the nvme had some traces left or something.

@337harvey, pure linux here so no no irst. I wiped all partitions today. As for the other options. My bios is limited, could be a problem on Acer's side. Please check -> Zorin OS 16 vs Pop! OS 21.04 - #44 by Michel