Zorin OS 16 vs Pop! OS 21.04

Did you format the drive GPT? Then after, install POP OS? I think you know the drill. SECURE BOOT and FAST BOOT disabled. And that your SHA256 Checksum checks out most deliciously, for a delicious install?

I let pop os do that it self, the funny thing is i do the same on the m2 sata drive (the one where zorin was installed on) and pop os works perfect. So yes format went perfect, it created this.

Imgur

I guess it does not like my samsung nvme drive. I also went to the pop os site for boot repair. Followed every single step, but still it wont boot the os on nvme.

1 Like

OK, Gparted is a little easier to understand because of the way its laid out in the window. But so far, if I am reading that right, that look normal those partitions. This is how POP OS did my drive when I let it do its thing.

See the EXT4 partition on mine? Thats where the POP OS installation will go to.

The top FAT32 is my EFI boot loader partition
The FAT32 just below that is the 4GB recovery partition.

There is also the 4.3GB Encrypted SWAP partition.

And finally, a tiny bit of unallocated space at the beginning and end of the drive on each end.

Yes i got the same in the nvme drive, yet the nvme drive refuses to boot. I wonder why ???

Could be a BIOS settings? Have you played around with EFI VS AHCI, cause thats thrown many through a loop, and that aint no lie. :thinking:

I can't change that, only UEFI or Legacy. I post some pictures later.


Live USB have a normal resolution. Interesting
After Installation i have a normal resolution but i disconnect all hard disks.

@Bourne, boot repair did not work. I already tried that from the pop os website. For some reason samsung 980 1tb nvme does not want to do a boot with systemd boot efi.

Thanks @Bourne for trying to find a solution. The problem i have after i installed pop on it and reboot my drive it does not see the efi/boot parameters for some reason.

I installed pop on a m2 sata and that one works as how it should.

I cant find much info about the nvme not booting, hope pop os/ubuntu fix this with newer versions out of the box

@StarTreker, @Aravisian or @jgordon or @337harvey do you have any ideas ? nvme that does not boot with systemd boot instead of grub

Did you used a guide partition POP OS from yt what i put here on this forum?
Zorin to go in best using boot menu from bios with keyboard a laptop F2 or another button it depends a type laptop. If you want start Zorin then you need click fast SHIFT to get inside grub menu. When you want go to POP OS the same method boot menu from bios then choose the same method but the keys will be CTRL+ALT+F5. The zorin using ubiquti and pop os is systemd and don't have a grub. You must install grub on POP OS.

I did alot of research, it seems this is a possible bug that needs a fix in the kernel. I tried to reinstall again with the other drives removed. I get things like this:

Imgur

Imgur

I put the other 2 ssd's back, need to repair boot on the other drive...done! and now i will stop testing haha. I give up to use the nvme for main os. I use the other m2 sata drive which is fast enough for booting up a os.

You could be very right Michel, it could be a really bad bug that needs to be fixed in a new kernel. The only real difference between our NVME drives, is mine is Western Digital, and yours is Samsung.

So maybe each of our drives are encoded a little differently. And maybe our NVME drives operate at different speeds from each other. Although I can't see that mattering that much.

I use Samsung nvme drives (970's) and haven't had one issue installing (alpha - pro). If you have ssd's connected, make sure they are in ahci mode. Somehow this has been effecting nvme drives. Also, take a look at your pci-e settings in bios, maybe turning off power management for the interface may help. Your computer doesn't use IRST from Intel, does it?

The most weird thing happend. I removed my second m2 sata driver where pop os is installed on. So i would make sure it would not happen again to lose the boot. I reinstalled pop on the nvme drive, rebooted and the same thing happend again. Can't boot, tried everything. So i thought oke i tried everything, lets install the sata m2.

"no bootable devices found" wth ?

Followed pop os instruction to recover boot, did work BUT i have to press F12 all the time. Wiped the entire drive again, reinstalled on the sata m2. Rebooted "no bootable devices found".

Formatted all drives with the windows 10 usb, reinstalled pop os and it worked. I guess the nvme had some traces left or something.

@337harvey, pure linux here so no no irst. I wiped all partitions today. As for the other options. My bios is limited, could be a problem on Acer's side. Please check -> Zorin OS 16 vs Pop! OS 21.04 - #44 by Michel

Hello Michel!

I don't think you realize this, but your feedback has been invaluable on your experience, that I have upgraded you to SUPER STAR :stars: status. You have no idea how your feedback is helping, so I wanted to make sure that I told you about it.

Your experience, while its more then likely been a real PITA for you, it really was important for this information to come out. With so many new users switching to Linux, its really important to see what does work, and what doesn't work, and what may need improved.

Also, its important for developers to get this feedback as well, as a lot of times, things can be fixed on distro level, but sometimes, things will have to be fixed on the kernel level.

You are getting quite the Linux education. And its in my opinion, that you've learned more in your short time dabbling with Linux, then most users do. You are pretty amazing in my book, and I also appreciate having you around.

Believe it or not, I've already seen you help a few people on here, yes, its true, you have, and I wanted to let you know that I appreciate it. So keep up the good work!

Yes, indeed, there could be some incompatibilities with Acer, so many things that either work or don't work in Linux, is due to whats in the kernel. A lot of times its a gooseshoot, sometimes you win, sometimes you lose.

But either way, your getting an experience. In regards to POP OS, do not forget that they have a huge resource of information on their website at System76, all their info is listed under categories that you can find there.

Also, don't be afraid to contact a manufacture of a product you own, to ask them to provide Linux support. If you contact Samsung, you could ask them to provide unique driver support for Linux, couldn't hurt.

The thing with NVME drives, is that they are still very new tech these days. For many system, bio's updates are required just to utilize newer NVME drives that use later standards, and higher clock speeds.

For this very reason, is why when I do eventually buy a second NVME M.2 drive for my notebook, I will be matching it up with the other one, as I have no interest in taking the risk to update my bios. And yes, it is always risky doing bios updates.

Never do a bios update unless you absolutely have to, because you have no other choice. Because updating bio's could either go completely great, or, it could brick your motherboard.

1 Like

It may just be me, but part of your issue is probably the security tab, secure boot = standard. For any Linux install you should disable this until it's completed, then reenable after, if you insist on its use. Bios updates will reenable this automatically...fyi.

Your bios is locked down. Not much you can do there. You may want to search your bios manufacturer and version for an unlock... but i don't think it'd help much. I'll do some searching and let you know what i find.

1 Like

You are so right Harvey, I too noticed his bio's was locked down. Thankfully, my MSI computer provides an unlock command to unlock the full BIOS, but you have to do that key combo command everytime you enter the BIOS, as its not permenant.

I too noticed that Secure Boot Standard. I was going to speak up about it, until I saw his BOOT menu, which was set to SECURE BOOT DISABLED. And I thought, well, maybe his Insyde BIOS is just weird, its not American Megatrends afterall.

Sometimes the BIOS can be a confusing place to hang out in. I tell you what, once you unlock an MSI computer, when you see how much stuff is in there, literally your eyes are going to go crosseyed, and role back in their sockets, while smoke is coming out of your ears, and then your brain suffers a BSOD.

The warning will state, run out of memory, consider sleeping to clear the RAM cash. :crazy_face:

1 Like

Nah i am not going to try to find one, my other m2 drive that is on sata speed is working great with linux. It's not worth to use the nvme to get some speed, i don't think it will be fully used anyway.

When i enable secure boot i can't change the "standard" part, already tried that. So when it is disabled i assume the ''standard" is no longer in use.

I am on the latest bios already, acer locked alot

Maybe acer has such key too ? that i might dig into.

Thanks for your nice words @StarTreker, i try to do my best. Still not an expert but i am eager to learn more about linux these days. I am very surprised i got so far and get the os running how i want to (specially with gaming).

Well the issue happens with the pop os, i get the feeling that my bios has 1 custom entry for a linux bootloader so if i install another os the previous one gets overwritten somehow (or systemd boot is the issue, no idea). That is why i lost the bootloader from zorin os on the other drive. It got overwritten by pop os somehow. The weird thing is i did do a clean install with pop os on a external hard drive and zorin os boot did not get deleted in the bios.

1 Like