Zorin OS 17 Beta Feedback

Why you guys dont like flatpak, snap ? Are you working in Nasa so you need highest level of security ? :slight_smile:

Hello ERZ,
wich model of Dell laptop are you using for Zorin?
I've tried it on my D620 with Nvidia and it crashed every time after a few minutes. Maybe it was the wrong format on my USB device, i dont know a nice programm like rufus for linux to set MBR or UEFI.

Ive tried it a few month ago on my D620, on a Dell E5450, zorin works well (-:

Basically, Flatpak (and snap) are not fit for purpose. I will give you a recent example. On KDE neon I run on another drive, Inkscape came up as needing updating from 1.31 to 1.32 - the flatpak update gubbins announced it had crashed.
Apt is rock solid compared to flatpak and snap, period! Stability is key = apt!


A D620 will be quite low spec if I remember correctly - have you updated it at all? More memory? SSD? Ventoy for Linux is out - that is what I have used to install it on my Desktop.

Just a gentle warning to people running the Beta. Don't change the server settings to Main Server or your country's locale server as the Beta is dependent on the Custom Servers that Team Zorin have setup for this release. Rember, it is a Beta, not a final release.

The Beta version is reliant on the Custom Servers that Zorin has set up for updates etc.

I'm going to do desktop capture video, once I know my good lady has returned with the groceries as I don't want to get my recording baulked!

I had installed 2 GB ram, with a HDD and ive tried it with the core edition. Maybe with zorin lite it will work and it was just a little try, i spent less than an hour for this experiment (-:
This thread is for Zorin 17 Beta Feedback and i dont think it need a new thread for my oldschool computers. Sometimes, i'll try it again (-:

Just some quick comments. I tried Z17 on a live USB drive with my Dell laptop. I kept getting some weird popping noises every once in a while when I would click on something. That was pretty annoying.
I next tried it again live using the USB thumbdrive on my Asus desktop. I did not get any annoying popping noises then. I really like the new looks of this OS. I decided to try the software store and could not get it to load anything while running it live on the USB drive.
I next installed it in the Boxes VM running on the Asus with MX Linux as the host machine. The installation went very smoothly and pretty quickly also. I again tried the software store and found that it did work but loaded very slowly. I don't know if that is because of being in a VM or if there is still a problem with the software store. I left Zorin before because I got frustrated with the buggy software store. I do like the new software store as it now gives a lot more information about the programs. Both the LM store and the MX store are much faster but the MX store especially gives very little information about a program you might be interested in trying. I was also pleasantly surprised to do a search and find that both Betterbird and Ungoogled Chromium were availalble for download.
As soon as I have more time I will try installing Z17 on my laptop along side MX23 and see how it works actually installed instead of on a VM. Interestingly when I rebooted Z17 after installing it on the VM, Z17 recognized that it was on a VM and suggested I do a real install to get the full benefit of Z17.

1 Like

I understand not wanting FF as a Flatpak, but it's just as easy to uninstall the version that ships with the OS and install your preferred one. No need to give up on the whole system based on that, imo


not interested about zorin core, i have not used it before, i'm interested in zorin lite xfce, i think these new features of zorin core 17 will not happen in zorin lite, may be the two features will be added to zorin lite , the first is Refreshed Software store, and the second may be Universal search and other improvements to the Zorin Menu, for tiling and switcher i think no built in way in xfce way can made the same new tiling ways that appear in zorin core 17, may that happen by third-party apps, but i think zorin lite will not do that

  • Flatpak and Snap waste resources.
  • The use of multiple package management systems is complicated to manage.

I do like the variety of options in Zorin 16 though. Sometimes I need the availability of flatpaks and even snaps.

1 Like

MacBookPro, 2014, 8gb RAM, 500gb SSD

Zorin 16.3 runs perfectly

Zorin 17 beta installs and runs under Boxes. Under boxes its still pretty much unusable as any interaction with the UI causes 10 secs at best for any kind of UI response. Even closing a window takes 10-15 secs. Looks like defaulting to Wayland.

Zorin 17 beta will not even present an option to install on raw drive from USB. Leaves a blinking flat cursor in the upper left of the screen. Never moves forward.

1 Like

I've had the occasional popping but think that was in live mode. One thing for sure is that you need to turn your volume down low before trying the live option, I nearly got blasted out of my chair with the login sound!

I used the installed Firefox to go to their website from the link in Software. Downloaded Firefox ESR - extracted the .tar.bz file which creates a Firefox folder in Downloads. Open the Folder and look for the cog labelled 'Firefox' - clicking on it launches it.
Use Main Menu to create a new Item. Call it 'Firefox ESR'. Then go to the command box and browse to the cog named Firefox in the extracted folder in Downloads - you now have Firefox ESR in the Menu - only once you have done this can you pin it to 'Dash' - what used to be 'Favourites' aka the Panel! The same goes for Thunderbird - just search for Thunderbird in browser, download the archive, extract and do the same as you did with Firefox ESR. Job done.

My Video is pants! Should have checked the settings in Vokoscreen - end result looks like an old Analog TV struggling to get a signal! Aaargghhh!
Just to add been able to install Synaptic Package Manager via Terminal:

sudo apt install synaptic

Then through that installed Gdebi Package Manager, then installed Apper but can't install Timeshift as no 'authorisation (password field) comes up (unless hidden behind it - will check again.)

1 Like

grub customizer will not stop loading to download - could download through terminal.

Are you referring to the Software Store as opposed to terminal?

exactly - not the world's end, but it says Zorin approved - lol

Just installing kde-full via Synaptic and Dark mode changed to Light in both Synaptic and Downloads window.

1 Like