Zorin OS core 16.3 logging itself out

I just Installed Zorin OS core 16.3.....But at the time of doing some work or even browsing..it just automatically logs me out....follwed by a blank screen appear for a second..and all my work always lost..What should i do..it keeps getting very annoying

1 Like

Can you please check your /var/crash logs?
It sounds like your system is crashing.

1 Like

where to find it..??...i m still newbie to linux

Are you using Zorin OS Core or Lite?

In a terminal (Launch from app menu or with keyboard shortcut ctrl+alt+t) run

ls /var/crash

This will list all the crash logs.
In that list, look for any crash logs referring to gnome, gnome-shell, gdm, or graphics.


the folder is completely empty.....i mean there is nothing inside crash folder
and i am using zorin os core 16....i m

What are the specs of this machine? Make, model, generation...

Dell latitude e6420.....i5 2520M....8GB RAM ...128GB SSD..(contains OS)....and 300 gb HDD

Do you have Nvidia or other dedicated graphics card?
Are you connecting with DisplayLink?

nope it has basic inbuilt intel 3000 graphics...and i am not connecting any display link..

Can you try using psensor to monitor your temps and see if anything is overheating causing the computer to stall, crash or shutdown?

sudo apt install psensor

Launch Psensor and actively monitor temps while working on something. See if things are getting too hot.

If temps seem normal, you may need to try the following grub parameters:

intel_idle.max_cstate=1 i915.enable_dc=0 i915.enable_psr=0

@ayaan To avoid this question about which edition of ZorinOS you are using, please edit your Forum Profile to add that you are using "Core". Thanks. Zab


here is the screen shot of psensor....is this ok??

yup will do it

It shows as below the max threshold.
In my own opinion 60 degrees C is too high... but that's just me.
I imagine that won't make your computer shut down.

Let's go ahead and try this...

sudo nano /etc/default/grub

Arrow key to


And add the parameters so it looks like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1 i915.enable_dc=0 i915.enable_psr=0"

Make sure you have the opening and closing quote marks in place. What you have in your grub file must match the above exactly.
Once you have added the parameters, tap ctrl+o to overwrite, the enter key to save the current configuration and ctrl+x to exit the editor.
You you must run

sudo update-grub

for the changes to take effect. Reboot and test...

i have followed every steps......Will let you know if problem will still occur......Thank you for now :slight_smile:

1 Like

just now..problem occured again...i was watching movie on vlc....then automatically blank screen appears..i get logged out....what to do now :frowning:

To see logs you can also just open Logs, preinstalled. As alternatives, I'd suggest letting your computer active while only monitoring it with System Monitor so you check computer status in real time and maybe you spot something interesting. You can choose to see Processes values to only CPU % and Memory.

What are your power settings configured to? My old laptop, acer, used to do this while watching videos. I disabled the screen saver and modified power settings to not turn off the monitor.


Yeah, I forgot about the screen saver. But then how can it explain this situation? Screen savers don't make the computer lose the work.

what???i have not mention screen saver...it just logs out...like restart