Zorin OS Core stuck after logging in

Hello,
I switched from lite to core yesterday, the live key booted fine and I installed core from that. After rebooting my pc and entering the password it just displayed a screen with some kind of dotted wallpaper and a mouse pointer only. I waited for about 10-15 minutes but no change happened :confused:

Any way to fix this issue?

Congrats on your conversion (although, Aravisian will never forgive you).
Start from this post: [SOLVED] Black screen after install
Yours sounds the same as what I saw on my wife’s PC (although mine was mostly black with a dotted line running horizontally along the center).

Think I should only follow post#2 as my bios is a really minimal one (legacy) and has no such options. Will try it and report asap :slight_smile:

Thanks, it worked perfectly there was no ro in the nomodset and splash section as of now (zorin os core 15.3). For future readers core does not have any kind of gui driver updater like in lite. But follow the steps and you will get everything up and running :slight_smile:

1 Like