Zorin os installation flash drive doesnt show up in BIOS

I was trying to install Zorin os but my flash drive doesnt show up in BIOS boot options.
These were my steps:

  1. Burning an zorin os image using Rufus, with these settings:

    (did the same with 2 flash drive, both didnt show up in the BIOS)

  2. Entered to the the BIOS but didnt see my fash drives, so I played with these settings and both of my flash drives:

  3. Nothing helped.

  4. I did the default settings for my BIOS but same thing happend, (only now the boot options had three things and not one)

Is there a problem with my burning settings or BIOS settings ? maybe I did something wrong ?
I would appreciate the help !

Here is the difference between my BIOS setup and yours.

Fast Boot -> Disabled
Boot Logo Display -> Disabled
Launch CSM -> Disabled

This setting might help.


It worked, thank you very much !
so after I did the default settings for my BIOS, changed to what you told me, it worked, it must be the fast boot and boot logo display that were the problem.

1 Like

You are welcome :slight_smile:
Do not hesitate ask if you have any further question.
We are all here to help you.