Zorin OS Installer not detecting my hard drive

Yes, it is possible, just a major pain. Let me see if I can find a guide.

EDIT: You can ignore the bits about LVM (logical Volume Management) if you want:

This is more demonstrative, to show how much hair you'll lose.

To really throw grease into the fire, you would need to be substituting Zorin OS for Ubuntu, which would mean compiling packages as Zorin OS is not based on Ubuntu Server.

1 Like

I read (or should I say glanced over?).
Something tells me it is easier to reinstall Windows in a non-RAID mode then install Linux in the usual way.
It sounds almost as complicated as installing macOS on PC...

I wouldn't do it.
I'd be in those UEFI settings flipping one switch lickity split and movin' on along the path to a normal installation. :expressionless:

But I thought OP wants to keep the Windows installation along side with Linux.

2 Likes

Good point. Part of my own bias in how my thinking works...
When the installer asks me if I want to install alongside Windows, I'm clicking, "nope."
LOL

No re-install of Windows necessary:
http://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-operation/

Note the warning at the top to really make sure you couldn't get a needle up it with a sledgehammer.
I never met anyone that lost their Windows by that method or anything.
On a Linux page, a warning of that nature looks more like:
"And be sure to make back ups and be careful." That's it.

1 Like

Glad I asked you about this [small] detail before you give OP an advice how to wipe his/her system clean before installing Zorin on it :crazy_face:

2 Likes

Just helping a fellow fix their computer. :smiley:

1 Like

I love your euphemism :rofl:

try disabling fastboot windows 10 and formatting the partition that will be used for zorin to NTFS using MINITOOL/EASEUS Partision on windows 10. then try to reinstall zorin os as usual.
I've experienced it after installing windows 10 21H1 a few hours ago. I tried the method above and it worked.

3 Likes

I may be the exception that proves the rule, but I installed and have been running Zorin 16 since April on a Dell Optiplex 7060 single-drive PNY CS900 SSD with RAID enabled. No problems that I can see.

I suspect that the switch from RAID to AHCI is recommended, but is mandatory if and only if the installer does not recognize the install-to drive.

I've had the same experience with SolusOS. I first installed it on the 7060 with RAID enabled, and then moved the disk to a RAID-enabled 7070 when I did a hardware refresh two years ago. Four years, two computers, and no issues.

I know a lot of people have had serious issues with Linux and RAID, so it might be that Dell implements RAID in a way that doesn't cause Linux issues. Dell is a major supporter of Linux, offering OEM Ubuntu on much of its line and supporting subsequent Ubuntu installs on a large number of OEM-Windows computers, so that's a possibility, I guess.

I took an interest for this subject since I always thought RAID involves more than one drives. I checked around Dell forum and found this very interesting comment:
https://www.dell.com/community/Inspiron/Why-RAID-with-a-SIngle-Drive/m-p/7502665/highlight/true#M75285

Indeed there is such thing as a single disk RAID. But the avobe posting also mentioned that:

The only downsides to using RAID are that a) you can't run Linux, b) you can't use certain proprietary drivers and applications (like Samsung Magician if you install a retail Samsung SSD), and c) you may have to manually provide the Intel RST driver when performing a clean Windows install.

I started to wonder if some Linux distros incorporate elements which made them compatible with this default RAID setting.

A point, an SD card and an SSD card are not really the Same Thing.
eMMC is far more like an SD card than it is an SSD (drive).

In that regard, it makes sense to install Linux on an external USB drive to avoid such installation fiasco. From my experience, USB 3.0 drive runs faster than the internal microSD card reader and runs almost fast as internal eMMC (at least on my Rock64).

I have no idea, but that sounds about right. I don't have a lot of experience with hardware-installed Linux, having used only Ubuntu, SolusOS and Zorin 16. When I want to look at other distros, I use Gnome Boxes running off SolusOS.

As I understand it, RAID can be (and is) implemented differently between OEM's and motherboard manufacturers, so it is possible that Dell somehow implements RAID in a way that doesn't blow off Linux.

Switching over from RAID to AHCI sounds really simple (switch into Safe Boot, change the SATA setting, reboot into Safe Mode to allow the ACHI drivers to set up, and then boot normally) so it doesn't seem like much of an issue.

2 Likes

This also makes sense since Dell also sells Linux pre-installed laptops albeit in limited selections.

Yes, and that is the tip of the iceberg. Close to 300 Dell computer models are Ubuntu certified and Dell has extensive support pages devoted to Linux.

Anyway, whatever the reason I've had no issues with Linux on RAID-enabled Dell computers, my ignorance has been my bliss. I read this thread this morning with a combination of horror and fascination, never having encountered the problem.

1 Like

That is an interesting information.
When I got too old :wink: or too lazy to built my own computer, I should consider Dell products.

My experience is more or less the same as yours.
So far, the only machine which resisted my effort to install Linux was this newish Acer Aspire tablet with an eMMC storage.

I have figured out how to work around it, but my husband is currently using it as a score reader (he is a professional musician) and does not want me to experiment with it :frowning: