Zorin OS Lite Wifi not connecting

Hello everyone. I recently decided to breathe life into an old pc of mine by installing Zorin OS Lite. Everything works perfectly, except for wifi. I have installed the drivers for the usb wifi adaptor, and it can detect nearby networks. It also connects to my phone hotspot and portable hotspot, yet it doesn't connect to my home wifi.
Whenever I try to connect, the loading circle moves in the taskbar, and after a long time, it again asks me to confirm the password. Then again the loading circle appears and again the same password window. This goes on and on and it refuses to connect. As mentioned earlier, it connects fine with my phone and portable hotspots, and also with ethernet.
Could anybody please suggest a solution? I am totally a newbie to Linux, but willing to learn.
Also, are the wifi router settings are to blame, as it is on CCMP and not TKIP?

1 Like

@NoobieNewbie Hi and welcome to the Forum.
Is your home wifi operating on a channel outside the range that your old pc can use?
(I am asking as someone found that was source of their wifi failure)

What wifi adapter does your machine have?

1 Like

Thank you so much for replying.
I don't know the model exactly, except that it is a Frontech one(they aren't that reliable though) and it is using the rtl8188fu driver for Linux.
As for the channel, the router supports both 2.4 and 5ghz, and the adaptor supports only 2.4. Yet I am pretty sure I am connecting to the 2.4 one, as I had hidden the 5ghz ssid before.
If you need more details, I am ready to give them. :smiley:
The adaptor did work in windows 10, but it had a different driver and didn't connect properly. (At that time, I was pretty young, and didn't know much about what I was doing :sweat_smile:)

1 Like

Hmmm. So in sunmmary: your wifi is working, just not to that router. I take it that you have set up 2.4 and 5ghz as separate SSID's, Zorin is seeing your 2.4Ghz SSID but just spins instead of connecting to it.
Can you change to a different 2.4Ghz channel on your home router and try again?

If you do a websearch, you can enter your wifi adapter and ubuntu 18.04 and see if anything good comes up.

Here is one for starters. networking - How to install Wi-Fi driver for Realtek RTL8821CE on Ubuntu 18.04? - Ask Ubuntu

Another question: Have you disabled Secure Boot in your BIOS, that seems to crop up when this sort of problem is mentioned.

1 Like

Ok, I will connect to a different 2.4 ghz ssid on the router and let you know.:relaxed:
As for the web search, I have been researching for the last day and found out the correct driver at a Ubuntu forum itself.:sweat_smile:
Yes, I think Secure Boot is disabled along with UEFI, but I will check.
Update: Secure Boot was disabled. The wifi still isn't connecting, even with a different ssid
I observed one thing though, when the mouse pointer is hovering on the network icon on the taskbar, a black box pops up saying "Configuring Wi-Fi network connection "My Ssid name".....".
Does that indicate anything?

1 Like

Which driver did you install?

"different ssid" Does that mean you have tried it with a different router than your home router, or simply renamed your ssid?

I can only guess it is trying to configure your wifi with your ssid.

I'm a bit at a loss, as I have not suffered your problem myself.

Maybe someone like @Aravisian may come along and impart his wisdom? Particularly as it is Zorin Lite you are using.

1 Like

I installed the Rtl8188fu driver which I found out by googling my bus id of my adaptor from the lsusb terminal command
It was from this forum topic:

I have tried it with a portable hotspot and my phone, and it connects normally with internet connection. I then created another ssid on my home wifi router, yet I couldn't connect to the router. Probably there is some configuration on my home wifi router which is preventing the adaptor from connecting to it. I will try and fiddle around with the wifi settings and see if it is fixed.
Any suggestions on which settings to configure would be greatly appreciated.:relaxed:

1 Like

It could be multiple issues, do you have access control turned on in the router? You may have to manually add the Mac address to allow that device then. Depending on your adapter, isolated networks can be an issue (each device seperate from all other devices in the network), disabling that may help. Try manually setting the ip address and netmask with a default route of your router. If this works, you're router may need a reboot, there is an issue with dhcp. Also check the amount of allowed connections on the router.

On your laptop go into the wifi settings and change the proxy to automatic. This setting sometimes interferes or rejects connections when it's off.

What is the model of your router?

I don't think it's your network card in issue because it can see the network. I believe the problem is in your router settings.

I hope one of these fixes it for you, but come back if you're still having issues.

3 Likes

Sorry for the late reply.
I couldn't see access control was on or off in the router configuration page. I did manually add the Mac Address on the router settings. But it still didn't work.
As for isolated networks, I couldn't find a similar setting. Could you please drop a hint as to where it could be located?
I manually added the ip and netmask via the Edit Connections on Zorin, but it still doesn't work.
Max number of allowed connections on the router is 22, yet that shouldn't be the problem as there are only 10 devices including the old pc using wifi.
Proxy setting was on automatic, still doesn't work.
I added the ip address and netmask using Edit Connections on Zorin, yet it couldn't connect.

I don't know exactly, it is supplied by the ISP, and serves my purpose pretty well.

I also think so, as when Windows was installed, the adaptor would get disconnected pretty frequently only on my home wifi.
One small thing, when I change the network from Client to Hotspot in Edit Connections, the wifi connects, the symbol appears on the taskbar, but there is no internet. Could this signify anything?

My problem is solved.... Yay!!!
I cleared the connection from Edit Connections and when I joined again, it connected
I myself don't know how it happened :joy:
I had previously tried it, but it hadn't worked. Probably the pc is now feeling sorry for his old friend.:grin:
Thank you so much @zabadabadoo and @337harvey for helping me out. I am extremely grateful for your support.:relaxed:

1 Like

Make sure you go through your router settings and schedule a reboot once a week or two weeks.... depends on the model (probably a Motorola though there is a model that starts with a, i don't remember the name of the manufacturer, the providers have been supplying) whether your able to specify how often. The sticker on the back will tell you the manufacturer and model. Searching "how to " and what you want to do with the model number and it should give you results to configure it if you're not sure what you're doing.

Not all routers have isolation and a quick switch for access control. Digging around in the menu pages can give you a better sense of what the routers capabilities are and how to do things in it.

Like your phone, router restarts are important to clear memory leaks, empty cache and force updates that may not occur until much later. So ensure that the router reboots regularly during the least active time at least once a month if not more. I normally set them up for once every two weeks.

Any major changes require you to restart the services if not the router to begin enforcing them. Adding the Mac address and clearing the cached connecting is what did it, but that requires the router restart because changes are not made to the running service in memory. The new rules had to be added to the service by the router to be enforced.

I'm glad my post was able to assist you.

Thank you so much. I didn't know restarting the router helps clear connectivity issues. I found out the model on the configuration page, and downloaded the manual from the ISP website (the ISP manufactures their own routers) and there it was written that restarting that router twice every week is a good practice. I did restart it, and the range has increased.
Thank you so much for help, you helped me learn so much.
Btw, I am thoroughly enjoying Zorin and Linux in general, I guess I don't need gates and windows on my primary pc too.:grin::grin:

2 Likes

Unfortunately, resetting connections didn't work for me.

I've installed and updated (via ethernet) Zorin Lite 15.3 32bit on a Packard Bell Easy Note R3400 using an internal Ralink RT-2500 wi-fi adapter: this one is recognised by the os but when I try to connect to any wi-fi signal available, it simply doesn't. A small window appears saying Disconnected, you're off network.

I've installed the same zorin os on another Packard Bell netbook: the wi-fi network is the same and it works smoothly.

I would recommend re-installing the Linux Kernel - or if it is a fresh installation of Zorin Lite, just reinstall the OS completely.
The Ralink RT-2500 should be completely supported by the kernel.
If that does not work; you may consider trying a Different kernel version. But at that point, if it was me, I would start troubleshooting the hardware.

You may also want to check your router settings. You may have access control on which doesn't allow new devices to connect. I've forgotten this feature a few times and had many headaches because of it. You may need to whitelist your mac address.

If you know the ip address range you could hard code your ip address (something higher in the range isn't normally assigned automatically). Go into network settings, then connections properties, change from dhcp to manual and type the ip address and subnet (10 beginning ip subnet is 255.0.0.0, 172 beginning ip subnet is 255.255.0.0, 192 beginning ip subnet is 255.255.255.0). Make sure to include the default gateway, if you don't this won't work. If access control is off and this works, try restarting your router, there is a problem with dhcp. It could be the wifi adapter or motherboard are done if this doesn't, further testing would be required.

Edit: i don't know how long it's been since your modem has been up, but powering it off (unplug the modem for 30 seconds... power cycle the router right after this) may help clear up issues. Modems aren't as smart as the rest of the devices for networks, but they can get bogged down to and ignore updates from both the router and isp. Since a reset of your router helped for a time, I'm wondering if this may be modem or router related. If you download netspot from the android store to your phone it will show networks available, channel, signal strength and more. Check signal strength is good where you are attempting to connect, make sure only one or two other networks are using the same channel (default depends on frequency) and if there are more try changing the router channel from automatic to a specific one. Make sure your router has a decent dhcp lease time (about 24hrs, less if you want it to renew more often).

1 Like

Router works well with almost 10 other devices, including 1 Zorin Core 64bit and as I said earlier, 1 Zorin lite 32bit.
It was powered off a couple of times last night after the install, just to make myself sure that wasn't a connection issue

ouch, this is a strong one, but considering that the hardware works fine with Windows 7 in that pc...
And considering that both os's are installed with grub(?) it sounds just difficult
These are the linux images installed:
ii linux-image-5.4.0-45-generic 5.4.0-45.49~18.04.2 i386 Linux kernel image for version 5.4.0 on 32 bit x86 SMP
ii linux-image-5.4.0-74-generic 5.4.0-74.83~18.04.1 i386 Linux kernel image for version 5.4.0 on 32 bit x86 SMP
ii linux-image-generic-hwe-18.04 5.4.0.74.83~18.04.67 i386 Generic Linux kernel image
Then?

Depends on the WiFi card, sometime it cannot connect channel higher than 12. I have such WiFi cards and was forced to change the channel of WiFi to lower than 12.
To avoid such situation, it is better to use a fixed channel rather than auto select.

The current channel on 2.4GHz is 11
The current channel on 5GHz is 100 (auto)

You are in the safe range then.
Do you have any live USB you can test your system with?
Ideally the one that uses different version of kernel than what has been installed on this laptop.