Zorin OS not working with integrated Alder Lake GPU

Interesting! Can I install the newer kernel also if already installed or would you recommend a new installation? Which repository would I be required to add?

I'll find you the link to the guide. You can use what you have installed.

Recommendation: READ THROUGH THE ENTIRE PROCESS PRIOR TO IMPLEMENTING. You won't have to add the jammy repo if you aren't going to a 6+ kernel.

Try only a few versions above the current kernel first....5.16, 5.17, 5.18, prior to trying 6+.

Thank you, I'll try that :hugs:

Does it make more sense to start from reverse, so 5.19, 5.18, ... instead of 5.16, 5.17 ... ?

I understand your idea, the point is to go only as high as you need for the support of your hardware. The further away from the current kernel, the better chance that certain configuration files from the Zorin devs won't be in use and you lose the benefits, possibly even break your system.

While newer can be better, more bugs may have been introduced, parts of the system may be broken, some improvements may be introduced, but the opposite is also possible.

I see, makes sense. I now tried 5.16 but it seems it wants libssl3 and libc6 >= 2.34.

Then add the library from jammy, but do not update and upgrade while that library is in your source list. Only install that library.

1 Like

EDIT: Wait, seems I need to remove the (unsuccessful?) installed kernel 5.16 first.

It seems the tutorial doesn't work any more. Installing libssl3 fails with following error:

root@office:~# apt install libssl3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libssl3 : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed
 linux-headers-5.16.20-051620-generic : Depends: libc6 (>= 2.34) but 2.31-0ubuntu9.9 is to be installed

Then use the command sudo apt install libc6 libssl3

Whatever you do, do not upgrade gnome... at all. The libraries should not be an issue at all... mainly gnome. Gtk libraries could be an issue.

Alright! Installation of 5.16 was successful. However, booting only possible with nomodeset. I think I should also test 5.17 so.

I would. Once you get somewhere (5.17 or 5.18) i would fine tune within that version ( i.e.)

Unbelievable. With 5.17 not only it worked immediately, booting is even faster. I immediately received 4K resolution and both screens were detected.

Shall I now remove the repo for the mainline installer? Will Zorin OS ask me for upgrading Gnome in future? Because you said it should not be upgraded.

Thank you so much! :hugs:

Remove the "jammy" repo prior to any updates. Once that is done, if you see an update for a kernel lower than yours, do not upgrade... you will have to mark the current kernel for hold, only if that occurs.

What version of 17? You can get it with uname -r

I hope all will run stable, no freezes or so. Thank you very much :slight_smile:

I used the latest version of 5.17:


I would stay within that version, upgrade through .15+ if a few things aren't working (hwe and such) if you need. 5.18 possibly if you can't wait for the next subversion.

You removed the jammy repo? This is important!

sudo add-apt-repository remove "deb http://ca.archive.ubuntu.com/ubuntu jammy main" i believe.

Yes, I'll keep that! The jammy repo I immediately removed after installing libssl3 :slight_smile:

1 Like

Please mark the solution that fixed your machine and take a gander in the tutorials section for many more helpful guides.

The mainline repo will not update or hurt anything....i would leave it for now. Use [HOW TO] Easily reinstall programs when Reinstalling Zorin to backup applications and home easily for reinstall. Use rescuezilla and timeshift to backup everything (recommended now that it works).

Please open a new thread. This is for both your benefit and that of anyone that reads this thread.

Go through your normal operation, you may end up including a few other things. Once you have done a few things you normally do, evaluating as you go, create the thread with those issues you find.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.