Zorin OS on ARM64

I have a question, when are you guys planning to make a arm version of zorin os?
I recently got an m2 macbook air and ive really been getting ready to move my files from my old laptop to the new one.

1 Like

The best question asking a developers. They know real answear.

So ZorinArm is being worked on, with no eta last i knew. What i did for my rpi400 was install ubuntu 20.04 for arm, then add the zorin repos, and then install the zorin packages. You'll find some apps won't install as they are not arm compatible, but most of the zorin stuff is such as themes customizations ect.

That said, this is not officially supported and is a use at your own risk, so don't use as your daily driver :slight_smile: And support maybe limited as i know apple tends to be stingy with sharing hardware info. One aspect that didn't work was Wine that maybe because it was a rpi or might be because of the arm architecture.

Found it


I am stuck on the step to add zorinos repository :confused:
It does some errors and I am unable to do the apt install zorin-os-desktop because the repository is not loaded :confused:

ZorinOS doesn't support Jammy there's no Jammy repo yet to my knowledge* you need 20.04 Focal Fossa. Try with this link Ubuntu 20.04.5 LTS (Focal Fossa)

1 Like

Thanks a lot! Worked relatively fine, but I am fighting against dependencies :confused:

And you've added the repo? it looks like the package is there, its listed in launchpad, maybe try downloading it directly and installing, or readding the repo and doing a apt update


1 Like

@Frog ran into this same dependency issue in a completely unrelated thread:

I wonder if a server was down?


That could be a possibility as well, also occurred to me, even though its an icon + theme gtk pack (essentially) its might also be marked as amd64 only in the repos although it wouldn't matter really

1 Like
1 Like

I saw that, I need one of those too :rofl:

@ivancarlos I reinstalled ubuntu 20.04 and then the zorin repo on my pi400 today and had no dependency issues, try install zorin-os-lite-desktop that worked without error for me.

1 Like
1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.