Zorin OS Pro doesn't seem so smooth to me

Hello everyone. I have Zorin OS Pro installed for the past 3 days. I'm very pleased overall but one problem i seem to have and can't get rid of is that the overall experience doesnt seem to be smooth. At least not as smooth as i know it can be in linux or in gnome in general. Take it from opening apps or just plain animations seem a little bit off. I tried searching for drivers in "additional drivers" ui but there aren't any available updates.

My system is not considered to be low-end. It is paired with a 3200g amd apu + 16 gb 3200Mhz ram.

We can try updating your AMD GPU drivers

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt upgrade

I have noticed one thing about the oibaf repo, that is, I keep getting driver updates constantly within just a few days and they are huge in size...sometimes up to 200mb. That's why I stopped using it and the newer kernels had no issues either way.

1 Like

Can you share with the user what kernel you are using Elegant_Emperor?

welcome to one of two things:

  1. outdated Graphics Drivers (if you're even using the correct ones in the first place)
  2. X11. if you're on an AMD or Intel graphics system, make sure to select "Zorin desktop on Wayland" on the Login/Password screen

to sum up what "Wayland" and "X11" are, they're basically the software used to make rendering windows and such possible in the first place, though, X11 was made in the literal 80's.
Wayland is much more modern, and generally runs faster and more fluently. Though it might come with some compatibility issues on some somewhat exotic hardware configurations

I am using kernel 5.16 in Pop! OS but my problems were fixed since kernel 5.13.

I tried this. It installed a bunch of things but there isn't any improvement.

I tried many many things but unfortunately, nothing worked. I came to the conclusion that Gnome is not for me after all. I installed KDE and the system works flawlessly and smoothly.

1 Like

I have just installed Pro 16.1 and is working just fine for me using Gnome. Funny enough, I installed this on a Tuxedo laptop, which already comes with Linux by default (Tuxedo OS - a mildly modified version of Ubuntu using budgie desktop), and it works even better with ZorinOS.

1 Like