Zorin OS Update After Sept 6 '21 kernel 5.11.0-34 Black Screen

Approx. after Sept. 6th 2021, if you updated your copy of Zorin OS 16 and got the 5.11.0-34 kernel, you may experience black screen on logging in. This may primarily affect Nvidia users.


Boot into the Recovery Menu by tapping or holding the left shift key at boot.
From Advanced Options for Zorin, select to boot from the working 5.11.0-27 Kernel.


Getting reports that initially, updating the Graphics drivers allows the 5.11.0-34 kernel to work - but then it crashes later.
The best option is to stick with the 5.11.0-27 kernel at this time.

You can lock the kernel to prevent it updating with:

sudo apt-mark hold linux-image-generic linux-headers-generic

Unlock it with:

sudo apt-mark unhold linux-image-generic linux-headers-generic

Further reports that this affects Suspend function. Confirmed on Linux Mint with Nvidia Drivers 470, 460 and 465, as well.


tried this many times, still no menu continuous black screen,
opened a ticket with support, i cannot wait a few days for an answer as this is my main machine which runs a few VM's
will probably need to reinstall , -sigh-

Update 1 - Have reinstalled, once installation was complete, asked to reboot, attempted reboot, got the same error as previous
" ACPI BIOS ERROR (bug) : Could not resolve symbol ..."
and machine hung.
forced reboot, everything is up now and asked to update, unchecked all system related updates and continuing

Update 2 - All is installed and running , back to normal, just avoiding system updates for now :slight_smile:

Intel® Core™ i7-2600K CPU @ 3.40GHz × 8
NV124 / NV124 ( Nvidia GTX970 )
Zorin OS 16 | 64-bit | X11 |

1 Like

This is clearly a major issue as of late, and its something that I think the Zorin teams needs to fix ASAP. If I was the Zorin team, I'd not be having a good day. Cause putting myself in their shoes, I'd like like, just great, we put out a brand new OS, and now everybody's computers running Nvidia GPU's are all going to black screens after updates. We can't catch a break!

Hopefully the team can get this issue resolved, cause its clearly widespread, judging by all the posts I am seeing in here. Good PSA Aravisian.


these things happen, best to report and try the suggested solutions and do what you can. Moving from windows to this was a big step for me, loving the OS thus far.


Confirmed that kernel kernel 5.11.0-31 is included in this.

Further reading:

1 Like

Update: ZorinGroup is continuing investigation into the probable regression in kernel 5.11.0-31 5.11.0-34
It appears to affect primarily Nvidia Users (if not only Nvidia users).
Some Nvidia Users have said they had success on switching to a non-proprietary driver. Others have tried that and suffered a crash not long after.
This affects all Ubuntu based Distros, including non-Zorin OS Distros. It definitely affects Nvidia Proprietary (non-free) drivers.

If you are not using Nvidia - You are probably fine.
If you are using Nvidia - recommended that you stay on the 5.11.0-25 or 5.11.0-27 kernel temporarily. Please follow the guide in the O.P.

I tell you what, it makes me feel much better knowing that the Zorin brother's are on it. I am lucky that my workstation computer doesn't have a discreet Nvidia GPU, as my workstation uses integrated Intel HD graphics.

Stil though, I like knowing those two are working on this, cause I know they will have this fixed for people. If there is one thing you can count on, is the Zorin brother's will get it fixed. I couldn't say the same for some game developers lol.

Also, thanks goes to Aravisian for doing some of his comparison testing as well. Also, there is a metaphor here, and that is, newer is not always better lol.

1 Like

This statement right here.

It is an often irk of mine that the common assumption is latest kernel needed.
There are a lot of machines being used with Zorin 16, right now - perhaps even the majority - that would work on the 4.15.0-75 kernel.
Some might even work better on it than the latest.
Some might be broken by the latest.

The kernel version number increasing may give a false sense of security. Yes, a higher kernel May Be what someone needs. But it is all about application, not "newer". It's about what applies, not what is higher in number.
Sometimes, I think the kernel versions should be named, instead of numbered.

uname -a

Linux $USER-Computer Hungry-Hungry-Hippo-generic #29~20.04.1-Ubuntu SMP Wed Aug 11 15:58:17 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux


Heres mine after running uname -a

Linux thegreatandpowerfulyogert 5.11.0-34-generic #36~20.04.1-Ubuntu SMP Fri Aug 27 08:06:32 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Yeah, but your inferior kernel is still operating on the antiquated numbering ideology.

LMAO :rofl:

Just as you said, its not about how high the number is, its about weather or not it works. Video drivers are the same way you know. For example...

If the Nvidia 460 driver is working perfectly, but you upgrade to the Nvidia 470 driver and then suddenly you black screen at boot. The answer is, the 470 driver sucks, revert back to 460. lol

Th truth is, which kernel works best, which Nvidia driver works best, really depends on the machine. What works for somebody else's machine, doesn't mean that it will work for your own.

So, I guess the point is, go with what works, and have less stress in your life lol.

Kernel upgrade 5.13 and 5.14 guide

I just noticed it this morning.
Even I put an hold of 5.11.0-27 kernel, Updater pops up and still wants to install this problematic kernel :face_with_raised_eyebrow:

I am not adventurous enough to try the manual kernel update. Hmmm...

1 Like

This is odd. Mine no longer offers the -34 kernel in the updater since putting the hold.
But I did experience a different oddity... My hold vanished yesterday. I replaced it and the -34 has not been offered since.
But yes, yesterday I noticed it offering the -34, so I checked the held packages and it showed none :expressionless: Very strange. I re-ran the apt-mark hold command and it currently is still holding.



Linux evill 5.11.0-34-generic #36~20.04.1-Ubuntu SMP Fri Aug 27 08:06:32 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

this is after enabling the lock, and still upgraded to -34
all seems to be working well though ( knock on wood )

Well, the kernel that I have came with Zorin OS 16 PRO, and I don't believe the kernel has updated beyond 5.11 on my machine. Let me double check... Nope, still says 5.11.

So, I am not sure why the kernel is updating for you guys, is it because were using different desktops? Like PRO uses core right, and lite is XFCE right? Does that even matter? IDK!

We are talking about kernel 5.11.0-27 vs 5.11.0-34.
Both are 5.11 kernels.

The problem is Nvidia users like myself have a problem with 34 kernel, try to block the kernel update but still got the notification for kernel update to 34.