Zorin Pro 16.2 reset brightness to minimum after each restart

Hello there!

I am new to Zorin. Installed 16.2 Pro today next to my W11 and I am happy with how simple to use this OS is.

I am having one small issue.
No matter what brightness I set, after restart I have lowest possible setting.
Before I start working I have to max brightness first every time I boot the PC.

In power settings I have dim disabled.

I will really appreciate your help!

Thanks,
Gracjan

Does your computer show the automatic brightness option? Or is that what you mean by 'dim'?

If it does show that option, disable it and test it. Hope this helps.

If you installed tlp, you can set the default brighteness there. If not, check your battery settings, since the default power saving configuration may drop your display brightness to the lowest setting to conserve power (its one of the largest power draws on any system). Checking the video card settings may reveal that as well.... unfortunately, it is controlled by many parts of the system.

1 Like

Nope, there's no auto adjust option on my lap.
Dim only when inactive I mean.

There's no option for brightness either in Tlp or battery options... :frowning:

You would have to look at the advanced portion, under display. It breaks down all the devices, from usb's and hard drives to specific hardware devices...cpu, gpu, wifi/ nic.... it is listed and adjustable.

1 Like

I use the Brightness controller app to set it and forget it:

sudo add-apt-repository ppa:apandada1/brightness-controller

sudo apt update && sudo apt install brightness-controller

Launch Brightness Controller from app menu.

1 Like

Doesn't work for me.
Set the desired brightness, saved, restarted and all dimmed again.

You might try this one

Open the file /etc/default/grub using gedit or any other text editor.
Find the below line.

Find the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Change the line to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

update-grub

If that one did not work and you have a nvidia card you might try this one too.

sudo gedit /etc/X11/xorg.conf.d/10-evdev.conf

Add the below lines entirely at the end of this file and save the file.
Section "Device" Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation" Option "RegistryDwords" "EnableBrightnessControl=1" EndSection

Once you are done, restart the system.

You should be able to control the brightness now using the laptop hardware keys.

I am able to adjust brightness using hardware keys. The only problem is the brightness resets every time I load OS.
So, your steps still apply to this?

AMD card here.

Have you set the brightness on the actual Monitor Controls?

Yes, it's Fn+F7/F8 for me.

Is this a Notebook computer?

I was thinking Desktop Computer with a Monitor. One that has Settings and Controls built in...
If I was smarter, I would have asked if you were on a notebook computer sooner. :wink:

1 Like

Problem solved.

I have edited grub file using:

sudoedit /etc/default/grub

Added

acpi_backlight=vendor

To this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

So it looks like this now:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Saved on exit and updated grub using:

sudo update-grub

Full brightness at startup finally! :slight_smile:

1 Like