Zorin shutdown freezes

So, I'm still quite new to Linux in general so I'm sorry, I might need to be babied on any solution or getting information. I don't know what exactly is going to be helpful (sorry if I didn't post, you may need to smack me and tell me how to provide it..) And I'm unsure if this is technically a bug, so I figured I should ask here before I post this as "Oh this is definitely a bug, plz fix!"
TLDR: Zorin usually freezes whenever I shutdown (or restart) the system.
Context: This is most reproduce-able for me if I leave Zorin on for some 5-ish hours or longer but I've had it a few times from just minutes or so. I seem to average some 13 hours with Zorin on, though.
When it happens, most of the time I'll have the Zorin logo show up, no animation, and it will just hang there, requiring me to press the power button. (Fortunately, this seems to have no ill effect on the system... That I've seen anyway..) I used to have an error about finalizing DM devices, but I believe that was a separate issue relating to my SSD (not the main drive) being dead; it has since been removed and is being examined by a friend. I would sometimes have this error on shutdown but I don't seem to anymore. For an old image of how it showed up (and hung) it's this:


If it at all affected anything, I installed Zorin with secure boot enabled, but has since been disabled with no apparent effect. My system is this:

  • MSI MAG H410 infinite _MS-B915_
  • Timetec 32GB RAM KIT (2x16GB) DDR4 2666MHz
  • Intel Core i5-10400F CPU @ 2.9GHz x 12
  • Zorin is currently running on a 256GB NVME, I believe WDC PC SN530 SDBPNPZ-256G-1032 (21111000) is the model? (From the disk page.) Looks like it's in FAT 32.. (Running Zorin 17.1 Core under 64-bits... I just noticed this, is this going to be a problem?)
  • There is an extra 1TB HDD that was NFTS, but I have since sanitized the disk as a storage device Ext4 and put my data back on it.

Is this a dual-boot installation or purely Zorin?

Purely Zorin, I did a clean wipe to remove Windows from the main drive.

What graphics chip is in use? Intel? or is it one of those discreet graphic options of Intel/Nvidia hybrids? I ask about the graphics as this is a possible solution (as Zorin 17 is based on Ubuntu 22.04):

Oh sorry, I forgot. I have an NVidia GeForce GTX 1650S card. I have the "driver metapackage from nvidia-driver-550 (proprietary)" driver installed. I will take a look, I suppose whether this is the solution will be uh... Late.. But thank you all the same. :slight_smile:

I didn't have any problems last night with shutting down my system, but I'll keep monitoring just in case it was a fluke. For now, this seems to have solved the issue! For reference, I did the following:

  • Downloaded the latest NVIDIA driver from their website (535) and attempted to run it but.. Decided to not continue since "applications were using it." (lol)
  • Tried the Gnome app for Software -> Menu -> Software updates -> Additional Drivers -> x.org. This might have worked, except I subsequently tried Rimworld and had 5 frames per second, so I decided to instead go with sudo apt install nvidia-driver-535 which, uses the same driver from the above gnome settings list (in case anyone needs this as reference) for driver 535. This allows Rimworld to run properly as well as (seemingly) shut down just fine.
  • Rimworld was honestly a fluke for me, but I don't have many other games installed. The other game that I would imagine would be more graphically demanding, LEGO Star Wars 3: The Clone Wars I recently installed, was showing no issues. (These are the two benchmarks I have side by side anyway..) The 535 driver let Rimworld do 60FPS.

In case it happens for anyone else, despite the normal Windows method or anything similar, whatever, check the NVIDIA website for your card first! Despite the packages that go above 535 (or whichever driver version) apparently does NOT matter for the highest value/version, I'm guessing that's bound to the cards themselves.

1 Like

Ones to avoid are those marked tested!