ZorinOS 16 shutting down

Around January 20th, I installed ZorinOS Core 16 with the hope of it working on a machine using the 11th Generation Intel Core i3. This was not the case. My PC began shutting down under "heavy" workloads without a visible reason, until I checked the logs. I saw that Thermald was shutting down everything after it recognized the CPU was reaching the critical temperature of 100°. From all over the internet I was looking for solutions, and of course, to no avail. What happens before the shutdown is my fan begins spinning, gets to about 2500-3500 RPM, and then everything shuts down.

Here's what I tried...

  • Reinstallation of ZorinOS
  • Reinstalling intel-microcode
  • Setting up lm-sensors without it detecting my fan after running sensors

F.Y.I. Windows works fine and doesn't shutdown randomly under "heavy" workloads, my fan can spin up to 5000 RPM. I reinstalled Windows as a daily driver until a solution can be found.

Any help is well appreciated!

You may try some tools

sudo apt install thermald tlp indicator-cpufreq

Thermald and tlp just run, no additional configuration needed.
Indicator-cpufreq is an application that allows you to choose which Mode to run in, such as Performance or Power-saving.

I would also recommend cleaning out your vents with a can of air, just to be on the safe side.
Dust and Lint insulate as well as blocking airflow. Fan speed is less important that heat exchange is. If even Windows is cranking up fan speed - Ensure that the notebook is kept elevated on flat surfaces, never placed on a chair or blanket.

1 Like

Thanks for the suggestion, but it's an AIO and if you've read the whole post, I mentioned that Thermald was already installed and the reason it's shutting down. I've previously installed ZorinOS 15 on older hardware (also an AIO) about a year or two ago and it worked fine. Recently (about two weeks ago) I did take the machine apart and the fan, and vents, didn't need to be dusted off.

Have you tried that same kernel instead of the one currently included?

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

One question before I do that... Is it possible that this is happening because I'm not including coretemp in my modules file, as lm-sensors says to do?

I wouldn't think so, since this is set by the CPU itself. It's really not a good idea for the user to try to set (or change) the max core temp.
From what you describe, it sounds like there is an issue of Overheating. Thermald is not the cause, overheating is - thermald is protecting the computer from heat damage by shutting it down.

Overheating - and its cause - really should be the focus. Sadly, it cold be software side. As you say that it is an AIO, free of buildup or dust.

I also have noticed a strange number of regressions on the later kernels...

For reference, here's the output from running inxi -Fad... inix.txt - AnonFiles

I'm presently running Zorin off of a USB drive, but I will take a look into dual-booting if nothing can be assumed from the inxi.txt! I just don't want to have my PC keep shutting down under what might be considered "heavy workloads" even though it happens when I'm just installing software (meaning I have the availability to go back to my previous OS when I need too).

all hardware can break, not just dusty hardware :wink: So i would not just look at the software side alone. Can you run the AIO without covers, maybe allow some external airflow to pass over it while you work? See if that helps. If so, then you know where to look.. :wink:

It's not the hardware though, again it can run Windows 11 perfectly fine. I opened it about two weeks ago and everything's normal, it's only a little over a year old. My previous hardware was about two years old when I installed Zorin on it, and it worked fine too.

P.S. I don't only say it's not the hardware because Windows runs fine, but also because other people appear to have the same issue with other Linux based operating systems where Windows also works fine. Doing a search on Google returns the same solution everywhere... "You need new hardware," "It's broken," "Update your BIOS," "Install these packages," and so on.

Windows is a a very heavy OS, when I run heavy workloads, the fan will ramp up and then back down within a matter of minutes (so it's definitely not the fan because the CPU is being cooled)... This behavior is different with Linux based operating systems with my hardware (even Ubuntu)–the fan will ramp, I'll hear a click (or tick noise) from the back of the machine, and everything will go dark. It'll all shutdown. I can't seem to come to a conclusion on this issue even with the solutions that I'm being given and have tried.

1 Like

Have you tried running it without the cover?

I am not saying its the hardware perse, it could very well be the software indeed. I'm just saying what i would do. I'm not saying you should, just offering suggestions. It's up to you what you try or not :wink:

I have not tried running it without a cover, and don't plan on it. lm-sensors is failing to detect my fan, and I'm 50% sure that's the problem.

Adapter: ISA adapter
Package id 0:  +38.0°C  (high = +100.0°C, crit = +100.0°C)
Core 0:        +36.0°C  (high = +100.0°C, crit = +100.0°C)
Core 1:        +32.0°C  (high = +100.0°C, crit = +100.0°C)

Adapter: ACPI interface
temp1:        +41.0°C  (crit = +100.0°C)

Adapter: PCI adapter
Composite:    +28.9°C  (low  = -273.1°C, high = +78.8°C)
                       (crit = +83.8°C)
Sensor 1:     +28.9°C  (low  = -273.1°C, high = +65261.8°C)

I'm going to attempt to dual-boot with other solutions and see what works. I'll still accept suggestions, with updates on the situation here and there if need be.

As with every solution, I've reached the desert. Nothing in sight.

You have not installed Zorin OS?

I think we found the issue...
There are certain Linux Distros made for running off of a USB only. While Zorin can do this, it would not be my first choice for it.

You are cramming an entire OS through a USB port bottleneck.

This puts all performance onto the RAM and CPU and it must work overtime in order to keep up with it.

I don't think you understood what I meant. I installed Zorin on my SSD before, but switched back to Windows 11 because of constant shutdowns, I'm not staying with an OS where I'm drudging through mud. For today, I was running Zorin off of a USB drive, then decided to dual boot it later on. No solutions I tried worked, so I gave up and uninstalled it from my SSD... Once again.

Obviously I've installed Zorin on hardware before, so I'd know what not and what to do.

You might try installing fancontrol, then running

sudo pwmconfig

This would replace lm-sensors.

Another option worth looking into is undervolt to drastically reduce heating.
This comes with a worrysome disclaimer... Though I know of no one that ever actually experienced troubles with it. That disclaimer usually means I am not quick to recommend it...:

The problem is that I installed fancontrol today and ran sudo pwmconfig to it saying that it couldn't find any fans... I'm not sure what's happening, maybe the fan is more so controlled by the BIOS and it's supposed to communicate that to the Kernel via a driver, I'm not too sure. I've run out of options unless the people who made the Linux Kernel somehow find a fix.

It is a stumper. I can certainly understand your continued frustration.

Linux is great. But not all encompassing. Hardware manufacturers really only plan for and care about Windows.
That is how they build them. While the Big Dogs are getting big money, Linux devs are left scrambling to backport, patch, port and adapt to a system that doesn't care about them.
If the hardware gets too close to the edge, it will have Windows support because it was made that way, but less Linux support because it's too close to the edge and Linux has not yet covered it. Which... makes some users complain that Linux isn't mainstream enough.
It is very frustrating.
Given that you have an 11th gen i3 (Which I am using a 10th gen i3), I would have thought you were pretty covered. But the AIO may be a bit of a wrench in the works.

1 Like

Sorry for this slightly late reply – is there any way I can uninstall thermald? I installed another Linux-based OS and nothing shutdown without that package, and it was running Linux Kernal 5.10 or 5.11. I was monitoring my CPU temperature after running multiple heavy workloads and my fan did keep the temperature under 97° (base temperature of around 35°) the whole time... I never got that far with Zorin.

Yes, APT can easily remove it with

sudo apt remove thermald

You may want to clean up after:

sudo apt autoclean && sudo apt autoremove

1 Like

Thanks, I'll try that tomorrow then! If it works, I'll let you know and probably mark it as a solution. If something else happens, I'll investigate further.