16 Pro + Win10 + UEFI problem installing

I am pretty sure that the Zoringroup has my picture posted on their wall.

They use it as a dartboard.

Hopefully the fix will be released soon allowing you to get your installation finally done. I wonder if you will be as impressed with Zorin OS 16 as I have been... I was trying out Ubuntu 21.04 (And 20.04) when I got my grubby mitts on the Zorin OS 16 Alpha build. It took me about ten minutes to know that Zorin OS 16 was going onto any of my computers I could cram it onto.

I watched some of the youtube video reviews in full screen and 16 Pro looks pretty fabulous. I've been waiting a while to move over to Zorin, since about version 12, and ditch Windows entirely and now is the time.

Would you have any recommendations for a Linux newbie like me in terms of books I can get in order to use the command line/terminal and general Linux use? It's not just the GUI I like, I'd also like to understand and use the terminal and discover the power of Linux.

I am not really aware of many books on it. The reality is: The terminal is all about Practice.

Using zsh with the addons "Word Completion" and "Word suggestions" helps a great deal.
Member Taha_mcp has started a project (Currently in development) of an online terminal emulator that can be a Reference Tool for terminal commands and practice point to ensure the use of the terminal - in a safe environment with no risk of mistakes on your system.

For me, when I moved over from windows, I had barely ever opened the command prompt on Windows. The terminal was scary. At first I complained that I wanted Easy Installations like Windows had (Somehow... I forgot the countless times Windows installations failed with some obscure error that I could find like no help on...)
After a few troubleshooting adventures (of my own mistaken making) and installations using the terminal, that fear began to subside. I began to play in the terminal. Like a kid.
And I never messed up my system by doing so. Ok one time we suspect I did a sudo apt autoremove that did harm... But never confirmed that. Either way, the fear was unfounded.
But the power it wields is certainly not. For such a basic looking thing... If Windows is Grand Central Station then the Linux terminal is The Q Continuum.
The best way to learn it is to get in it and Do Things.

Hi Aravisian, I tried the Zorin guys fix for Dell UEFI problem but having no luck so far. Maybe you can feed it back to them.

They note this:

  1. Navigate to General > Boot Sequence > Add Boot Option
  2. Select the "Boot Option Name" and insert "Zorin"
  3. Click on "..." in "File Name", select the Zorin OS Installation USB Drive and EFI / Boot / grubx64.efi

However, when I do this there is no grubx64.efi anywhere to be seen. The USB is recognised, along with the SSD, and I can select either one and have a look at different .efi files in different directories, including a Rufus one (I used this to flash the USB) but no mention of that particular grubx64.efi file.

I'm going to try Balena etcher to see if that makes a difference but the reason I used Rufus is, as you suggested, you can specify GPT and UEFI.

Secure Boot in BIOS is turned off by the way, as is Windows Fast Boot in Win 10 and I also disabled Hibernate in the registry just to make sure. POST Behaviour in BIOS is set to 'Thorough' as that's also recommended.

Edit: Should also say that I tried this, as suggested by Zorin guys:

"If the system can't identify the USB Drive at step 6, you can unplug & re-plug the USB drive to see if it changes inside the "File Name" > "..." menu."

In the screenshot below, you can see my path in the pathbar: /media/mech-1 (that's my username)/PNY (that's my usb)/EFI/boot
Within are the files. Can you follow that same path - /media/$USER/Your-USB/EFI/boot and ensure that those files are not present?

Err....probably not....I'm doing this in the BIOS Setup and so if the file isn't there I can't select it. I've navigated both the Boot and EFI directories on the USB ....again, from the BIOS Setup, following the Zorin guys instructions. When I click on the "..." for File Name.....I get lots of different types of .efi file showing and which I could select....but no grubx64.efi file....anywhere.

...and so you know, this is how I flashed the iso file:

1 Like

I meant by plugging the usb drive into a working system and just looking in the file manager...

As far as not seeing it from within the MB's settings... I am not sure... I would need to try replicating this just to see if I can spot something you don't... But I am not on a Dell (I uhh... I worked for Dell once, many years ago...)

By the time we suss this out- the corrected copy of Zorin OS 16 will probably have been released.:expressionless: LOL

I'll give that a go, just trying to flash it with Balena again but it keeps failing, Rufus flashes OK. I want to see if there is a difference when I boot with the USB in and try to see if the grubx64.efi is there when flashed by Balena. I doubt it but want to rule it out.

Yeah and I'll have even less hair than I do now :frowning: but hopefully my sense of humour will remain intact! I'm not going to give up because I really want Zorin as my OS of choice. Even if it means I have to vaporise Win 10 before I planned to.

1 Like

@Rory have you tried using Fedora Media Creator to create the bootable USB? I'm pretty sure FMC makes bootable media compatible with UEFI and secure boot.


Well, I appear to have a Zorin 16 Pro system up and running alongside Windows 10 on my Dell Laptop :slight_smile: am writing this in Firefox on Z16Pro....yabbadoo.

The grubx64.efi file was on the Balena flashed iso and so I could add Zorin as a boot option as per the Zorin guys fix. Strange that the grubx64.efi was not present when flashed by Rufus.

Anyway, all done. Dual boot to Win 10 works.

One quick question, once I check out the things I need to I'd like to get rid of Win 10 and just have Zorin on this laptop. Would that simply be a case of running the install routine again and selecting the option to wipe everything and install Z16Pro afresh?

1 Like

Yes, you can do it that way or...
You can use the partition manager to reclaim the space taken by Windows, expand the space allotted to Zorin into that - then Update grup and update initramfs.
When you are at that point, if you want to reclaim the space and keep your Zorin Install as is, you can start a thread if you would like a hand.

Aravisian, that's great and when I'm at the stage I'll probably start a thread as you suggest.

Many thanks for your help and patience with all this, it's sincerely appreciated and I'm grateful to you.

...and....damn.....Z16Pro is just so speedy on my laptop....and gorgeous....and I'm off to play!

1 Like

Hi Rory,

Firstly, Balena Etcher is a pile of junk. It never worked for me on several different laptops. So I'm not sure why team Zorin insist on using this worthless tool.

Secondly, make sure you do a full format of your usb not a quick one(I had some dodgy fake ones from ebay which caused me problems).

Rufus seems to be the way to go. Did you try burning the USB in DD mode instead of ISO mode? This worked for me (when you click the button to burn the boot image, it will pop up which mode you prefer).

I found out in the end I had dodgy USB drives. I ordered new ones (offical genuine Kingston and paid a bit more for a 32GB). I then used YUMI Legacy tool (v2 something) to create a "multi boot" USB. On this I uploaded Zorin, Kubuntu, etc. just to test whether it was the Zorin ISO or something else.

Anyway, long story short, I had to disable secureboot and enable "legacy" options in the Bios. Then finally it started working.

I admit, Zorin should offer some education on dual boot topics (although it is outside the scope of the OS itself), this is where it has a chance to stand out as a distro compared to other sites that just expect users to endlessly google all day.

@swarfendor437 had written excellent unofficial manuals for Zorin OS - the latest being for Zorin OS 15 - much of which is still applicable on Zorin 16.

I fixed it by doing this:


It worked for me where Rufus didn't work in the past. I use both to be honest. I admit, this could be because of an option I used in Rufus. And sorry I don't recall the specific situation but just remembered this.

There is a lot of documentation out there on dual boot topics. Dual booting comes with its own set of challenges. But I guess, unlike the solution I will go for, with a laptop you do not have that option and you are stuck dual booting.

Or that installing Zorin on the a USB connected drive. Carrying around an external disk is kind of a nuisance if one needs mobility though.

1 Like

Yes, thanks for clarifying that, it is what I meant, it becomes a nuisance and that is the key word I should have added to what I wrote.

1 Like

That is not completely true. In my distro hopping I tried lot of different distros and different tools for making bootable usb.

and it is really funny. Some distro behave really well with Rufus, while other always fails. Same with "dd" or Etcher.

In Zorin case, I tried 4 different methods ( Rufus, dd, Ventoy and Etcher) and only succesfull was Etcher.

dont know why and how, but yes, it is working. So Zorin team suggesting Etcher, and yes, you should use it. Because they tested it. They don't want suggest something what is not working :slight_smile: