16 Pro + Win10 + UEFI problem installing

Hi, first ti9me here and Zorin newbie.

I just tried to install 16 Pro and it has not detected my Win 10 installation. I need to install it alongside at the moment.

First problem is that that the help file doesn't explain that I needed to disable UEFI secure boot and enable legacy mode. It wouldn't even see the USB drive without that. But then once I disabled UEFI secure boot and enabled legacy mode I could boot to the USB and then let the Zorin install file check run.

Once into the 16 Pro install routine it did not detect my Win 10 installation and I need to dual boot at the moment.

Any ideas? Thanks

Edit: I should probably add that I have a 1Gb SSD partitioned into 2 x 500Mb drives, one with the Win10 installation and the other I just formatted ready for the Zorin 16 Pro.

1 Like

Is Windows 10 installed as EFI?
IF so, you really want Zorin OS to be installed as EFI, not Legacy, as well. It sounds like your Etcher burned Zorin OS not in EFI mode. I recommend Rufus etcher if you are using Windows.

Cheers Aravision, yes, Win 10 is installed as EFI. I'll try Rufus etcher as you suggest, I used the balena etcher as suggested by Zorin. I'll let you know how that goes, the balena didn't appear to have the option for EFI mode.....

1 Like

Aravisian, no joy with the Rufus etcher. I set it to GPT for partition scheme and UEFI for target system. I then make sure that the BIOS has secure boot disabled and Legacy enabled (or it doesn't see the USB as a boot option).

Then restart and I choose USB option for boot disk, then the screen just goes blank.

So Rufus doesn't even get me as far as Balena etcher which at least loaded the Zorin installer and went through the install routine until it decides there is no Windows 10 system on any partition.....

A frustrating experience of several hours so far, Windows may be more expensive than the £39 I paid for Zorin Pro......but at least it installs and works without having to be a computer genius. I thought this version especially was to entice Windows users?

I contacted Zorin support but don't expect any reply any time soon as they just launched today. So I'm now stuck.....

If Rufus was set to GPT w/ EFI, then the BIOS settings cannot be set to Legacy. Legacy is MBR, not EFi.

Well, you can set it to legacy ROM and yet still be on UEFI (though with secure boot disabled) in Dell BIOS.....but still no boot option to USB. In fact if you don't enable Legacy ROM and Legacy mode (rather than UEFI).....no USB boot option is available.

Rufus was set to GPT and target of UEFI along with Zorin iso as boot selection.

Is there any help on this page?
https://www.dell.com/community/Inspiron/BIOS-Setting-to-boot-USB-UEFI-stick/td-p/6239562

I certainly understand your frustration, but I do not think that this is a Windows OR a Linux issue...

Unfortunately that page may as well have been written in Swahili for all it means to me.....but I do genuinely appreciate the gesture and your help.

The problem is that even though I have USB Boot Support enabled in the BIOS.....it just resolutely refuses to see the USB drive when booting in UEFI mode and will only see it in Legacy mode. But then doesn't do anything no matter what and no matter which USB port it is in.

Like I say, whereas Balena etcher did boot and did run the Zorin install routine but then refuses to see my Win 10 installation. I can't proceed then because it would wipe my Win 10 installation.

So I'm stuffed and am light by £39 in my wallet with nothing to show for it.

When you ran it from the Balena Etcher copy, did you try the "Something Else" option below the "Install alongside" or "Wipe drive and install" options?

As a SideNote: if you chose Zorin OS Pro - it comes with professional Installation Support from the ZorinGroup. Please keep in mind that hte ZorinGroup (The developers) consists of two people and as Zorin OS Pro was just released a few hours ago- they are probably swamped with requests so Please Be Patient.

No I didn't try the 'something else' option and I've lost the will to live for the night now. Spent all evening on it since I came home from work. It would mean flashing the drive using Balena again and then going through the whole thing again and it's late here.

Yes, I did send a support request to Zorin quoting my registration number and they just got back to me suggesting the same thing as you have, ie, use 'something else' option and manually partioning. Not sure I'm too thrilled at that idea because if the install routine can't see the Win 10 partition then who knows what could happen if I do things manually.

Have some rest (I could use some, myself... been troubleshooting Zorin OS, cars and other things all day so far...) Once you have more pep, we can walk through it monitoring to make sure nothing gets messed up.

1 Like

You're a good egg Aravisian, your willingness to help says much about you. I'll have another go tomorrow when my mojo returns. Cheers for now...

1 Like

I wanna say, I am no newbie, and a title like JUST zorin 15.3 trying to install zorin 6 does not worked !
I tried every possibility. redownloading the iso files, make the usb from a laptop tha tonly have zorin 15.3 on it, to try after to boot the 16 .. it failed .. then I use my windows 10 laptop with another usb, with etcher , rufus, in mbr in gpt, in UEFI in legacy just to say i tried it all, nada.. so someone lauch something to quick.. and with the level of quality the marketing as took the direction for, I would stop trying to help individualy everyone that will come with the same problem.. OH by the way.. what worked, is etcher making a usb on zorin 15.3 .. took the usb and boot it on my second laptop that have windows 10 and that worked.. so the usb is fine.. strange all this.. make me wonder, we my trusth is gone. (edit #1) sorry, I kept the screen at install zorin or try zorin on my wndows computer, i thought that was fine, but when i came to click try zorin its crash! so no can do also on y windows pc)

he need to go in the bios, remove PTT, and but secure boot at disable, whie his there, deselect s.m.a.r.t. and I readed you been there done that removed the fastboot.. under the boot secction where if its in legacy you decided of the order, if it's UEFI which boot will appear if you push F12, the section below, make sure there is nothing check about the legacy rom.. then save exit and tried again, but still wont work .. Rufus by default installed Zorin in mbr, btw for your infor guys, etcher when we can we shoudl go for that.. What it did to my wokstation that have only zorin 15.3 when I boot to install Zorin 16, is that I see ubuntu on first, on top, then the name of my sdd in second and in tird under the 2 other my usb.. UBUNTU? I tried, its my OS Zorin.. reboot tried the one with the name of my SDD, same OS that boot, and when i try to boot with the usb made on windows 10 with etcher, did not work, made by rufus in mbr and gpt for fun both, did not worked, when i tried etcher on zorin, did not worked either, used the image writer that come with zorin 15.3 nothing.. WELL nothing it boot a second to write error then my bios start is recvoery full scan from speaker to hardrive.. so I am going back to black...mad thought i woudl be windows free finaly

A quick update, several other users have had similar complaints- a far larger number than normal. This could just be the statistical odds following a release...

Or it could be that a package somewhere needs correcting.

Hi Aravisian, hope you had a good sleep after a long day? I finally got the 16 Pro to boot from the USB but had to enable Legacy ROM in order to see the USB drive. It's still in UEFI mode but has the option to allow Legacy ROM, without that it doesn't see the USB drive as a bootable option. I think it may be a Dell BIOS problem as you hinted at, though I'm on the latest version.

Anyroad, the install routine still doesn't see my Win 10 installation. I've disabled FastBoot, SecureBoot, ShinyBoot, DullBoot and TwoHoots. I had to revert to the Balena Etcher to flash the USB drive as when flashed with Rufus nothing happens, after boot to USB, except a blank screen.

I looked at the 'Something Else' option and printed out the manual partitioning guide that the Zorin guys emailed to me, it's from Ubuntu, except the pictures won't print out.

What concerns me is that if the Zorin install routine doesn't detect my Win 10 installation, why would the Grub (is that correct?) loader see it once I'm done faffing around with bizarrely named Linux partitions and having sphincter palpitations when I hit restart.......

I've ordered a new external 1Tb USB hard drive solely to do a full Windows backup, separate from the ones I already have. So I may wait until tomorrow until the drive comes and I've done that.

1 Like

No... lol
Can you try the tips in this guide (Will need to boot into Windows):

Turn your computer off, go to bed early!

I had already run chkdsk and even DISM to make sure all was OK. So it's a mystery.

One more thing. When I got to the stage of needing to partition, in the Zorin install using 'Something Else' option, my EFI boot drive is noted as something like sda1 but it doesn't show it as an EFI drive nor that it is the Windows Boot Manager. It says unknown. Which is a big worry for me.

However, my EFI drive is definitely the boot manager drive as you can see here:

The EFI partition should not be within the Windows Boot Manager. It is independent of the User Operating System (Whether Linux, Windows or Mac).