4K monitor @ 1280x800 max on desktop with RX480 displayport

Hi,
For 90% of my use, Zorin boots with 1280x800 resolution… not very cool.

I can see at the login screen if the day well begin at 4k or not.

So after some research (I am a newbie on linux) I found this command line below.
It had worked for a long but not now.
Maybe someone could help me here?

So in the past, I had to type those comand after each boot enable 1980 to 4k resolutions:

sudo xrandr --newmode “3840x2160_60.00” 712.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync

then

sudo xrandr --addmode DisplayPort-0 “3840x2160_60.00”

So when I typed those command, I could change my resolution into 4k or 2560 or 1920

But now, it doesnt run anymore
any guess ?

Ferris, France

Ferris, the commands you posted are exactly what I would have recommended - and they work on my machine. While you may check your graphics drivers and the kernel version you are running… The only logical reason I can think of (I am no expert) why that would arbitrarily STOP working is the Cable itself. Are you using VGA cable or HDMI cable?
The VGA cables are known to go out and cause this. If you have a spare cable or better yet, another graphic card physical port and a spare cable, you can narrow it down quickly (and let’s hope it is not the port on the monitor.)
You can also Clean the cable connections and ports using compressed air and cotton swabs to remove grime, dust or grease that may inhibit a proper connection.

To check your graphics drivers , you can use Jockey (Additional Drivers in the app menu) .
You can check your current Kernel with the terminal

uname -a

Should be running 5.4.0 or above.

Thanks Aravisian for your answer,

I am not with HDMI or VGA cable but with DisplayPort. This Pc has a dual boot with win10 and the same cable run perfectly with 4k resolution.

uname command give me : 5.4.0-60-generic #67~18.04.1-Ubuntu SMP

Alternatively, use isopropyl acohol (or even methalated spirits) on a cotton bud as contact cleaner.
(@Aravisian obviously has compressed air freely available in his shop, which may not be available to all) :wink:

I see something strange.
When I type my initial soluce, 3840 resolution well appear on screen setting.
Here is the strange thing :

  1. I choose 3840 and apply
  2. My screen doesn’t change anything but I have the message “would you conserve new resolution or discard” ?!?
  3. I discard and make a second try
  4. My screen become dark and I go to 3840 but within extended mode so I can only see less than 1/4 (top-left corner) of my screen because it is always into 1280.

What error do you see when you run the above commands?

I got this :

sudo xrandr --newmode “3840x2160_60.00” 712.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync

X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 16 (RRCreateMode)
Serial number of failed request: 43
Current serial number in output stream: 43

and command ‘cvt 3840 2160’ give :
3840x2160 59.98 Hz (CVT 8.29M9) hsync: 134.18 kHz; pclk: 712.75 MHz

Modeline “3840x2160_60.00” 712.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync

FOUND !!!
I had to change frequency !!
and type :

sudo xrandr --newmode “3840x2160_59.98” 712.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync

Frequency information found with : cvt 3840 2160

Strangest thing is it worked before at 60hz

Thank you @Aravisian because our messages made me go ahead :pray:

1 Like

Reference:

lshw -class display | grep “driver”

Do you have contents in /etc/x11/xorg.conf?

You might try changing the name of the mode to see if that jiggles the handle:

sudo xrandr --newmode “2160” 712.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync

The soluce below for future help :

Identify your port with :
xrandr

Result example :
DisplayPort-0 connected

Then type :
cvt 3840 2160

Result example :
3840x2160 59.98 Hz (CVT 8.29M9) hsync: 134.18 kHz; pclk: 712.75 MHz
Modeline “3840x2160_60.00” 712.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync

Then type :
sudo xrandr --newmode “3840x2160_59.98” 712.75 3840 4160 4576 5312 2160 2163 2168 2237 -hsync +vsync

and :
sudo xrandr --addmode DisplayPort-0 “3840x2160_59.98”

1 Like