5.40.48 kernel upgrade problem

Every time I run sudo apt-get update and sudo apt-get upgrade and install updates it always fails in zorin os 15 or zorin os 15.3 and it says something like this:

rm: cannot remove ‘/usr/lib/linux/triggers/5.4.0-48-generic’: read-only file system

dpkg: error processing package linux-image-5.4.0-48-generic (–configure): installed linux-image-5.4.0-48-generic package post-installation script subprocess returned error exit status

1 dpkg: error: unable to create new file ‘/var/lib/dpkg/status-new’: read-only file system

touch: cannot touch ‘/var/lib/update-notifier/dpkg-run-stamp’: read-only file system e: sub-process /usr/bin/dpkg returned an error code (2)

w: problem unlinking the file /var/cache/apt/pkgcache.bin - pkgdpkgpm::go (30: read-only file system)

Please make sure that you do not have any other Package Manager open and running, like Synaptic or Gdebi.

In terminal, can you please run

sudo mount / -o remount,rw

Then

sudo dpkg --configure -a

Then reboot and test your

sudo apt upgrade

EDIT: I made a mess of this post and am doing a do-over at this point.
If it is after installing the kernel, it looks like the installation may have been interrupted during the process.
Perhaps a power outage or other computer interruption.
Probably the best way to address this would be to boot into Recovery Mode.
Boot the machine and at the splash screen, start hitting the Left Shift Key. You should see a boot menu with “Advanced Options For Zorin” listed. Select that. This will take you to another Recovery Menu.
On this menu, arrow down to Enable Networking. Oncve enabled, return to that Recovery Menu and then arrow down to Run FSCK. Run FSCK to check for and repair errors.

hmmm… You are saying you have reinstalled Zorin several times, and that happens each time on the Upgrade without interruptions?
That is concerning. It may mean Hardware Failure. I would suggest testing your HDD and hardware, as well.

Well, let me ask you this: Does everything work normally and well on the kernel until you upgrade to 5.4?
If so- Is there any reason to upgrade to 5.4 at this time?
I would be very happy if your hardware is fine and that the installation is fine. If it is just the 5.4 kernel causing breakage, then it may be best to not use that kernel.
It is up to you if you would like to test the HWE ( Hardware Enablement) 5.4 kernel instead of the Generic 5.4 kernel. If you feel like you would like to try that, say so and we can walk through that process.

Otherwise, if you would prefer to wait until a kernel release compatible with your machine is available, you can use the apt-mark hold command to prevent the kernel from being upgraded when you do an upgrade or upgrade all other packages. In terminal, you can Hold the Kernel at current version with

sudo apt-mark hold linux-generic linux-image-generic linux-headers-generic

Possibly, or you can use the Recovery Mode outlined above to choose the Previous Kernel at boot.

Update Screenshot:

It looks like Windows is locking access to the drive. You are certain that Fast Boot and Secure boot are both disabled?

… and advanced (hidden) power settings in Control Panel | Power has the hard drive ‘Sleep’ mode turned off?

I’ve tried and like this:


I always disable fast boot when I want to use zorin. and at that time, it is in a state of fast boot disabled.

OK I will try it. I hope this works.

I just looked closely at your screenshots and the terminal UI says “zorin@zorin” which is the LiveCD account.
The installed User account would have the username you created during installation along with your Computer Identifier.
Are you running LiveCD as persistent?

I think the problem with the DPKG is not compatible with the 5.40.48 kernel. because when updating the DPKG without updating the kernel the problem is the same as above. different things happen when updating kernel 5.40.47 or before there was never a problem with the DPKG. when will the 5.40.49 kernel be released? I will try to use the kernel.

Running from LiveCD would not work for what you are performing, regardless. Not for this instance. You would want to run from the previous kernel. You can roll back your kernel if needed, if you have not already.
Or, you can roll forward. 5.4.0-48 is the currently released TESTED kernel, but the Linux kernel itself is up around 5.9 now.
Why not try the 5.5.0. kernel and see what happens? If it still produces an error, you can use the recovery mode to revert back to the previous kernel.

That all said, I find it very unlikely that dpkg is having and conflict with the 5.4.0 kernel. Very Unlikely, indeed. I suspect the problem is elsewhere and probably will seem simple in hindsight once we find it.

I think so too, maybe there is a problem somewhere else. i will try again. how to get to the 5.5.0 kernel? I don’t know much about linux. because I am only a daily user to complete school assignments. Thank you for the help. :slightly_smiling_face: :blush:. I am sorry, my English is not good.

Installing a kernel is generally the same as installing anything else that you root install.
There are just two things to remember:
The Linux kernel comes in four parts:

  • Modules
  • Image
  • Headers-Generic
  • Headers-All

So, when you go to get a Linux Kernel package, always be sure to get and install all four.
The second thing to remember is to update the system after you finish the installation

sudo update-initramfs

Now… Let’s look at how to install the kernel and where you can get your packages.
Here is the complete list:

Let’s look for 5.5 first:
https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.5.1/linux-headers-5.5.1-050501_5.5.1-050501.202002011032_all.deb

https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.5.1/linux-headers-5.5.1-050501-generic_5.5.1-050501.202002011032_amd64.deb

https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.5.1/linux-image-unsigned-5.5.1-050501-generic_5.5.1-050501.202002011032_amd64.deb

https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.5.1/linux-modules-5.5.1-050501-generic_5.5.1-050501.202002011032_amd64.deb

In order to stay organized and keep things simple, once you have downloaded each package, just create a new folder in your ~/Downloads folder named “kernel” and place all four of the above packages and only the four above packages in that folder.
Go into that folder in your file manager and open a terminal OR us the ‘cd’ command in terminal

cd ~/Downloads/kernel

Then use the command to install:

sudo dpkg -i *.deb

Then your update to apply new kernel

sudo update-initramfs

This spares you from trying to install each individually in the Correct Order. It also keeps the copy of the kernel in a safe and easy place you can find or remove afterward.
Your English is quite good. It is a shame on me that I speak only one language (Or at least only one actively used language).

1 Like

after i re-downloaded my zorin os then installed it, now i can boot in my new 5.51 kernel like never before. but such brought about problems:



this, made me not install any new software through the shop or terminal.

This reminds me of the CPU overclockers, and bikers who rev their bikes to over 7,500 rpm from cold. Or “Don’t fix what ain’t broke.” :wink: