(A7) Me FW - Downgrade - Request MeSpiLock Failed

OK I tried to install xterm as you suggest in your link but I get this ~
Screenshot from 2024-03-22 09-17-22
Also with the greatest of respect to you, the video you have posted runs through so fast I simply got lost and couldn't follow it.

I have downloaded multisystem, I've right clicked on it and selected "Extract here" then I found xterm in the software centre which installed without issue, I've right clicked on the file that was extracted and chose the option to open with another program but xterm is not in the list.

Try Terminal. If you install Synaptic Package Manager from Software, xterm is available via Synaptic Package Manager.

I tried following the tutorial I found here https://itsfoss.com/bootable-windows-usb-linux/
I downloaded the Windows 10 iso from the microsoft site, opened it with disk image mounter & copied all the contained files to a 64GB thumb drive that I had formatted to NTFS (I also tried it by formatting to FAT32) this time when I select the thumb drive in the boot menu it goes to a black screen with a static (not flashing) cursor top left, I have left it on that screen for at least 10 mins but nothing else happens. I also tried changing options in Bios from UEFI to legacy and secure boot on and off, all options fail to allow the windows iso to boot from the thumb drive. At this stage I'm completely out of ideas.

I've been reading that the drive should be formatted to FAT32 but that format system only works up to 4GB and the contents of the windows iso is almost 6GB so how does that work?
I'm getting so confused.

OK I have read up on this, I now understand that it's a limit of single files of 4GB so I would need to split the larger files, question is how do I do that & once they are on the drive in their split form would they be recognised or is there a method of stitching them back together. It seems from what I have read the drive does have to be fat32, the bios has to be UEFI and secure boot has to be off, so the question seems to be how do I get 6GB worth of files onto a drive that's formatted to FAT32............Or am I completely barking up the wrong tree.
Should I maybe just give up and put up with the downgrade error message considering everything works ok?

Have you tried using exFAT rather than FAT32?

For some reason when I formatted the drives exfat was not an available option, however I've now got a sort of solution to the issue,
I did a fresh install of Zorin & although the downgrade failed message appears very briefly on the first black screen (I assume this is bios) once it boots into zorin, there's no further messages on the desktop & to be honest I can live with that. I realise it will now always be present in bios as it was a bios firmware update that failed but it causes no issues (at least not for now) so it's not worth losing any more hair.
To be honest, it's the fault of the zorin developers that this has happened because they pushed a windows update to my system & that should not happen but there you go.

Firmware updates are manufacturer updates, not Microsoft nor Windows updates.

You even said this in the sentence right above:

My mistake, apologies to the Zorin dev's in that case.

There can be so many moving parts, it can be quite a task to figure out which is moving where.

But Zorin OS will not push Windows updates or packages since they do not have access to them. GnuLinux and Microsoft Windows are different and separate systems.

You cannot be faulted for thinking along these lines, though. Many BIOS updates are packaged as .exe or formatted with Windows OS in mind, due to Windows OS being the dominant User Operating System in the world.
And users may think that they can install a BIOS Update using Wine or Zorin WIndows App Support. But this also cannot be done since these applications are a compatibility layer, not System essentials. Doing such will likely break everything.

As these many moving parts communicate and align to a common goal (ensuring the end user is taken care of) things have been changing as issues are sorted out and trickle down the system: Firmware Updates are being released more Linux-Friendly and supplied to the Firmware Updates team. In our case, these come down from Canonical (Ubuntu) with the fwupd and fwupdmgr packages. The changing times are providing help to us GnuLinux users.

So, what went wrong with yours? I have no idea.
Looking into it, this can affect Windows and GnuLinux users alike and each manufacturer (Like Dell) only says that they recommend downloading and installing the latest BIOS update as a resolution to the issue. Not a lot of details are given as to what went wrong or how it did.

Yes I understand where you're coming from, still at the end of the day my system is working and working well so I will say thank you to you for your help and indeed to everyone else that helped, I am so grateful to everyone on all the various Linux forums that freely and gladly give their time to assist those of us with less knowledge.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.