(A7) Me FW - Downgrade - Request MeSpiLock Failed

Wasn't sure if I should put this in General or Hardware support but here goes,
I have recently come to Zorin from Mint but despite using Linux for a while now I'm still nervous of command line stuff so I was pleased to see the Zorin software app shows available firmware updates, so when it had an embedded controller update for my Thinkpad T480 I happily clicked the update button, unfortunately nothing happened & despite leaving the box open for over an hour the "install" button remained greyed out, only the cancel option was available so I cancelled thinking maybe I could try again later however when I rebooted the laptop before the OS loaded I had a message
"(A7) Me FW - Downgrade - Request MeSpiLock Failed" after which once the desktop had loaded a message popped up to say an update failed. Everything works normally however, it's just annoying to have these massages showing everytime.
I did some digging, I couldn't find a solution but I did read someone say it might be that this update may be pointing to a Windows update which is why it fails, that may or may not be true.
If someone knows of a way to solve this issue it would be great, there was another suggestion I read saying install Windows on the laptop download a new bios then put Linux back on afterwards, frankly that's far too long winded & I don't have a copy of Windows anyway. Looking on the Lenovo website it seems bios updates are for Windows only.
Any thoughts please. Thanks

Yes, Windows only, and that is because the hardware was manufactured to run ... Windows!

Give this a shot.

  1. Download Ventoy for Linux:
  1. Download an .iso image of Hiren's Boot CD - this uses a WinPE of Windows 10 in Live mode - try to update the BIOS this way by adding the .iso of Hiren's Boot CD to the Ventoy thumb drive.


When booting off the Ventoy thumb drive, enter your BIOS to change the Boot Order - you will see 2 entries for your thumb drive - a standard one and an EFI one - you need to choose the EFI boot option for Hiren's Boot CD to work.

Thank you for that information, I will give it a try but it will be a couple of days until I have time to do it.
I will post back here to let you know if it's been successful.
I'm grateful for your help.

OK here's where I am.
I have successfully created Ventoy on my 64GB Thumb drive & I have the Windows PE ISO from Hirensbootcd & copied it to the Ventoy thumb drive as described in the instructions. I then restart the pc & go to the boot menu & select the thumb drive, however it just returns to the boot menu again. There was something about enabling wimboot with ctrl+w but I don't understand at which point I am supposed t enter this command, also I have secure boot disabled in bios, should it be enabled or disabled. If you can help me to get past this point I would be so grateful, also if & when I do get it to boot what exactly will I see in this windows PE, is it like a live windows distro so I can open a browser to go to the web site of Lenovo to download a bios update for windows?
sorry if these are stupid questions but this is a little out of my comfort zone.
Many thanks for your efforts to assist me, I really am very grateful.

You may need secure boot enabled and after you have made the change, reboot into BIOS again and change the boot order to select the thumb drive with EFI and yes it is basically a live version of Windows 10 and comes with Browser.

OK thanks, I will give it another go.

I have enabled secure boot in bios, the thumb drive was correctly installed with ventoy & I've put the iso the the ventoy folder, the drive shows up in the boot menu but that's as far as I get....nothing else. What could I be doing wrong.

I am not sure an what is going wrong either, but I do know that recently, Microsoft made a change to Windows OS .iso's in which it is now a Windows installer program, instead of an Operating System .iso

Can you check if the Windows .iso you are using on Ventoy is actually a Windows installer instead of the OS .iso?

Hi & thanks for that information, to be honest I have no idea how I would find out if it's an installer although I will see what a search on the internet turns up. This seems to me like it's far more difficult to solve than I had hoped & maybe as the system is working fine I may have to put up with the message I get each time I boot up saying an update has failed, however I won't give up just yet but it's not looking good. Still enjoying Zorin though.
Thanks again

One thing I have found out is that the problem is not with the Windows iso as I have also put a linux iso on to ventoy and it won't boot that either, I should be getting a ventoy menu but I don't.
I feel it's something to do witha setting in bios but I dont know what, I have tried changing secure boot to on and off but either way it makes no difference so there must be something else.

It may be that something went wrong with the Ventoy installation.

I would wipe and format that USB stick just to ensure it is in the clear - then a fresh install of Ventoy where you can drag and drop .iso files onto it.

Actually I have done that a few times without any different results. Just out of interest would you recommend formatting to extfat or something else

I'm going to grab myself a different thumb drive tomorrow just in case it's the drive.

Yes, I would format to exFAT.

Thanks, I will try again tomorrow

I am wondering if, because you have not got an updated BIOS whether EFI is installed anywhere. This is what shows up in my BIOS if the BIOS is EFI enabled:

If using the Ventoy Linux installer, Ventoy takes care of formatting etc. :wink:

Well it is time for me to eat humble pie ... big time! I thought I had tried Hiren's Boot CD in Ventoy but it does not run! Where I do have it is on my MultiSystem USB drive:

So ignore Ventoy and download this .tar.gz I uploaded on the old forum which is archived here:


And follow my Video tutorial here on how to install and use MultiSystem:

If you drag and drop the HBCD iso onto the MultiSystem interface, then reboot, choose MultiSystem with UEFI and it will automatically boot into the interface as shown in the screenshot at the top of this post.

Be aware that when using Hiren's Boot CD, it defaults to US keyboard layout so if you need to use the @ sign you need to use Shift+ 2 and for the # sign you have to use Shift+ 3 if using UK (en-GB) keyboard.

Oops! Forgot you can change keyboard layout to your locale from the Desktop shortcut!:

1 Like

OK Swarfender, I will take a look at the link and try to follow the instructions, I will let you know how I get on.
I was about to post anyway, as I had decided to try using Balena Etcher, when I attempted to add the HBCD iso I got this ~

Yes Balena Etcher not good for a few things. My mainstay is MultiSystem 3 for USB. It was based on Ubuntu 16.04 and I fell in love with it because when you drag and drop an .iso into the interface it tells you immediately whether the .iso will run or not. Prior to this I was trying to use unetbootin which would only tell you of compatibility issues after 20-30 minutes of copying an .iso to unetbootin.