Access to a hard disk on the network

hi, I'm new here and also new to the Linux world. I am pleased to have Zorin OS version 16 installed on an old PC running Windows Vista.

I am now trying to figure out how to access a hard drive that I have shared on the network through the USB port of the router. Its access address is // and is perfectly seen by another PC (with Win10) next to it nd both are connected to the router via a switch. I have tried to read several guides but it seems that the network does not accept the SMB protocol.

I also insert a graphic scheme to understand. The PCs in question are PC1 and PC2. But in reality even PC3 and PC4 (both with Zorin OS) still do not have access to the Hard Disk.

Any idea how to fix it?

What method are you using to access it on Linux?

Have you tried this...

In the zorin file manger, in the folder list on the left, select "other location"(or similar), then in the address bar at the bottom of the screen type in:

"smb://" (without speech marks).

You may be prompted for credentials.

Good luck!

hello, thank for reply. Yes I did already. A message says:
:warning: Windows share could not be mounted: Connection lost due to software problem.

hi, thanks for reply me! I tried:
SMB - :warning: Windows share could not be mounted: Connection lost due to software problem.
FTP: asks for credentials, nothing happens than.
others: errors or nothing happen.

Is your firewall on? Try turning it off.

On your router - are there options for how th HDD is shared? I'm thinking SMB versions or NFS?

1 Like

firewall is off and there is no options to know how the HDD is shared. So I had a contact with the operator and we found out that this router is a too simple toy for my needs, so we agreed to receive a new model (a Fritz-box!) and it is already on they way. So, let's have a break until I will install the new router and see what happens :slightly_smiling_face:

Hi @padrino Can you please edit your forum profile to indicate which edition of ZorinOS you have e.g. Pro, Core, Lite etc. That will ultimately help us help you.

hi, I did it. I have 2 PC with Core edition and 1 Netbook with Lite.


I'm still thinking about this one.

You have two routers, and one has an address of whilst another is on

How are you connecting? Wifi or cabled?
I'm thinking things to look at might include:

  1. Do you have wifi isolation on (stopping devices from seeing each other)
  2. Do you have any firewall on the routers? Have you allowed the ports for SMB?
  3. What version of SMB is the router using to share the HDD? Some new OS's (Zorin) don't allow SMBv1, or at least you need to explicity turn it on / allow it.

If SMB is an issue, you could look at the routers documentation and see what other protocols are available.

hello, today I received new router (a ZyXEL) and I set it up. All problems are now fixed. I connected easly the HD via Samba. So the old router as got some incompatibilty with Linux machines.

BTW, to answer your questions. I use cabled. Firewall was only on router, deactivated in the switch. No possibility of information about the old router.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.