Accessing NAS through Samba share

Hello everyone. I'm trying Linux again after a couple of years. Zorin OS looks great. I do however struggle to connect to my Thecus NAS.
It has a couple of browseable folders that are public. So I can easily connect from my Windows install.
From Zorin it's not that easy. The Files browser sees the NAS as "N4200 (Samba)" but it will not connect when I click it.
I installed samba, it runs when I check with ¨sudo systemctl status smbd".

What am I doing wrong here? I want to be able to backup to my NAS and access the music and pictures on it.

Hi and welcome to the forrm :slight_smile:

I have no knowledge about this particular product, but I have a home-made NAS (Open Media Vault).
I can connect to it in the file manager (Nautilus) without any additional application. I can also connect to it through the browser interface as well.

Screenshot from 2021-12-13 17-47-49

title edited for clarification

Thank you for the reply. Did you do anything special when you installed samba to make it work?
I set the folders to 'public' on the Nas and allowed anonymous logins so theoretically I should be good.

I searched through my installed apps but I did not see any Samba related app in there :frowning:
You might have to wait for other volunteers to pitch in here to help you.

Or others may be more helpful; I have never used Samda. Zorin OS does not include Samba by default.

Was it?
How come I can access to my NAS?
I can access to it not only from Zorin but also from Mint which also does not have Samba.

I am not sure... I do not use Windows or a Home network - we are venturing into territories I have only looked at over the fence.


What do you see when you click on the plus sign in the left pane of file manager?

I did not include it in the previous screenshot.
But I do see Windows network is also listed - although I never use it.

Screenshot from 2021-12-13 19-00-45

Hello. I can see my NAS but when I click on it it just does not want to open it.
I enabled NFS on the NAS and tried to connect with the bar at the bottom.
Like this: nfs://
It searches for a while and then says mountpoint is not available...

I think you need to enable CIFS protocol in your NAS.
See my above screenshot?
It says SMB/CIFS

I had already enabled SAMBA/CIFS.
Somehow it works now. I created a new user on the NAS. Now finally I got a prompt when I clicked on the NAS. It is connected now.
THanks for the nice help. This is a nice forum.


I think I've finally figured it out :slight_smile:

This SMB/CIFS is a protocol offered by OpenMediaVault.

Since CIFS is already included in Linux, I can access to my NAS from Zorin without any additional apps.

1 Like

Good day not sure if this is helpful but it works out of the box.

Yes, it was exactly my experience. OOB.

I think the problem was that OP installed Samba on Zorin which was not necessary to access the NAS.

I was too quick to cry victory. After restart it will not connect again. I had it saved to favorites as smb://N4200.local/ but it gives me the same error message as before: "Could not retreive list of shared folders from server: invalid argument."

Connecting via nfs is als not working: nfs:// where that is the IP adress of the NAS. It says there is no mount point. Do I need to mount it via the terminal first?

Have you tried to disable the firewall configuration first.
See Settings and then Network.

For Linux, you should not need Samba (unless you are planning to connect Windows network).
I suggest you to uninstall it first.

That's because NFS tries to make a network connection during boot, while chances are the network components aren't fully started yet. You should change that something with the startup time of NFS, for example that the connection is made at a slightly later moment. With Samba (CIFS) this happens anyway at a later time and the network components have already started.

I'm going to pick this up this weekend and try to get it working. I'll post my findings.

1 Like