Accidentally removed efi partition

I was editing my usb but I mistakenly deleted my own system efi partition.
I have been able to keep my laptop turned on this whole time and will try to continue until solution.
I tried to follow this boot - accidentally deleted EFI partition, system is still running! - Ask Ubuntu but i cant understand and follow this step - Edit /etc/fstab so that /boot/efi will be mounted using the new UUID.

Please help ASAP.

Can i use timeshift to go back? will it recreate partitions?

Is this screen current - what you are seeing now in Gparted?

You can recreate your EFI partition using the remaining unallocated space. Be sure to format it as FAT32, size 512mb and set the boot flag.

Once done, you will need to reinstall Grub:

when i run
sudo grub-install --force --boot-directory=/mnt/ /dev/sda1,
it gives grub-install: error: cannot find EFI directory.

Did you boot from LiveUSB? Or are you still running in Zorin OS installed?

Uh no i am still in zorin installed.. I am scared to reboot laptop. is it necassary, if so ill do it.

Jayesh, let's back up a moment and check your Gparted.
Did you follow the steps to format your new EFI partition?
Screenshots can help.

If looking at a lot of steps is daunting - remember that you always ever perform one manageable step at a time. Don't rush.

this is how gparted looks after doing what you said.

i dont know why but esp flag comes along with boot flag when i select boot flag.

Ok the partition is confirmed present. Do you have a Live USB to boot into? IF not, you need to grab (download) an .iso and a USB stick and create one before you power down the computer.

I understand it is scary to power down now that grub is gone. But it is also the way to get it back.
Also - do you have a means of accessing the net and using the forum other than that machine?


Yes, i have wired connection and my phone plus another laptop to access forum.

while i am downloading the iso, would you take a look at my /boot, there is a dir named grub.

and this is inside the grub dir,

Correct - and that references the partition that has since been deleted. Which is why you are unable to reinstall grub from within Zorin OS as it will try to reference that partition that no longer exists. You must boot from Live USB to get a Fresh Read on the new mounted EFI partition.
Then install grub to the mounted EFI partition.

@Aravisian man, you really are a lifesaver. Thanks for helping out. Everything's back to normal.

1 Like

You were gone so long, I started to wonder...

I went to sleep after putting on flash, it was like 4am for me when we were talking. LOL.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.