Acer Aspire 3 A315 struggles to install any ubuntu (including ZorinOS)

Hi,

I have ZorinOS 15.3 installed on a few devices (desktop, laptop, etc)

I am trying to help a friend install ZorinOS 16 onto an Acer Aspire 3 A315. I have googled and searched and tried multiple things (I eventually found that you need to press CTRL+S in the bios to unlock the SATA mode option to change it to AHCI in a blog for installing Debian)

I have already solved multiple problems including the live disk not being visible (if the flash is made using balena-etcher as recommended here it doesnt work but if its created with rufus its fine)

Currently:

  • Secure boot is disabled (BIOS)
  • Fast boot is disabled (BIOS)
  • SATA mode is changed to AHCI (BIOS)
  • Fast boot is disabled (Windows 10) (tried disabling it with 2 separate methods both power options and when that failed with a reg key in cmd prompt)

However, the internal SATA drive is still not visible on the live disk install boot. sudo fdisk -l only shows loop0 and /dev/sda (the flash stick)

As can be seen in this other thread:

when the internal hard drive is not picked up, the installer defaults to the install medium (the flash stick) and any clicking on ('+', '-', or 'change') to modify the partition table of the selected device when the only device available is the read-only/locked install medium results in a crash. While the installer should have a check and instead display an error message when no drives are available instead of displaying the wrong device and crashing when you click on modify, that is not the problem.

The problem is that the hard drive is not visible. I have tried for 2 days and have run out of things to try to get the hard drive visible. I'm not even sure how to verify if the windows10 fast boot lock is indeed disabled.

Please advise as to what else i can try.

This is the first thing I would focus on. I the machine unable to boot into Windows?

It is unable to boot into windows .... but that is because of SATA Mode AHCI instead of Optium without Raid. By changing SATA Mode back to Optium without changing the rest of the settings I mentioned Windows boots just fine.

disabling Fast Boot (BIOS) should add a delay and display the POST and print a message that states: 'Press F2 to enter bios' (it doesnt affect windows from booting)

And disabling Fast Boot (Windows 10 Power Options) is supposed to stop Windows from marking the drive as mounted (and preventing Linux from seeing it) even when powered off.

These are two different settings for 2 different systems that do 2 completely different things. And neither of these settings should prevent windows from booting but they can interfere with installing a new OS.

Since the hard drive is not being detected during live disk and this is said to be a common problem if you fail to disable the windows fast boot (I'm not all that familiar with win10, i have refused to use it personally .... ever) so the fact that it can block linux from installing is pure hear-say to me so I'm just going on what i have read. I am guessing that even though i have tried to disable the windows mode in 2 separate ways its still active (i guess - since I cant see the hdd from live disk)

How do I check if the windows fast boot mode is actually disabled? What other things can prevent a harddrive from being detected by the live disk when the USB drive shows up (which means the south bridge drivers are functional and the SATA drives should be visible?)

Yes, exactly. If you have disabled it in power settings in the Windows Control Panel (Not BIOS), then it is actually disabled.
Therefore, since you say you have done that, we can discount that as a possibility.

I agree that SATA should be in AHCI, so let's discount that, as well, unless new and surprising information comes up.

If you could, boot into Try Zorin and then open a terminal.
Enter in fdisk -l
Note the /dev/sdX of the SATA drive you are looking for. Let's say for this example that it is /dev/sda
In terminal, enter in dmraid -E -r /dev/sda being sure to match the sda as the actual drive letter you saw listed in fdisk -l

If you get a confirmation asking to remove the RAID information, we may be on the right track.
Confirm to remove.

As already stated I have done fdisk -l the only results are loop0 (the ramFS the livedisk is mounted in - i assume) and /dev/sda (the 32GB flash stick the zorinOS iso is copied to in a 4GB partition)

there is ONLY /dev/sda there is no sdb or sdc etc
there is no 500GB device listed in the fdisk -l with or without any partitions

i cannot dmraid a device that is not there

I see your point.
You might check and ensure from the Acer Website whether your machine has the latest BIOS Firmware installed.
You might try installing using rEFInd to see if that "jiggles" the hardware read, forcing the Drive to become visible.

I read the thread and wonder if getting Windows to boot properly in AHCI might trigger the change you need.

Here's a method for doing that:

(1) Boot into BIOS, change SATA to Optium, and boot into Windows (you've said that this works to allow Windows to boot normally).

(2) In Windows, open Powershell (Admin) and run this command:

bcdedit /set safeboot minimal

This forces Windows to boot in Safe Mode on the next boot.

(3) Reboot the computer, F2 into BIOS, and change Optium to AHCI. Save and exit BIOS, and the computer will boot Windows in Safe Mode.

(4) In Windows, open Powershell (Admin) and run this command:

bcdedit /deletevalue safeboot

The forces Windows to boot normally (no Safe Mode) on the next boot.

(5) Reboot the computer and Windows should automatically start with AHCI drivers enabled.

At that point, see if the Live disk sees your hard drive.

I suggest this on a hunch that the problem might resolve if both Windows and Zorin are set to use AHCI. It is just a hunch, but it might be worth a try, since you've done everything else without resolving the problem.

1 Like

Does this machine have IRST or a raid array setup?

Sorry ...... forgot to mention that I updated the bios blushes

Link please.
(And instructions to achieve 'jiggle')

I'll give it a try, thanks

IRST?
No raid, its a laptop, single drive ..... raid is pointless
I do know its not the original drive, I do know it was installed by a proper technician, I do know the drive works for a windows boot.
I dont think any of those conditions would have an effect on the current situation

If you need the current partition structure or HDD make/model I can look it up for you.

temp

@tomscharbach getting windows to boot in AHCI mode worked, but the drive is still not visible in live disk, many thanks for the suggestion

That's too bad. It was a hunch, and nothing more. At least Windows boot is now working in AHCI, and that's some temporary benefit, I suppose, while you are working to replace Windows with Zorin.

Although the Acer Aspire 3 A315 comes in many different models (different processors and configurations), I did a "acer aspire 3 a315 linux does not see hard drive" internet search a minute ago, and this seems to be a frequent issue on Acer Aspire 3 A315 laptops. The issue does not seem to be specific to Zorin (it is showing up with Ubuntu, Pop!OS and other distros) but more general.

I'm going to take some time this morning to read the threads and see if I spot anything that might be of help.

1 Like

I'm aware its not just a Zorin problem .... hence the title.
Thanks for the help
I hope you find a thread I missed with a solution

Most of the posts state that ubuntu cant see the drive but other linux can (debian and archlinux are often mentioned) I just booted into an Archlinux live disk and fdisk -l is still not showing any other drives.

1 Like

I am using the same model laptop and it is fine for me.

1 Like

Ooooops. I didn't think about the title.

You've eliminated one path that I was going to suggest -- see what happens with Solus OS Live, which is an independent (that is, not Ubuntu-based, Arch-based, Debian-based, etc.) Linux operating system, built ground up on top of the kernel and which does not use Grub, which seems to be involved in the issue. I suppose that it might be worth a try, because booting Solus OS Live would eliminate both Ubuntu-dependency and Grub, but it looks like that is more likely to waste a half-hour of your time than bring us any closer to figuring out the issue.

I think that is probably unlikely, given the amount of homework you've done. The threads I've looked at so far are long on ideas, but short on solutions.

I assume you've seen this exchange:

I think that this falls under the "Don't try this at home ..." category, because the cure seems to be worse than the disease.

yeah ...... corrupting the bios
if it was a desktop i would try because bios reset is easy
i dont feel like disassembling a laptop without the correct special made custom tools to try and reach the flash bios jumper

1 Like

"This is what I needed to know. If this sleep mode trick works, there is a workaround to modify grub configuration so it will boot properly. The ubuntu forums have published this mod."

How nice of him to allude to some published grub mod, but not link to it, give any details or post the actual modification...

I've read threads on this issue until my eyes are crossing. I've read the Acer boards and the Ubuntu boards. The threads take all sorts of different directions -- Grub, RAID embedded on the SSD/HHD, Optane conflicts, Intel firmware issues, and so on -- but none seem to end up in a solution. It is beginning to look to me like the Aspire 3 A315 is locked into Windows somehow, but I'm reading a lot of not much, to be blunt. Most of the threads end in a blank.

At this point, I'm stumped. I'm going to let this rattle around in my head for a while, and see if anything comes out of the rattling.

Two bits of information might help the rattling turn productive: (1) the processor, and (2) the SSD/HHD. The first is available in Windows Settings>About, and the second should be available in the BIOS.

1 Like

Yup. But if the suspend/wake trick works (that is, @zaphrina is able to see the drive after suspend/wake), then we might be able to chase the mod down on the Ubuntu boards, and figure out what it is and what it does. But seeing the drive is one thing, screwing up the BIOS is another, as @zaphrina points out.

I wonder if following a line of inquiry into @sulthan's hardware/settings and comparing them with @zaphrina's hardware/settings might be a profitable line of inquiry. The fact that both are Acer Aspire 3 A315 computers doesn't mean much, because that line has been all over the place in terms of hardware specs -- Celerons, Intel Core i3, AMD A9, AMD Ryzen, for example -- and I suspect that the BIOS isn't common between the various hardware configurations. So I'm not hopeful.

It seems like trying the grub parameter would be the easiest logical step, rather than risking BIOS. If he grub parameter does not work, just remove it.
Perhaps it is a common one like pci=noaer or pci=nomsi, and that is why he did not bother mentioning what it was.

I've seen both mentioned in the threads, but Solus OS doesn't use grub, so I haven't touched grub in four years so I don't have enough knowledge to help with grub.

I will go back and look at the threads to see if I can find the mentions. Uh huh ... good luck with that, Tom.