Acer laptop will NOT operate unless the bootable USB stays permanently plugged in

I had no trouble with Zorin 16. However trying to install a fresh copy of Zorin 17 my Acer will not run unless the Bootable USB is plugged in. When I try running the OS without the USB plugged in. Laptop will not boot up. Until I plug in the USB, I can try Zorin without any problems, as long as the USB flash stays plugged in. If I try reinstalling a fresh copy, everything goes smoothly, until it gets to the final stage, remove USB and hit enter. It won’t boot up! Then the vicious cycle starts all over again.

Do you see any error messages on the screen or something?

Normally when a computer starts it looks for a device that it can boot from, and there are a series of pre-defined places that it will look at: the USB, CD/DVD (if there's any), any other external drives, the installed hard drive(s), etc.

The fact that it's not recognizing the installed hard drive may suggest the installation didn't go well. I've actually seen this happening with old device I also had with Z16, and I still haven't figure what caused it but I do get a message saying something like "no boot device found".

I still haven't tried it on my end but this post may be a solution:


Could it be as simple as changing boot order in BIOS setup? I know it's typical for the computer to look for the next bootable device, so it's logical to assume that when the USB is unplugged it would find the hard drive. But maybe your setup requires you explicitly change boot order in BIOS. Try making sure your hard drive is set to the first position in your BIOS settings.

While you're there, ensure Secure Boot is disabled. This could also be a culprit, I think.

Another thought that comes to mind is that your partition/sector layout might be set up incorrectly. Did you do a typical install, or did you elect to choose where you installed Zorin? If you chose where, it could be possible you didn't install the bootloader on the root partition. I think Zorin asks which partition you want to install the filesystem on, and then asks where it should install the bootloader. Ensure you selected the root of the partition/drive for the bootloader. It's also possible you installed Zorin on the USB drive itself, and not your hard disk.

You could also use Boot Repair while the Live USB is loaded. It may fix your problem without requiring you to make the choices.

All that said, if the issue still persists, as a last resort you might consider performing a fresh install and choosing what I think is called the "Recommended" installation. That involves little user input and doesn't require you to choose where you install things like the bootloader (if I remember correctly.) However, I say " last resort" because you probably want to save whatever other OS or data that might be located on the drive - and that process would overwrite it.

If you're a new user, Boot Repair might be the way to go. But if you still have Secure Boot enabled or another UEFI problem instead, Boot Repair won't help much.


That’s the other problem. It won’t let me in bios. Keeps asking for the key. I never assigned a password. My first guess was it’s the order in which the laptop boots itself and it’s starting with the USB and not the HD. It was a fresh copy. I had it erase the HD before installing. It’s a mystery because I had no problem a year ago installing Lite. I can’t even go back to Lite

What do you mean by "key"? As in, you start the BIOS after pressing Esc, or a function key, and it asks you for a password? Or, are you able to get in BIOS, but when attempting to change a setting, it asks for a password. Can you take a picture with your phone and show us?

1 Like


Also, opening up a laptop is a delicate process and some may not be comfortable doing cracking the case. But it may be necessary in your case if you ever want to enter BIOS again.

I think my HP laptop allows clearing the CMOS by simply holding down the power button for an extended time (like a hard-reset, but longer, e.g. 15-30 secs). I say "think" because when this happens, and the machine is powered back on, I get a CMOS reset screen. Not quite sure if it's a full CMOS reset though. You could try it, won't hurt anything. I would also unplug from the wall during any CMOS reset process.

Are you able to boot - enter your BIOS Settings with the appropriate F key (e.g. F10) and then see a Security Tab in your BIOS Settings?
Does the Security tab have any passwords enabled?

I'm totally lost here. I've never seen a Boot Option menu where one of the two options is "Yes". I also want to say it's odd for the BIOS to yell at the user when the password check fails. :thinking:

@ChefMark - What exactly was the last thing you did before you were asked for a password. As in... what did you select before the password prompt appeared. Aside from what Aravisian asked you, are there any other F keys or Esc or Del which bring up some sort of menu or option after booting? If so, please explain what each key does when you press it on startup.

1 Like

If it's a laptop, they often today don't have a CMOS battery... the main battery also maintains the CMOS settings. So removing the main battery will reset the CMOS.

I found this out empirically... my HP laptop with main battery removed reverts to UEFI defaults. I run it with the battery removed (until I can figure out how to do SoC limiting), so any power loss would cause a CMOS reset, but I've got a UPS, so I'm relatively safe except for long power outages that drain the UPS battery. Even then, it's pretty easy to reset the UEFI settings once power is restored.

To 'crack the case' on your laptop, get an old, expired credit card, use scissors to cut off about 1/2" of it, then wedge it into the crack between the two halves of the laptop shell and wiggle it along to release the little plastic clamps.

I discovered this yesterday when I opened it up and found no cmos I disconnected the battery for awhile, but it didn’t resolve the password problem. I’m about ready to chuck this cloud book into the trash.

If you are able to boot from USB... Have you yet tried booting the LiveUSB of Zorin OS, then running Boot repair?

Just found this:

" Method 3: Recover Acer BIOS Password Using the Manufacturer Backdoor Password

Some computer manufacturers build in backdoor passwords for their own technicians to use so they can access the BIOS when the hardware is being serviced. So if the BIOS password was set by the manufacturer, you can look up the BIOS manufacturer to see if they use a standard password. However Acer seems to refuse to assist customers with BIOS password issues unless you send the laptop to them and paying a $100 fee."

Source: How to Reset or Remove BIOS Password on Acer Laptop

Check these out:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.